1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Could not start the windows firewall/internet

By rp748 · 50 replies
Oct 23, 2004
  1. I cannot start the Win XP sp2 firewall.

    When I try to enable it I get the following message:
    "windows firewall setting cannot be displayed because the associated service is not running. do you want to start the windows firewall/internet connection sharing (ics) service?"

    when I click yes, I get this message:
    "windows cannot start the firewall/internet connection sharing (ics) service."

    when I try to start the service manually this msg appears:
    could not start the windows firewall/internet connection sharing (ics) service on local computer.
    "Error 10047: an address incompatible with the requested protocol was used"

    I am running a Compaq laptop Presario 700 (AMD Duron 1.10GHz, 240MB RAM) on winXP home SP2
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    Welcome to TechSpot

    From what I have read about it, XP's firewall is still not what it's supposed to be.
    You are better off, installing a free program such as Sygate's Personal Firewall, Agnitum's Outpost or Zonelab's Zonealarm. Either program will do a better job than M$.
    I agree that this fixes only the symptom, not the problem. But XP SP2 has caused so many problems, this may well be one (more) of them.
  3. rp748

    rp748 TS Rookie Topic Starter

    thank you real

    As you said, this fixes only the symptom.
    I would like to be able to use ICS.
    One more thing, which i am not sure if it is related, the IPSEC service can not be started as well with this error msg:
    "the ipsec services service terminated with the following error: the requested protocol has not been configured into the system"
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    I don't know XP, (use Win2000 myself), but is your TCP/IP installed?
    Do you have any connection (modem or cable) to the WWW?
  5. rp748

    rp748 TS Rookie Topic Starter

    yes i do have connection to the web.

    i have tried this option but with no success:


  6. rp748

    rp748 TS Rookie Topic Starter

  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 3,874

    Thank you for posting your solution for others to be able to use in the future. I hope to see you around TechSpot ;)
  8. Chuckk727

    Chuckk727 TS Rookie

    Cannot start Windows Firewall due to error 10047

    rp748: I have the identical problem that you reported in October (23rd) . Did you ever find a solution for the Firewall??? My problem started when I downloaded and installed the new Microsoft AntiSpyware.
  9. rconesa

    rconesa TS Rookie

    I just had the same problem since Microsoft AntiSpyware installation.
    rp748 sugestion solved it (netsh winsock reset)
  10. moshe832

    moshe832 TS Rookie

    thank you for the solution

    thank you for the solution
  11. bibangie

    bibangie TS Rookie

    thank you rp748
    Thank you for this, it worked perfectly.
  12. myers18111

    myers18111 TS Rookie


    Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service.

    Perform the following steps in XP SP2 if you get the above message when trying to activate its new firewall.

    1) Reset the Winsock.
    --a) Go to the command prompt.
    --b) Type the command "Netsh winsock reset" (without the quotes), and press <enter>.
    --c) This won’t take effect until after you re-boot in step 4.
    2) Install and run a spyware removal program.
    --a) Two free ones are:
    ----i) Spybot Search and Destroy.
    ----ii) Lavasoft’s Ad-Aware.
    --b) I prefer Spybot S&D myself. :) (not a plug)
    --c) Some spyware programs won’t let you activate your firewall, for obvious reasons.
    3) Make sure the ICS (Internet Connection Sharing) service is set to start automatically.
    --a) Go to the Control Panel.
    --b) Double-click “Administrative Tools”.
    --c) Double-click “Services”.
    --d) Scroll to the bottom of the list; double-click “Windows Firewall/Internet Connection Sharing (ICS)”
    --e) Make sure the Startup type is set to Automatic.
    --f) Click Apply, if needed.
    --g) Click OK.
    4) Restart your system.
    5) Your firewall should now be up. Check it by going to the Control Panel.
    --a) Double-click the Security Center Icon (new with XP SP2).
    --b) The firewall section will be green and say “ON”.
  13. sayce

    sayce TS Rookie

    solution of the problem

    solution of the problem
  14. Miss_Wizzz

    Miss_Wizzz TS Rookie

    :approve: Thanks a bundle Meyers, appreciate the easy explanation of how to fix this nagging prob i had for a bit there :)

    Have a great day!!!
  15. thekent

    thekent TS Rookie

    ICS still not working

    I have done your suggested steps of reseting the winsock, cleaning the system of spyware. I already had Zonealarm installed and working, but I can't not access the sp2 windows firealarm. I want to access it and disable it.

    I am getting an error that reads:

    Error 1075: the dependency service does not exist or has been marked for deletion

    Any suggestions?
  16. tony_34

    tony_34 TS Rookie

    could not start the windows firewall/internet
  17. windstrings

    windstrings TS Rookie

    I had the same error message... I found that while monkeying around in my services... I turned off the "event log" that killed my ics and firewall and make me invisible on the network....
    I run win sp-2 with all the updates.

    Go to control panel, administrative tools, services and look at "event log" rightclick on it and go to properties.. make sure the startup type is set to automatic.

    Thats what got mine back!....everything works now!... it warned me when I origianally turned it off that the service could not be stopped... I found it amusing that I was able to disable it nevertheless..... I guess they were right!.. that is, if you want everything to work right!
  18. t1hawkins

    t1hawkins TS Rookie

    Try this one guys

    cannot enable firewall service after spyware removal

    seems to occur in conjunction with microsoft antispyware

    error 10047: an address incompatible with the requested protocol was used

    if you get this problem, open a command prompt and type:

    netsh winsock reset

    reboot, and you will get your firewall back
  19. BrazilianRogue

    BrazilianRogue TS Rookie

    Um... i've gone through al the steps suggested (including the one provided by windstrings) and still get the same error message.
  20. hurls61

    hurls61 TS Rookie

    Windows Firewall Partial Understanding

    This is what I found about Windows Firewall. I too have the problem of not being able to turn on Windows Firewall. I attempted to rest and or turn on the firewall via the command prompt and though the indication was that the firewall reset and or was turned on, I always have an off indication in the Windows Firewall dialog box. What I did discover is the hyperlink at the bottom of the dialog box indicating ‘What else should I know about Windows Firewall?’ When I click on the link it takes me to the Help and Support Center What Is Firewall information. Again at the bottom is a Related Topics hyperlink. If you click it you have two options. Select Turn Windows Firewall On or Off. In the Windows Firewall On or Off description there is a Warning after step 2. This warning identifies one main reason for not being able to select the On (recommended) option in Windows Firewall. If you select the advanced tab while viewing Windows Firewall the indication should show that you have option/s selected and that the firewall is enabled for those programs. Hope this in part helps.
  21. neeraj

    neeraj TS Rookie

    for this issue
  22. dlcsr

    dlcsr TS Rookie

    i have the fix for everyone probably. i had the same issues. i uninstalled update 905414 and everything now works fine. hope this helps.
  23. WillPower

    WillPower TS Rookie

    trying to start win xp firewall

    I've been reading through this thread and it sounds completely relevant to what i have been experiencing. I have tried to get to the command prompt by going to start>run>"cmd", however, the command prompt box is just opening and closing out again to quickly for me to type in the suggested command to fix the problem. what should i do?
  24. jsharkey3615

    jsharkey3615 TS Rookie

    Firewall won't start/ICS won't either

    If your problem is the same as mine. You also cannot see your Network connections in the Network folder or on the taskbar. They work, you just cannot view them. I tried all of the different solutions both on Tech boards and from Microsoft support sites, none worked. I finally found this site.
    This is the second time that I have encountered this problem and this solution fixed it both times.
    You have to rebuild the WMI Repository (Windows Management Instrumentation). There are two methods to do this on this page, I tried both, the comprehensive towards the bottom worked both times. You just need to insert your XP install CD, run the script on this page at the command prompt, it will ask you to point to your disk, point to the I386 directory on your disk and let it run. After this, my firewall worked again. ICS worked again. The second time this happened, I had to restart the "Network Connections" service to see my network connections, both in the folder and on the taskbar. The first time this happened, the service restarted without me having to manually do it. Hope this helps. I sent the URL and copied the text on this page to myself in an email. I found it in about an hour the first time this happened. Took me nearly 6 hours to find the solution this time, so I don't want to lose this info again. Anyway, let me know if this works for you all, some of your error codes are a little different than mine.
  25. swingster780

    swingster780 TS Rookie

    had same problem.. this worked for me

    when i had same problem. i found out that a program i had just downloaded and installed from limewire (in this case a spysweeper program) had caused the problem. it had disabled my firewall and caused other problems with sound card drivers. once i removed this program everything was back to normal. Anyone having this problem might want to think about recent downloads that might have been sketchy and try deleting them.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...