Direct X problems

By Pazz ยท 15 replies
Feb 24, 2002
  1. Direct X problems, crashes

    I think Ive messed up my Direct X under win98se,
    I think I may of installed version 8 when I was installing when I already had 8.1

    I cant get my games to work, they just crash as soon as I start them. With Swat 3 I now get ( DDERR_GENERIC ) error message and then it crashed back to DT.

    Is it possible to Un-install Direct X so I can then Re-Install 8.1.
    I tried to Install version 8.1 again but it made No difference.
  2. TS | Thomas

    TS | Thomas TS Rookie Posts: 1,319

    DirectX doesn't allow itself to be updated by an older version of it. Might want to try changing/reinstalling your graphics card drivers instead.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I won't say it is impossible, but the chances of your graphics card or drivers being to blame is much greater than Direct X

    Direct X does screw up from time to time, but generally it is a game or driver issue. If you have an old graphics card or old drivers not specifically designed for 8.1, then this is likely the problem.
  4. Pazz

    Pazz TS Rookie Topic Starter

    Its all working again!!!!!!!!!!!!

    Thanks Guys for your replies,
    in the end I did the "quick" install of win 98 sort of over the top of the previous one so I didnt loose everything,
    then I ran system file check and I had to install two missing files and now everything is back to how it was ALL my games work again, Im not a tech wizzard but it worked dont know how!!!,
    while Im here I noticed when u run regedit that there are
    LOADS of entries for games that I deleted ages ago;
    shall I just leave the entries there or shall I delete them,
    anyway thanks again for getting back to me!
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Good to hear that everything is back to normal!

    Hope to see you sticking around the forums too. Just because your problem was solved, doesn't mean you can't help others too!
  6. navyslug

    navyslug TS Rookie


    i just bought swat3 and it keeps closing and saying DDE I now get (DDERR_GENERIC) how do i fix it? plz reply ASAP thnx
  7. Joe Koolio

    Joe Koolio TS Rookie

    i have the same problem with 9.0c

    i have the same problem with 9.0c but it was just missing a file called qasf.dll wich is very strange considering i test products for the direct x company and i don't even know what to do
    :suspiciou :confused:
  8. jethomas1955

    jethomas1955 TS Rookie

    DirectX problem

    Here's one for you: I recently purchased the upgrade to Corel Paint Shop Pro 11. When I attempted to load it, I was told that the program needed DirectX 9 or later which my computer did not have. When I checked, I found had DirectX 9.0b. I tried to update to 9.0c, but nothing happens. I did notice though, that when I ran 'dxdiag' it lists two versions of the system.dll file. I can't find where these files are located, or how to correct the issues so 9.0c will load. Any ideas?
  9. Jazrice

    Jazrice TS Rookie

    I'm have a Direct 9 problem I'm trying to play the sims 2 and I can't cuz of the problem Please help!!! I have an XP home edition 2002 Service pack 2 Intel(R) Celeron(TM) 1300MHz 1.30 GHz 384MB 0f RAM
  10. jethomas1955

    jethomas1955 TS Rookie

    Direct X problem

    Well, I ran across a solution that worked for me. I found it through a friend at: At this site I found these instructions:

    Wed Jun 29, 2005 6:07 am

    Well it worked for me anyway.

    You need both the 9.0b and 9.0c full versions. both around 30Mb each. Unzip both to respective temp folders. then copy and paste the following from 9.0b to 9.0c:


    next you need a direct x uninstaller. i used dx eradicator from, bu there are plenty around

    once done simply run dxsetup in the 9.0c version (which would be the one you copied before right) and it will install using the files from the folder it is in. and there you go you have installed directx 9.0c.

    pls email at to tell me if it worked for you, since i wanna know if i fluked it for sum crazy reason

    Happy playin, and of course I take no responsibility if anything happens to your system (I have to say that dont I) due to using this fix. Im still happily playin and since the original post i made i have had people email me saying it works for them to without problems.


    The only part of this that didn't function properly was the part about using a direct X uninstaller. I tried to find and use the one mentioned however that particular program wasn't there, however, there are several other programs listed so I "picked one" (I really don't remember which one I attempted to use) but when I ran it, I got an error message stating that my version of Windows was not supported, even though it "touted" all versions of Windows was supported (go figure). Anyway, I went ahead and ran the direct X 9c (from the "modified" folder) installation and it "took". I now have 9c that actually shows up, and my program installed with no problem. I would just like to know how someone figured out that you had to use the 9b engine and .dlls in the 9c folder. Good on them!

  11. 123456

    123456 TS Rookie

    I have windows xp home edition. I brought The Sims 2 and I installed it, all went well, I do have a video card, but, when I try to play the game, this message appears..."Failed to find any DirectX 9.0c compatible graphics adapters in this system! Please make sure you have DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer. The application will now terminate."

    My video card manufacturer: VIA/S3G
    Card name: VIA/S3G UniChrome IGP
    Total memory: n/a
    Monitor: hp m703 Colour Monitor

    I have looked on the manufacturer's website, I dont know if you can put DirectX 9.0c on my video card. Could someone please tell me how to fix this problem and, do I have to buy a new card? I really dont want to because they are expensive.
  12. kpo6969

    kpo6969 TS Maniac Posts: 710

  13. lilzeeker

    lilzeeker TS Rookie

    I recently got sims 2, and every time I try to start it up it says failed to find any directx 9.0c compatible adapters, I have directx 10 but it still won't let me play. I tried doing what people say, and it says I need display memory, what do I do?
  14. Frostie1337

    Frostie1337 TS Rookie

    some one help

    I keep getting the error where it says you havent got DirectX 9.0c when you have. I am trying to get on world of warcraft but it fails :( i have tried
    Run: dxdiag
    and i do have directX 9.0

    i have a Radeon 9600 PRO

  15. roicks

    roicks TS Rookie

    I can't install DirectX

    When I try installing DirectX i get a "cannot connect to database" error and the installation stops. Anyone have any ideas?
  16. dark123

    dark123 TS Rookie

    hello guys
    Minimum System Configuration

    1.2 GHz Processor
    256MB RAM
    DirectX 7 capable graphics card
    Windows 2000/XP/ME/98
    Internet Connection

    Preferred System Configuration

    2.4 GHz Processor
    512MB RAM
    DirectX 9 capable graphics card
    Windows 2000/XP/ME/98
    Internet Connection
    for cs source

    i got this
    pentium(R) 4 CPU 2.80GHz
    2.79GHz 512 MB of Ram

    and for world of warcraft i keep disconnecting how come and i got a wireless adapter i use linkey
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...