DirectX 9.0c compatible trouble, please help

By Me0729 ยท 284 replies
Sep 25, 2004
  1. becca.hardcore

    becca.hardcore TS Rookie


    i already had the Sims 2 University on my computer, so i know that i have everything i need, but i accidently deleted it [long story] and i have since reinstalled it. but when i try and play it, it complains of a problem with the DirectX 9.0c Compatible Graphics adapters

    it has never said anything like that before, what should i do?
  2. becca.hardcore

    becca.hardcore TS Rookie

    i think i got it to work :S

    i just restarted my computer, and it seems to be installing a graphics adapter :S

    i hope this makes it work =]

    thankyou to anyone who took time to read my problem though =]

  3. cindylovesims

    cindylovesims TS Rookie

    I have played Sims 2 Deluxe on my computer before, but now that I added Sims 2 Open For Business Expansion Pack, it gives me that message about DirectX 9.0c. I have the Mobile Intel (R) 915GM/GMS, 910GML Express Chipset Family. I read the first and some of the last page of this thread, please let me know if you need more information. Please help, I wanna play my sims!! ;)
  4. ajhollowood

    ajhollowood TS Rookie

    Please help!!

    I know nothing about computer's except for the basics. I got my computer in 2006 and I have been playing my Sims2 games on there since I got it up until a few months ago when I got this message:

    "Failed to find any DirectX 9.0c compatible graphics adapters in this system! Please make sure you have a DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer. The application will now terminate,"

    I have a Gateway GT4010
    Microsoft Windows XP
    AMD Athlon 64 Processor 3500+
    2.2 GHz 2000 MHz 512 KB L2 cache
    nVIDIA GeForce 6100
    Double Layer 16x Multi Format
    1024 MB DDR
    dual channel memory
    200 GB HD
    7200 RPM with 2 MB cache

    All of this was on the front of my computer. I don't know what any of it means. Please help me as I am lost for what to do. I am going nuts not being able to play my games!! :confused:mad::(
  5. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    easiest way for us to see what you have is go

    Start -> Run -> type dxdiag -> hit enter

    After it's done click Save All Information -> attach the generated file here

    [​IMG]Attach the requested logs
    • ONLY attach .txt or .log files, that mean NO .doc or word files
    • We prefer you to attach the logs into the thread, but if you have trouble with that, you are permitted to copy and paste them into your thread
    • To attach a log click on New Thread (or use Post Reply in an existing thread).
    • Scroll down until you see a button Manage Attachments. Click on that and a popup-window opens.
    • Click on the Browse button, find the requested log file, and doubleclick on it.
    • Now click on the Upload button in the popup. When done, click on the Close this window button.
    • Please Note: you can attach more than one file to a post by repeating the above steps.
  6. bklo

    bklo TS Rookie

    i got the message "Failed to find any DirectX 9.0c compatible graphics adapters in this system! Please make sure you have a DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer. The application will now terminate" after trying to start up my sims apartment life. this is weird because i've played the game on my computer just last night and it worked fine. also my catalyst control center keeps telling me that the command interface encountered a problem and needs to close. any relation between the two? how do i fix this? tried restoring my PC and it didn't work. my display adaptor drive is an ATI mobility radeon hd 2600. please help! much appreciated :)
  7. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    Make sure in that you graphic is well connected, check it in device manager and check it is working well. If everything is ok then have you updated you Catalyst recently?
  8. bklo

    bklo TS Rookie

    Catalyst installation tells me that the setup will now terminate because apparently it cannot find any compatable driver for my hardware or system?? also device manager doesn't see anything wrong with the device.....
  9. nicolette5683

    nicolette5683 TS Rookie

    I am having the same problem, and I attempted to find the listed components as you described, however once I got into "Device Manager" there was no category 'Display Adapters'
    I had the Sims2 program on my computer before, and there was no problem, then I needed to do a system recovery because my computer crashed. I was told by the people at Gateway that the recovery program in my computer would automatically reinstall all of my programs and have since been no help. Any answers please?
  10. finnions101

    finnions101 TS Rookie

    not correct

    i have an ati radeon hd2400 pro with driectx 10 support, pixel shader 3.0 etc. and 256mb on it this is on the recomendadtions list for the sims 3 letalone the sims 2. so the card isnt the problem. theres something else. and when i try to reinstall it, it wont let me. i click uninstall and i get an hour glass for like 5 seconds then it dissappears and nothing happens after that. so im guessing if the ****ing software was actually good and i could uninstall it, and reinstall it, the problem would be solved. can anyone help me with a manual uninstall process?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...