DRIVER_POWER_STATE_FAILURE (9f) please help me

By Papaija ยท 5 replies
Nov 20, 2007
  1. I am new here so i apologize in beforehand if my grammar is bad, i seem a little rude or my descriptions are not very clear..

    So i've been getting this error message thingy lately after turning my computer on and i can't turn the computer off without holding the power button, it just stays in the "shutting down" screen.

    This started after i uninstalled quite a few programs including Norton antivir without restarting and clicked then the "install updates and shutdown" (latest Vista update) orwhateveritwas button. Next time i turned on my computer it said that the computer couldn't be started and asked if i want to restore it to the moment when everything was okay and i did. All the programs were still there and the update wasn't installed. I thought everything was okay until i tried to shut down the computer. After over 15 minutes of staring at the "shutting down" text i just manually shut it down. After loggin in an error message was there. I tried to look for solutions but the window just disappeared. This has now happened many times. Also i can't wake my computer from sleep, it just freezes.
    I did some research (google) and ended up trying to understand the minidump file. By now i know only that it should be driver(s) causing problem..
    The only sensible part for me was this.

    A driver is causing an inconsistent power state.
    Arg1: 00000003, A device object has been blocking an Irp for too long a time
    Arg2: 82d7d1d0, Physical Device Object of the stack
    Arg3: 87180030, Functional Device Object of the stack
    Arg4: 83417318, The blocked IRP

    Well, i checked if i have any unsigned drivers which could cause the problem and there was one.. xrwcxst0.xst. I haven't got a clue what it might be or what i should do now. Im already panicking. I can find similar cases but they're well.. still different. So what im asking is help as soon as possible.

    Oh yeah... I have an Acer TravelMate series 5510 (5512AWLMi) with Vista Premium. The dumpfilethingy should be attached..
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If Vista has a repair feature like XP does, try performing a Vista repair. Don't use the restore feature. Programs that you have removed are no longer there and a restore will try to enable a missing program.

    Your only other option is a clean install of Vista
  3. Papaija

    Papaija TS Rookie Topic Starter

    Some evolvement in this case. I unistalled many many programs again and shut down the computer. Again i had to turn it off manually, but this time after logging in the error message didn't appear. Im not sure if this is good or bad but at least it's well.. progress in way.
    Im trying to avoid clean install (or the thing that restores it to the state it was in when i bought it) of Vista.
    It read in the dumpfile that the cause of this problem is Hamachi which was now one of the programs that i uninstalled. Still the problem exists and i don't get any more info about it :/
  4. Papaija

    Papaija TS Rookie Topic Starter

    Okay.. now i know at last the drver causing my problems. It's rtnicxp.sys also known as Realtek RTL8139/810x Family Fast Ethernet NIC. The only problem now is that i don't know what to do. I can't seem to find any updates. Does anyone know any simlar cases or something that could help me?
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

  6. Papaija

    Papaija TS Rookie Topic Starter

    Actually i just solved my problem.. by just pulling off the ethernet cable thingy and restarting a couple of times :D i just have to use wireless net
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...