Error: Couldn't find place for swap file

By elegant5_dude ยท 7 replies
Jun 30, 2008
  1. I am trying to install Windows 2000 Professional on 150 GB "SATA" Hard Disk by making 3 partations of 50 GB each.
    When am trying to boot with the Win2k Pro. Bootable CD,it's giving an Error "AN INTERNAL ERROR HAS OCCURRED.COULD NOT FIND A PLACE FOR A SWAP FILE.SETUP CANNOT CONTINUE.PRESS enter TO EXIT.

    Please somebody tell me the solution for my problem.

    I'll be Thankful & Appreciate for your help.
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Format then partition?
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Have you set the CD as the first bootable drive in the bios? Also I think CCT is suggesting you try formatting the partitions after partitioning, but that is normally not necessary - how did you do the partitioning ? with FDISK?

    Also in the mists of time I seem to remember you cannot use large drives until you have reached SP3 of Win2K. Possibly the solution is clear the HDD down completely (no partitions), then boot off the CD and see what the install makes of it. It may only use part of the HDD, which is no problem because after updating to SP3 you can then carry on, partition and format the rest of the drive.

    I found this in my notes - (forgive me, copyright owner !)

    Requirements: 48-bit LBA compatible BIOS or PCI ATA controller card which supports 48-bit LBA.
    Windows 2000 with Service Pack 3 or greater installation CD.
    3rd party partition utility like Partition Magic or Partion Expert.
    EnableBigLba value added or changed in Windows registry.

    48-bit LBA compatible BIOS or PCI ATA controller card. The BIOS must support 48-bit LBA. To test your system's BIOS for 48-bit LBA, refer to our HDInfo tool. Alternatively, you can connect the 48-bit LBA hard drive to a PCI ATA controller card which supports 48-bit LBA devices.

    Windows 2000 Service Pack 3 or greater. The Windows 2000 install CD must include Service Pack 3 or greater and labeled "Including Service Pack 3".

    3rd party partition utility. When doing a new install of Windows 2000 with Service Pack 3 from the installation CD, the setup program will only allow you to create a single partition up to 131 GB even though 48-bit LBA is supported with Service Pack 3. This is a problem if would like to use your 48-bit LBA hard drive at full capacity with a single partition. You can solve this problem by using a 3rd party partition utility after Windows 2000 is installed to resize to full capacity the 131 GB partition originally created during the install. PowerQuest Partition Magic and Acronis Partition Expert support partition resizing. Unfortunately, you cannot use any of the partition utilities provided by the hard drive manufacturers as none of the applications we tested support partition resizing.

    Alternately, if you do not have access to a 3rd party partition utility, once Windows 2000 Service Pack 3 is installed, and EnableBigLba added and set in the Windows registry you can use the partition utility provided by your hard drive manufacturer to create a new partition from the space leftover after Windows install created the original 131 GB partition.

    EnableBigLba value added in Windows registry. With Service Pack 3 or greater installed to Windows 2000, 48-bit LBA support in Windows 2000 is not enabled until the registry value EnableBigLba is added and set properly in the Windows registry. Unfortunately, Windows 2000 SP3 install does not add and enable this registry value properly by default.
  4. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    Best i can do

    Installing SATA drives is not as easy as IDE.You have to install the RAID drivers
    from a Floppy.You need the motherboard manual and cd containing Raid drivers to copy to floppy,Do you have these ?
    Best done by a Technision.Cost me $ 25.00.
  5. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

  6. elegant5_dude

    elegant5_dude TS Rookie Topic Starter


    Guys...i myself solved the problem.
    i just tried several options like re-partition hard disk several times,format had disk by several methods & in that process i tried to replace the Operating System CD & you don't believe works & till now working very well & faster.

    anyway..thanks everyone who came to help in my problem.Appreciated the way you guys responded quickly.

    Ba Bye :wave: :wave: :wave:
  7. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    You're saying it was an old install CD that could not be read?
  8. elegant5_dude

    elegant5_dude TS Rookie Topic Starter

    Yes...Exactly !
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...