External hard drive driver suddenly 'not installed'

By MD3000 ยท 41 replies
Dec 15, 2013
Post New Reply
  1. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

  2. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    Rest assured EClyde, I am very grateful for LookinAround's help on this, and the original post. I trust your reference to wasting valuable bandwidth was self-deprecating.
    LookinAround likes this.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    @EClyde and @MD3000
    Thank you both for the kind words. Glad to try and help :)

    @MD3000 re:
    By default, Windows hides certain files and folders (dllcache is a hidden folder). There was a hyperlink in post #24 on how to "unhide" things. But no problem since you still managed to find it on your own. (good work, by the way ;))

    re: msvcrt.dll vs msvcrt
    That's Windows hiding things again! (I forgot to provide a link that time but, again, you got it right (y)). fyi.. By default, Windows also hides extensions of well known file types. IMO Hiding extensions makes it easy to miss things. I keep that option turned off. http://support.microsoft.com/kb/865219

    Now back to the problem.... Dang! I though it would be a file version problem. I have one more idea to try. Windows has a "dependency checker" tool. I'll post back later with instructions so we can try it
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Download the x86 version of Dependency Walker
    > Change the Unzip to Folder box to unzip to C:\Depend
    > Click Unzip then Close

    If Teamviewer is running, we need to stop it first. Right click on its notification icon click Exit.

    > To run Dependency Walker double click C:\Depend\Developer\drop\dependsx86version2.1.3623\depends.exe

    > Click File->Open navigate to C:\Program Files\TeamViewer\Version9\Teamviewer.exe
    > Teamviewer will load. Then click Profile->Profiling
    > Check the box Use full paths when logging file names
    > Click OK

    Does the error window pop-up? (I'm guessing yes). Copy/paste the log in the bottom pane into a text file and upload. I'm hoping the file error will be identified in the log file
  5. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    Ok, log uploaded. The error popped up as you predicted.
    btw, I did unhide all files before searching , dllcache was not listed under System32 with this setting, but it is there:confused:

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    My bad! (again :confused:) Windows REALLY likes to hide things. I forgot and gave you the wrong "unhide" option. fyi.. There's another line item Hide Protected Operating System Files. When it's unchecked you'll see a mess of stuff (you don't otherwise want to see :) )

    Now back to our fishing expedition... I ran Teamviewer 9 under XP on my machine and compared my dependency log to yours. One thing jumps out at me (this is just a guess. Don't know if it's the problem) but
    > Your log had 32 references to language resource files. All of them were errors
    > My log had no language resource references
    Here's just two example entries from your log (1st is for German other is for French)
    LoadLibraryExW("TeamViewer_Resource_de.dll", 0x00000000, LOAD_LIBRARY_AS_DATAFILE) returned NULL. Error: The system cannot find the file specified (2).
    LoadLibraryExW("TeamViewer_Resource_fr.dll", 0x00000000, LOAD_LIBRARY_AS_DATAFILE) returned NULL. Error: The system cannot find the file specified (2).

    /* edit: somehow I chopped the following off my post. Added it back */
    Check if those files exist under C:\Program Files\TeamViewer\Version9 (TeamViewer_Resource_de.dll and TeamViewer_Resource_fr.dll)

    In Teamviewer window, click Extras->Options->Advanced. click Show Advanced button. Set display language to English. Restart Teamviewer. Make any difference?
    Last edited: Jan 6, 2014
  7. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    The only resource file is English, so I did what you said but error is still there on relaunch. If nothing else I'm learning a lot about hidden files!
    I don't know if this is related but another (more annoying) niggle on this system is that some applications do not load the graphics icons tabs, I don't know the correct term so have loaded a screen print. Could this be related?
    Please don't feel obliged to spend your time on this, you have been a great help already, it would be good to fix it but I can survive with it.

    Attached Files:

  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Trying to debug some of these wacky Windows problems are a learning experience for me as well. Gives me a "real-world" problem to use to dig and learn more about Windows "under the hood". I'm good with continuing until either one of us get tired or run out of ideas :)

    I did some more searching and reading.... Think I may have found something <fingers crossed>.

    Tell me if C:\WINDOWS\system32\dwmapi.dll exists on your machine. It's a Vista file that some apps have mistakenly installed under XP
    > If it exists under XP, it can cause errors similar to yours
    > Your dependency log suggests it may exist on your machine. Double check
  9. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    No luck there :( ( did a cut n paste of address, and a search just to be sure).
    No shortage of 'real world' problems on this machine!
    LookinAround likes this.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    LOL LOL :p

    Footnote: I fully uninstalled/reinstalled Teamviewer 9 on my XP machine. Now, just like you, I don't have all those extra language resource files either now. Go figure. <confused> But at least that helps definitely rule them out!

    I DID discover that Teamviewer starts TWO processes: Teamviewer.exe and Teamviewer_Service.exe. So it's possible the second process is the culprit.

    Will post sometime later when have the chance with some new things to try / data to collect.

    /* EDIT */
    But one thing you could do. The result could be interesting. Run dependency walker and this time load and profile Teamviewer_Service.exe. Does the error message pop up? If yes, let me see the log file generated./
    Last edited: Jan 8, 2014
  11. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    Exited Teamviewer then did the walk with Service.exe, no error message, but two red lines in the log:
    Warning: At least one delay-load dependency module was not found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.
    Warning: Not enough cabbage in the Flux-Capacitor
    (Last one's mine!)
    LookinAround likes this.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    If we could just send 1.21 gigawatts into the flux capacitor, we could send you back in time before this problem began! :D

    Hmm..... Tell me if this file is on your machine C:\WINDOWS\system32\dxgi.dll
  13. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    It is there: VS:6.0.6000.16386
    We made need to go back to Atari TT days to get this fixed!
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Re: dxgi.dll

    Let's try an experiment
    > Create a system restore point
    > Exit TeamViewer
    > Rename the file to dxgi.dll.old
    > Restart TeamViewer. Any change?

    If that didn't help, rename the file back to original. I found TeamViewer keeps its own logfile. Maybe another clue in there.

    Exit Teamviewer again. Now with the dll back to its original name, start Teamviewer to re-create the error. On the Teamviewer window click Extras->Open Log Files. It should take you to the log file. Open it, copy/paste into a text file and I'll take a look
  15. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    ...and the winner of this year's 'Services to Impenetrable XP Problems Award' goes to...
    Lookin Around. cue wild applause.
    You did it again.:D Error gone...but how? How does changing the extension on this file effect the operation?
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Ha Ha.... Thank you... Thank you.... And I'd like to thank my parents and my college Comp Sci professors.... :)

    Here's what I learned (or, at least, seems to be the case) by inspecting those dependency log files
    1. Teamviewer invokes many modules (like DLL's) that must be optional because the log files contain many lines that say Error: The specified module could not be found (126) but Teamviewer still works just fine.
    2. BUT then I found these log entries on your machine (but not mine)
      LoadLibraryExW("C:\WINDOWS\system32\dxgi.dll", 0x00000000, 0x00000800) returned NULL. Error: The specified procedure could not be found (127).
      This implied the file dxgi.dll was on your machine but it didn't contain the procedure Teamviewer was looking for.
    3. For some reason dxgi.dll is on your machine but not mine. Apparently it's OK for Teamviewer to reference dxgi.dll and it not be found BUT if that DLL exists then the referenced procedure must be defined or SPLAT!! You get an error message pop up about entry not found.
    Based on some more reading, dxgi.dll is part of Windows DirectX.
    > It must be an add-on since its on your XP machine but not mine
    > I also found many video games use it. (I don't have any video games installed on my XP) Maybe the video games cause it to be loaded???? IDK

    Do have video games installed? If you do, and they now have errors when they run you may need to rename the DLL back to original and have to live with the error pop-up. I don't know if the bug is in Teamviewer or your version of dxgi.dll.

    Phewww! In any case, glad we got that one solved :)
    Last edited: Jan 13, 2014
  17. MD3000

    MD3000 TS Rookie Topic Starter Posts: 23

    Well I'd be lying if I said I understood all of that, but I guess here is not the place for a lesson in advanced windows programming. Suffice to say problem gone.
    There are no games on this machine (unless you count solitaire!) but lots of professional video apps (Avid, Sorenson Squeeze, DVDit HD...) Maybe they use Direct X. I hope they still work with the re-named file, I know what to do if not!
    Thanks again for your time and effort on this.:D

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...