Extreme fluctuations in ping

By Marty9231 · 56 replies
Sep 19, 2012
Post New Reply
  1. Brett Husebye

    Brett Husebye TS Rookie

    Home routers arent meant to be hung off of each other, routers would a. have to be hooked up via crossover cable, b. on the same subnet period reguardless of what others say (how the hell do you think you can back to back 2 router interfaces together like a CISCO for a lab??? HMMMM) 3. Use one number off the same network as the first one for the ip address of the 2nd router 4. if this doesnt work save yourself a crapload of grief and replace the router with a plain switch
  2. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Alright, in short (I tried...), here is a list of what's happened today:

    1) I disconnected the router, took it upstairs, reset it and accessed the router page. The page was password protected, and I found out the routers provided by my ISP have custom firmware on it to be instantly compatible with their modems. This software also builds in another default password and a firmware-upgrade block.

    2) I set the router address to and followed your instructions. I experimented a bit with different channels, to see if interference had anything to do with the issue, and to a certain extent it did. One channel would have 30-300 ping, while the other had 30-600 ping. After a while of testing, all channels blurred into the same ping-range of 50-800 with spikes to thousands or 'request timed out'.

    3) I looked up this specific router from this specific ISP, and noticed many many people having trouble with it. Basically it's causing nothing disruptions in connection, lot's of people experience disconnects, slow internet, etc. They all said to return the router and get another, decent, router.

    4) Both tracert and pathping trace to my router, and time out after that. They never seem to reach my ISP's address. Despite this, internet connectivity seems to work (albeit very slow, with disconnects here and there, like I'm used to by now) 'normally'.

    My questions:

    - Is it possible their custom (but very outdated, theirs is at 1.0.3 or something, and the latest is 2.0.26) firmware is messing things up? If so, is there any way to update the firmware despite the update-block? People wrote that even manually updating is restricted.

    - Could it be that local channel interference is messing up the signal? I did see a difference between certain channels in the moments just after reboot.

    - Why can't tracert and pathping reach my ISP? Could it still be that they're messing up on their end? After all we saw the ping spiking up from the pathping hop between me and the ISP.

    - After reading and assessing all this, wouldn't it just be easier to urge the house admin to contact the ISP and if need be return the router for another? Or even change ISP if things persist?

    Edit: I looked further into the frequency thing, and downloaded "inSSIDer" to scan my area for used frequencies and channels. I saw a few heavily used ones, but this graph stood out for me. My router (blue one) has a frantic graph, going up and down in frequency like crazy. That can't be good, right? Is that the routers fault? Could it be what's causing my problem?


    Tracing route to google-public-dns-a.google.com []
    over a maximum of 30 hops:

    1 2 ms 1 ms 3 ms
    2 * * * Request timed out.
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 * * * Request timed out.
    7 * * * Request timed out.
    8 * * * Request timed out.
    9 364 ms 401 ms 188 ms google-public-dns-a.google.com []

    Trace complete.


    Attached Files:

  3. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Hmm; (4) & the tracert results are "interesting" in that those nodes were reporting previously.
    The destination was reached, so this indication indicates that they are not responding to the ping
    but still passing traffic. If it were one or two I might buy that but all eight as simultaneous changing ???

    I would go for the firmware update - - but that's locked out.

    Is it possible to connect a laptop directly to the modem (ie borrow one from you buddy) then Try the tracert again.
    I suspect the ZyXEL.
  4. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Not true. Downlink from A going to uplink on B is perfectly legitimate and creates a new subnet. Standard cables work just fine.
    Yes, that's using the second device as a switch
    Except he wants the WiFi feature (not available in switches).
  5. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Use the 2.4 GHz tab to find the channels used in your location. You show 24 wifi routers in the time graph - - WOW, that's heavy interference. Pick a channel with the fewest competitors.
  6. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    For the record, the ZyXEL has these features:

    • NAT (includes multi-to-multi NAT)/SUA, 512 NAT Sessions
    • NAT Server (Port Forwarding)
    • VPN (IPSec, PPTP, & L2T support NATTP) pass through support NAT
    • Protocol and Generic Packet Filter
    • DNS Proxy
    • Dynamic DNS (www.dyndns.org)
    • IP Alias
    • DHCP client/server/relay
    • supported RIP I/RIP II
    • Support 16 IP Static route
    • IGMP v1 and v2 IP Multicasting,
    • IP Policy Routing
    • UPnP support
    • Centralized log​
  7. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    I picked a channel with no one on it, and that changed nothing. I'm thinking the frequent frequency changes have something to do with it.

    Also, I don't understand a thing about that list of features, what does it mean?
  8. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    just fyi info on the device.
    The availability of DHCP and 512 sessions tells us we could use your WiFi router as a switch, still keeping the WiFi
    but allowing the ZyXEL to provide the IP assignments.

    Wired RouterA-lanport-->yourRouter's Uplink will isolate the WiFi users from the ZyXEL. If the whole house needs WiFi then that becomes moot.

    Wired RouterA-lanport ->wifi router lan port will run it as a switch, but you need to disable the DHCP service in this router.
    All wifi configuration is still active and can be modified as needed.

    Try it, but I think the ZyXEL is a major contributor here and the motivation to get off the 192.168.1.x subnet.
  9. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Ok, but I am on the 10.0.0.x subnet already. So if removing the DHCP from the router doesn't fix it, you reckon we should replace the ZyXEL?
  10. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Ok, more slowly.
    • ZyXEL is on 192.168.1.X
    • Netgear is now on 10.0.0.x
    If you connect the ZyXEL(lan port) --->(lan port)Netgear, THEN AND ONLY THEN do you disable DHCP on the Netgear.

    The ZyXEL will provide all DHCP support, all systems will be on the 192.168.1.x subnet and the Netgear will still provide WiFi access to all users.

    btw: I understand the tracerout timeouts when ZyXEL(lan)-->(wan)Netgear and you are on the 10.0.0.x subnet.
    PING (including pathping and tracert) use UDP connectionless protocol so there's no socket for the far end to use when making the reply. The ping reply spews UDP response to the requester (ie your 10.0.0.x address).
    When it reaches the ZxYEL 192.168.1.x device, there is no route to cause the reply to reach your 10.0.0.x address and the reply is tossed - - causing all the timeouts. (sorry I didn't remember this when I saw it. )

    This is a good thing (for securing) but complicates file sharing across subnets. It is fixable, but that requires access to the config page of the ZyXEL.

    Action items:
    Wire a connection to the Netgear and disable the dhcp. save and logout
    Reconnect ZyXEL(lan port) --->(lan port)Netgear and leave the Netgear WAN port (uplink / internet) slot empty.
  11. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Alright, final update + conclusion:

    I talked to the house admin, and they're looking into a new ISP and a new subscription. One that comes with an actual mechanic + router + modem.

    I think part of our problem is because the router firmware is 4 years old (Oh dear, I know) and that the router has custom firmware for a completely different ISP. This custom firmware prevents me from updating it to regular updated firmware, and thus from letting me turn it 'back' into a 'normal' router. I told this to the house admin and they said "Yeah, when we first got this subscription we didn't get a router/modem with it yet, so I just goofed off with cables until it worked..."

    In the end, I/we didn't figure out a concrete problem and solution, but my issues will probably be fixed with a new ISP. Also, my ping now always shows "request timed out", even when I DO have internet. Same goes for tracert and pathping. They all time out after hopping to the router. I read up op on this, and most conclusions were that the firmware of the router was to blame; nothing I can do there.

    I want to thank you for all the effort you put into this problem. You may not have solved the problem, but you certainly helped me well on my way in better understanding networking for the future :).
  12. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    I think I would finger the ZyXEL as the issue. ANY device that old, with locked down firmware which is several levels behind the curve HAS GOT TO BE SUSPECT ;)

    be sure to see the comment above (btw: I understand the tracerout timeouts...)

    This thread should be of some assistance in getting the new ISP and its equipment installed.

    Keep me post - - best wishes, Jeff
  13. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Just to be clear: the ZyXEL is not the one with the locked firmware. The router has locked firmware.

    However I've just managed to update the firmware to another ISP custom version, a bit newer. It now shows me my ping again, and now the problem seems to be that there is simply 'not enough internet' to do anything. The ping shoots up whenever I even load a website, speedtest indicates I have 300kb/s tops.
  14. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Netgear is not locked - - what leads you to that conclusion?
    DSL max's out at 756kb

    If the DSLis the 'poorest' link in the chain, then tracert will show the link from your network to the ISP Gateway
    as the largest time and everwhere else should be better than that link.

    Get me another tracert please
  15. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Alright, here you go.

    Tracing route to google-public-dns-a.google.com []
    over a maximum of 30 hops:

    1 2 ms 1 ms 1 ms
    2 3 ms 24 ms 21 ms
    3 28 ms 28 ms 28 ms 82-169-27-254.ip.telfort.nl []
    4 42 ms 57 ms 31 ms core1.ams.net.google.com []
    5 33 ms 31 ms 103 ms
    6 32 ms 32 ms 74 ms
    7 36 ms 37 ms 111 ms
    8 * * * Request timed out.
    9 52 ms 98 ms 202 ms google-public-dns-a.google.com []

    Trace complete.

    I noticed myself that the 'second router' popped up again under I ran a pathping [] again, and it was listed there too as a second router.
  16. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Those are acceptable numbers !! :)
    What Make/Model of modem are you now using?? As previously noted, it needs to have NAT and may have (SPI+DHCP). IF SO, then
    If you have Modem(lan)--->(lan)Netgear(lan)-->system AND the netgear has DHCP disabled, this should be impossible :(

    (ie: the netgear WAN slot should be empty)​

    and your system should have a 192.168.1.x address.​

    We intentionally moved the netgear to 10.x to avoid multiple routers on 192.168.1.x and while what we now see is workable, the ONLY feature you need from netgear is the WiFi connection,
  17. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Right now the situation is: ZyXEL(lan)->(lan)Netgear(WiFi)->System

    The Netgear has DHCP enabled, but for a good reason. Ever since we moved the netgear to 10.0.0.x, the 'second' router has been gone. It has not been in tests, it has not been on the network, it was just gone. When I found those acceptable numbers yesterday, I speedtested my internet connection, and it came with about 300 kilobits/second, which is extremely slow. When I test now (early morning, so internet connection is fine like 'normal') it comes up with about 16Mbit/second which is what it should be during the rest of the day. For some reason it's just losing tons of speed during the day.
  18. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    I would have expected modem(lan)---(wan)Netgear to give these results. I find it strange that
    modem(lan)---(lan)Netgear)(wifi) still provides NAT support.
    I expect that
    the 10.0.0.x IS actually the previous secondary router [and is another reason for the change ]
    the 10.0... is now the secondary router and the path is via the primary at 192.168 and YOU know which is which.
    Recall, the original conjecture was that a printer was showing up in the path (quite impossible).

    Now, if more than one system can connect to your setup then smile . . .
  19. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Agreed :)

    Every since I updated the firmware to the newer version, things have stabled out a bit. I can now at least use internet, albeit very slow. We're getting a more 'up-to-date' subscription anyway, so things'll be solved then.

    Again, thank you so much :)
  20. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    So... Guess what. The trouble reappeared, and my internet connection is constantly at 3000+ ping or timing out. My last discovery, before I gave up, was that the ZyXEL and the RangeMax are both routers (with the ZyXEL also being a modem) and the ZyXEL has wireless internet disabled.

    I was wondering if the double router setup could be 'singlehandedly' causing this internet connection issue. Even though the ZyXEL has wireless disabled. The thing I don't understand about all this is that if they're both routers, they'd both probably have DHCP enabled. Why am I not seeing multiple local IP addresses for my computer? I'm always only 10.0.0.x.

    Would it get me any further if I replace the ZyXEL AND the RangeMax with a 'recent' modem/router combi? The modem/router in question is a Speedtouch 780 (Experiabox). Or is there an easier solution to solving a double router problem? (I know I could disable DHCP on the ZyXEL, but I'm also a bit weary about the ancient (custom!) firmware of the RangeMax...)

    Edit: Just thought of something, wouldn't it just be possible to remove the ZyXEL completely and stick the LAN(in) cable right into the Rangemax router?
    (If it's any use: Internet IP Address -> Get Dynamically From ISP - This is set)
  21. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    First, you are not the sole person with double routers. I have recommended disabling the DHCP in the
    RangeMaxto keep all systems in the same subnet - -
    Doing this converts the second router (ie the RangeMax) into a switch which provides ONLY the wifi support.
    The ZyXEL would provide the NAT and SPI service.

    What you have WORKS for others and should for you too.
    {personally, I've used the upstream for my lan and the secondary for guests. Nice isolation.}

    the request for DHCP is a unicast - - sent to everything on the same subnet (ergo 10.x.x.x). The ZyXEL doesn't see it and even if it did, the RangeMax would reply first and win.

    With all the pain you have suffered, I would take a hammer to both boxes, find another ISP and start over.

    With greatest empathy, I feel your pain.
  22. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    GO for it - - nice box.
    Be sure to update the firmware when you get Internet service.
  23. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    CAVEAT EMPTOR: Just remember, you control the LAN->Modem
    the ISP controls the Modem->Gateway address

    and everything else (all those nodes to get to google for example) are out of your hands and you suffer
    whatever the local service provides.

    {old story re Italy, phone service is terrible}.
  24. Marty9231

    Marty9231 TS Booster Topic Starter Posts: 142

    Alright, so before I get my hands on the Experiabox, it would suffice to have ->(lan)ZyXEL(lan)->(WAN)Rangemax(Wifi)->Me with DHCP disabled on the rangemax?
  25. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    It would suffice to have ->(??)ZyXEL(lan)->(LAN)Rangemax(Wifi)->Me with DHCP disabled on the rangemax

    I thought the ZyXEL was the modem so the (??) should be the telco line

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...