Fix Windows folder unresponsive/slow behavior, green loading bar

Julio Franco

Posts: 8,856   +1,790
TechSpot Elite

fix windows windows tech tip windows 8 windows 7 fix

Hate that green loading bar when browsing a local folder? Makes no sense, right?

An old Windows fix for an equally ancient Windows issue. This Windows Explorer "bug" goes back to the days of Windows Vista, yet unfortunately remains a glaring annoyance in Windows 7 and Windows 8.

This unresponsive/slowdown behavior is typically seen when browsing the "Downloads" folder, so it's very likely it's happened to you as well. Windows tries to be smart about the files you store in your folders and thus optimizes the view and sorting options for pictures or videos. On either of those settings it will try to generate thumbnails for all your files (even when they are not pictures or videos) and take away precious seconds of your time, every - single - time.

Needless to say it's a very frustrating behavior, but thankfully something that can be easily fixed.

  1. In Windows Explorer, right click the Downloads folder (or any folder you are having issues with), then select Properties.
  2. Select the Customize tab
  3. From the drop-down menu, Optimize this folder for: "General Items"

That should do the trick.

Fix Windows slow folder

Note Windows might forget this setting in the future if you keep storing certain types of files (images or videos) and again default to optimize for them. I've had to change this setting back a couple of times in the past year, but most important of all, after the fix access is instant when I'm browsing around for my latest downloaded files.

Permalink to story.

 

Chazz

Posts: 679   +76
Hmm, mine was already set that way and I'm sure I didn't do that. Any idea why? I'm using windows 8.

I know I did a few things to make my library folders go to my D drive(HDD) instead of my SSD, but I didn't change any settings.
 

wiyosaya

Posts: 7,489   +6,296
In 7, I find no "Customize" tab. I'll assume that it is because I am not running indexing. However, I am rarely bothered by this problem.
 

Chazz

Posts: 679   +76
In 7, I find no "Customize" tab. I'll assume that it is because I am not running indexing. However, I am rarely bothered by this problem.

You need to go to the actual folder location and right click the folder, not via the favorites bar in windows explorer. I'm not sure if that's your problem, but it sounds like it's' what I ran into.
 

lmike6453

Posts: 100   +6
In 7, I find no "Customize" tab. I'll assume that it is because I am not running indexing. However, I am rarely bothered by this problem.

You need to go to the actual folder location and right click the folder, not via the favorites bar in windows explorer. I'm not sure if that's your problem, but it sounds like it's' what I ran into.

+1, so navigate manually to My Computer, c:\users\PROFILE_NAME\ and right click the sub-directories from there
 

javierkaiser

Posts: 35   +28
Would be very very very interesting something like this tip, but for the network. It take hell of time to try to connect to my other pc ... :-/
 
D

DelJo63

99% of the time, I use the Detail view so as to get column headings {name, mod date, type, size} upon which you can click to resort the list - - very useful (at least to me) and getting the file info is much faster than creating thumbnails :)
 
G

Guest

Does this also work for DVDs?

I have some old data DVDs which seem to take forever to open. I've been trying to copy the contents to a new external but some of these DVDs are predicting hours to copy over. Any clue?
 

dividebyzero

Posts: 4,840   +1,270
Win8 must set the affinity accordingly.
Docs folders for me are already set to General Items. Folders containing video folders are set to video, and music folders have the "music" setting selected.
 

St1ckM4n

Posts: 2,887   +628
The loading bar does nothing when browsing local folders, you can still click on what you want to go to. Much like the loading bar in a web browser.

Or is that just me? :(
 

toooooot

Posts: 1,507   +753
Another thought: if you have a secondary HDD, by default it goes to sleep after 20 minutes. So, when you try to access it, you might have similar delay. I changed settings under the power options in control panel for HDD to two hours. It can help too.
 
G

Guest

Thanks man, it really works, now folder open instantly, change sorting detail, view, no more long rendering green bar

thanks really
 
G

Guest

To me helped also: click right in given folder and then "group by" select "none".. For now,the folder with many audio,video and other stuff opens immediately.
 
I can't even begin to do the fix. When I get the dreaded green bar, the only things that show in the left side are Favorites, Homegroup, and ThisPC...I can see the Download folder if I click on Favorites, but in properties, there's no customize tab.
 
G

Guest

You can also use 'Organize - Folder and Search Options... - View Tab' - Tick 'Always show icons, never thumnails' and click [Apply to Folders] but that doesn't always work. Hence my search for more help and finding this solution. For me however, this tip only worked if I set to 'Documents' and not to 'General Items'. I was browsing Novell OES NSS volumes at the time. Hope this helps.
 
D

DelJo63

Usually, that green bar arises when the folder View choice is icons (try list or details) AND that folder has lots of pictures. I organize our picture archive into subfolders, like {family, friends, vacations, sports} and then subdivide those further by date or perhaps locations. In this way, icons are again safe to use and the time to search, create and display them is rational :)
 
Windows 7 : I was having similar issues anytime the PC was opening a dialog box to display places to save/open a file from. I have four mapped drives to folders on my NAS for music, video, photos etc. Even though these are well-organised into year and month, it was still super-slow to open any file explorer dialogues.

The fix that (seems to, so far...) have worked for me is:

Click on the Start Button, type "Indexing Options" (without quotation marks) in the Start Search box and press Enter.
Click "Modify"
In the "Index these locations" section, remove everything (click it and press delete key).
Click "Advanced" button.
Click on the "Index Settings" tab.
Under Troubleshooting, click the "Rebuild" button.

Seems to work.