Flash Drive Acting Up

By DJ Vindictive · 19 replies
Jan 30, 2008
  1. Ok so here's my problem: I want to put a video file in my flash drive but its not letting me. It gives me some lame excuses. I'll post the screenshots after a few more posts. Anyway, its a Dane Elec 2 GB flash drive and i use windows xp. Any help would be greatly appreciated.

    Most of the time here is how my little properties graph usually looks like:


    After i try pasting something in anyway, i usually get this message:

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    k i'm in the process of dling it now. I'll update this post when i'm finished.

    Just posting this so you don't think i'm not responding.

    Update: Here's what comes up afterwards. I thought i was suppose to have 2 gigs? Anyway, what do i select FAT or NTFS

  4. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    OK here are the results, guess its a no show:

  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You may need to go to device manager and confirm all USB devices are updated
  6. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    how do i do that?

    If it involves going to hardware, and updating the driver then i've already done that.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Ok so you have visited your m/b support page and downloaded all drivers and installed them.

    Also device manager is in System in control panel
    Once in there look under hardware tab.

    You may already know that, so I must go (be back later)
  8. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    um i don't think i know that. What i meant when i said that i updated the driver, is that i clicked properties from my computer and then followed through until it gave me options like updating driver, roll back etc..

    Anyway, here's where im at when i did what you said:

  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Yes that's it.

    But you may also want to confirm directly from manufacture
  10. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    err didn't work (updating the drivers)..i clicked scan for hardware changes which didn't help either.
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Actually the updating all drivers part

    What are the System Specs of this computer

    What is the make and model number of your computer

    What operating system are you using (Xp Sp2 32 bit ?)

    It would be ideal not to just paste or write all this info here, But to just add this information to your PROFILE, which makes it easier for support to confirm driver links so forth.

    Are you able to do that?
  12. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    ok i put all the information on my profile. Sorry i took so long, i gave the drive to my networking teacher and he formatted it on his comp (i wasn't there) and then said it worked fine. He said he even put in files and took them back out to check. When i told him what was happening he said he thinks i probably have a virus or something on my computer that isn't allowing me to save things on the drive. I mean just for the record, i have saved things on it in the past.

    Oh and another message that usually comes up that i didn't include was: "Cannot copy, the parameter is incorrect. " If i don't get that message then i get the post 1 message at the bottom and afterwards if i check the properties of the drive after one of the 2 comments occurs, i get that showing.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Your Mem 288Meg (?) looks a little low for Windows XpSP2
    The concern is, that if you consistantly run high (even low) memory usuage programs (ie Antivirus and millions of others) that in turn your computer's PageFile will be more and more accessed, which puts a big strain on your HardDrive (and all its filesystem)

    I would suggest to upgrade your Ram (if you think it's worth it) and run a few tests on the HardDrive
    You will need to confirm your HardDrive make (reading the cover) and then download the HardDrive diagnostic utility.
    Here's a few: https://www.techspot.com/vb/topic7602.html
  14. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    soo i can't fix this problem without upgrading my RAM? I'm getting a new computer in about another month and then this one will only be used by my parents (who don't use this much). I wouldn't say its worth it. The whole reason i got a flash drive in the first place was so that i can put videos from my computer into my ps3. When i get my computer i'll hook it up to my tv so then it won't matter anyway.

    Anyway, i guess if this is it then thanks.
  15. jobeard

    jobeard TS Ambassador Posts: 11,175   +989

    RAM is not the issue!

    It appears that the flash drive was once upon a time partitoned and formatted.
    Use cp-> Admin Tools -> Disk Manager to verify a healthy partition -- it should be
    formatted as FAT32.

    If it's NFTS, then you will have permission issues on every system to which it is attached.

    XP seems to treat USB devices rather poorly whereas Mac OS X and Linux do not
    run into these issues.
  16. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    its formatted as FAT32, i always make sure i format it on that, and matter of fact it only works on that. Anyway, here's my most recent screenshot that i think is the most accurate as to what the problem may be:


    how do i correct ^
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Can you format (Yes Fat32 - covered) the USB drive on another computer
    Basically these drives can fail - and never work again

    Confirming from another computer will take your computer out of the equation
  18. jobeard

    jobeard TS Ambassador Posts: 11,175   +989

    Delay write error:

    http://support.microsoft.com/kb/330174 says
    This issue may occur if one of the following conditions is true:
    • The "Enable write caching on the disk" feature for your disk is turned on.
    • Your Ultra Direct Memory Access (UDMA) hard disk controller is configured in either of the following ways:
    • You are using a 40-wire connector cable to connect the UDMA drive to the controller instead of the required 80-wire, 40-pin cable.
    • The BIOS settings are configured to force faster UDMA modes.​
    but this is NOT USB related

    this looks hopeful

    select Optimize for quick removal
  19. DJ Vindictive

    DJ Vindictive TS Rookie Topic Starter

    its my computers fault, when i gave it to my networking teacher he said it worked fine on his room computer. At first it wasn't letting me format it on this computer and he managed to format it on his. Now as of recently, its been working except for that delayed write thing which isn't allowing me to save files onto it.

    EDIT: Joebeard, i used one of the links and followed through with the step that told me to uncheck the enabling write caching on both of my hardrives and i switched my flash drive to the quick thing as opposed to the improved performance one and at the moment it seems to be working. Hopefully it'll continue to. Kim and joe thanks for all of your help. If things don't work out i'll resort back to this thread.

    EDIT x2: Ok after the first video file worked, i tried to take advantage by adding a second and then i got the whole "The parameter is incorrect" + delayed writing combo..maybe i just need to fiddle around with it.
  20. Bravo7

    Bravo7 TS Rookie

    Can someone help me in my post *New* Flash Drive problem. 1GB to 2MB.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...