USB flash drive not detected in Laptop

Hi! I am new to Linux thus, I'm using VirualBox and running Ubuntu on virtual machine, just started a week ago. My laptop is having Windows 10 OS. To get familiar with Fedora, I used Fedora media writer to setup Live Fedora workstation on USB flash drive. It is a Transcend (Jet flash) 32GB USB flash drive. I did not transfer the files and folders in USB and just went ahead to use it, as the files and folders were not more than 1GB. Later after installing Fedora Media writer, I started to write the image (*.iso) file. But before completing the setup, there was a warning, that if I proceed, whatever data previously existed in the USB would be wiped. So, I stopped the process but then, I observed my flash drive is not visible in the laptop. I checked in 'Disk management' where it shows USB drive but without letter assigned. Even if I click 'Change driver letter and path', I'm getting error stating the system cannot access the file. I used data recovery software Disk Drill and it was retrieving data deleted long back. Then, I tried installing VirtualBox extension and then tried to access USB via Ubuntu VM, even then, I am not able to access the USB. Some files in the USB are crucial for me like Salary slips from previous companies and other few documents. Anybody gone through similar problems please help. Thanks in advance.