1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Flash drive not operative in all ports?

By safulop ยท 12 replies
Mar 14, 2008
  1. Greetings,

    apologies if there is an existing thread answering this question but here goes. . .

    I have a Dell Latitude laptop and a new 8 GB Kingston flash drive. I run Windows XP SP2 and also Linux Fedora Core 6 on this machine. Normally I do not have problems with my flash drives in either system but recently this new Kingston drive is only recognized in the lower USB port, not in the upper port. This same thing happens on both operating systems, when plugged in to the upper port, the light on the drive blinks for a moment and then goes dark, it is never recognized at all, and there is no error message from the system. It is as if nothing were plugged in. Yet plugging in to the lower port works fine.

    Any bright ideas?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    The port is dead? Can you use any other devices there?
  3. safulop

    safulop TS Rookie Topic Starter

    Port is fine


    oh no, forgot to mention, my USB printer and other two flash drives work fine in the upper port. Only the 8GB Kingston fails to fire up in the upper port. Since I've recently acquired it, and since I normally plug into the lower port first to maintain easier access for a second device, it is likely that it has in fact *never* worked in the upper port and just didn't notice for a week or so.

    Then one day I had my printer plugged into the lower port so I put the Kingston in the upper port; didn't work. Plug-unplug, didn't work. So I unplugged the printer and put it in the lower port and it was fine.

    I have since tested this behavior numerous times in both operating systems, and it is quite consistent. Always good in the lower port, never works in the upper port. All other USB devices still work fine in the upper port.

    It is very strange.

  4. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    This is a hardware issue. You probably have a loose or bad cable in the upper port or something is not making sufficient contact.
  5. safulop

    safulop TS Rookie Topic Starter

    New info on USB ports

    Hi again,

    getting back to this old thread, I have since learned from a tech-savvy friend that a number of computer manufacturers such as Dell were in the habit of putting older USB ports into their machines that would not work with drives larger than 4 Gb.

    Since only my upper port has problems, and since the only unit it has problems with is my 8 Gb drive, my suspicion is that this is not a *bad* port, but an *old* port that Dell stuck in here hoping no one would know.
    The lower port is fully capable with the 8 Gb drive.

    What do you think of this explanation?

  6. jobeard

    jobeard TS Ambassador Posts: 12,553   +1,440

    Sounds like Usb 1.1 vs 2.0 compatibility.
    Does your Kingston flash drive have P3 or similar program loaded so that it Autoruns OR
    is it a naked data drive?
  7. safulop

    safulop TS Rookie Topic Starter

    Usb 2.0

    Well now,

    if by "autorun" you mean does it open that dialog box that asks "what do you want Windows to do, play all files, open folder, etc." the answer is yes it does run that dialog.

    And my other smaller flash drives do not run that dialog, they just open an F drive folder or whatever.

    So, why would I have one port that is compatible with USB 2.0 and another one that isn't?

  8. jobeard

    jobeard TS Ambassador Posts: 12,553   +1,440

    because there are USB 1.1 ports and hopefully USB 2.0 ports as well.
    look in your device mgr under USB; you'll see TWO kinds of controllers.
    on my laptop, I have only ONE USB 2.0 and three USB 1.1; made it fun to locate the 2.0 port
  9. Davidlee48

    Davidlee48 TS Rookie

    Some individual USB ports are "unpowered" as well. Meaning they lack the +5v supply, if memory serves me. I have such a laptop, and the info is in the specs for the machine. I just have to remember which laptop, lol, to get the spec.
  10. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Part of the specification for a USB port is that it be powered. There was a day when you could get both a USB 1.1 an a 2.0 in the same laptop, strangely. But than ended in early 2003. What model do you have, or what is the service tag? However, most of the Dell USB problems we have seen on Dell Latitude and Inspirons involve situations in which both ports are used at the same time, thus splitting the power unevenly and rendering one port less effective.
    I doubt it is a power problem, but rather a BIOS design problem. Jobeard has the solution, as usual. Look in your device manager to see what is reported there.
  11. safulop

    safulop TS Rookie Topic Starter

    According to the device manager, only one USB controller line says "USB2 Enhanced Controller." So, that's the answer, there is only one USB 2.0 port.

    But this is a 2007 model Latitude D620. Or at least, it's supposed to be. My university leases it for me. Didn't you just say the practice of mixing ports ended in 2003? I know the machine isn't *that* old.

  12. raybay

    raybay TS Evangelist Posts: 6,908   +10

    News to me. Common on older models
    What is the service tag?
    There are many configurations of their laptops which are special order specs, for group pricing at extremely low costs. We service some of them, so perhaps I can check out some aspects in our contract repair guide.
  13. safulop

    safulop TS Rookie Topic Starter

    Well the little sticker says
    Service Tag 3RHXVB1

    Any specific info you could get would be great, since I could pester my tech guys to get me an upgrade if this machine does not meet our specifications.


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...