1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Flash, Firefox & Linux (Ubuntu)

By Bluemouse ยท 4 replies
Apr 1, 2009
  1. Anyone else having problems with flash in ubuntu 8.10? Random players don't seem to work, and sometimes it just crashes my browser. Other sites/players do funny things :)

    Anyone able to get flash working reliably?
  2. mrturtle

    mrturtle TS Rookie Posts: 43

    I couldn't get my soundcard to work properly with flash player, worked fine in the mobo's line in though.
    Have you tried uninstalling and reinstalling it, sudo aptitude purge to make sure that all the files are removed first.
  3. vahnx

    vahnx TS Rookie Posts: 22

    Are you using Gnash or Adobe or that other one (can't remember what it's called)? If one is giving you troubles, remove it with Synaptics and install the other, etc. You can keep both but if you do, make sure both are not active at once in Firefox's addon's. Also, does Flash appear fine in Opera, Epiphany or other browsers?
  4. Flash is poor under Linux, especially the Adobe flash. I find that it works but it's slow and when there's video involved such as with sites like Youtube it's very jerky. It also tends to be a whole release behind the windows equivalent. I tend not to visit sites that use flash much anyway so for me it's not an issue. If you're not bothered about videos etc, then I would follow vahnx's advice and try one of the open source flash players such as Iced-tea or gnash.
  5. ITGuy702

    ITGuy702 TS Member Posts: 70

    Late Response

    I know it has been a while since someone has replied and I'm not sure if you still need a response. But I experienced the same problem running Ubuntu Studio. MySpace music players weren't working, YouTube videos would play without sound, etc. I searched and searched and searched and FINALLY found a forum (can't find it now but if I do, I post the link to it). The fix was using Macromedia Flash. Gnash wasn't working for me and Adobe Flash was a joke!

    Apparently, Adobe bought out Macromedia but both versions are still available for install? I've never been a huge fan a flash so I don't follow the history. Haha.

    Anyway, It has been a while since I've corrected the problem but I think I remember the command I used. :confused:

    Ok...ok...now on to the point.....

    I used the following command to install Macromedia Flash:

    sudo apt-get install flashplugin-nonfree

    Ever since then, I haven't had any problems with flash. I hope this helps you!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...