1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

FPS issues with WoW

By wdhodgeiv ยท 13 replies
Feb 9, 2010
  1. Hey guys long time reader first time poster. I have been having some FPS problems with WoW and cant seem to figure out what i am doing wrong.

    AMD phenom 9650 quad core 2.3 ghz
    Asus MZN68-LA motherboard
    XFX radeon hd 5770 overclocked to 960 mhz cor and 1300mhz on the memory

    Running at full settings in a 25 man raid situation i am getting 5-10 fps on a boss fight was wondering if these fps were normal for my setup or is something wrong?

    Thanks in advance for the help
  2. PaulWuzHere

    PaulWuzHere TS Guru Posts: 271

    Enable hardware acceleration, Disable full screen effect, Drop AA to 2 or 0. Besides that, Whats your internet connection looking like?
  3. Relic

    Relic TechSpot Chancellor Posts: 1,379   +16

    Hi geiv :wave:;

    No that is not normal, I quit after 3.1 but have played all the prior content and 25man raids on a worse machine then yours with onboard gpu. My average FPS during intense boss fights was 5-10fps granted not at full settings :).

    What OS are you running? From reading around I'm seeing a lot of individuals who are running Win7 with a 5xxx cards getting 10 or lower FPS in raids or cities. Actually seeing a lot of Win7 issues...anyway you don't appear to be alone :) .

    My suggestions would be like Paul said, turn down settings, turn off vsync and play around with your resolution. Make sure you are updated on drivers. And you could also try asking over at WoW's tech support as blues answer quite often with helpful info :) . Good Luck.
  4. wdhodgeiv

    wdhodgeiv TS Rookie Topic Starter

    ok i am running with qwest DSL 8mb i have about 95 ms to my server and am running widows vista 64bit and paul i have no tech know how so what you told me soundsto me like french anyway you could elaborate?
  5. PaulWuzHere

    PaulWuzHere TS Guru Posts: 271

    They are all options in the video menu. Manually change them and you should see an improvement.
  6. LNCPapa

    LNCPapa TS Special Forces Posts: 4,247   +448

    Internet latency will have nothing to do with your frame rate. As said previously, this sounds very abnormal, unless your running at some really high resolution like 2560x1600 or higher or maybe windowed over multiple screens. What res are you playing at? What are your current settings at? What kind of performance do you get outside of a raid? In Dalaran? When out questing by yourself?
  7. KyBrewer

    KyBrewer TS Rookie Posts: 60

    My wife's computer has a 5770 with a little faster quad core processor and has no problems with WoW that I am aware of. I have not updated my wife's driver from the version that came with the GPU, I think from November 2009 maybe.

    I have a 5870 in mine, and when i installed the driver update that came out in December (I think it was December anyway), my fps in WoW went to crap. I rolled back and they were fine. I recently updated drivers with the January 2010 release and have had no issues.

    Both computers are running Windows 7 64 bit, which I think has the same driver set as Vista.

    Regardless, for the latest driver:


    Forgot to add, we play with all graphics settings maxed out, 1920 x 1080
  8. vectorsigma32

    vectorsigma32 TS Rookie Posts: 154

    lol just turn some of the effect down and lower ur resolution abit XD
  9. wdhodgeiv

    wdhodgeiv TS Rookie Topic Starter

    thanks for all the help. I figured it out my quad core was a low clock speed and that was holding me back upgraded to a amd phenom 550 black edition dual core clocked at 3.1ghz amd upgraded mother board and and went from ddr 2 800mhz to ddr3 1333mhz. I get no less then 40 fps at ultra settings in 25 mans now :).
  10. LNCPapa

    LNCPapa TS Special Forces Posts: 4,247   +448

    Glad you got it fixed, but I think you just chanced across a fix in your case. I believe your old processor was more than fast enough to run WoW just fine, even at high settings. My daughter's machine has a Q8300 in it with an 8800GT and it runs very smoothly in raids @ 1920x1200. I'm sure your upgrades helped your performance even more, but I'm betting you inadvertently addressed your problem while upgrading those parts.

    Anyway, glad to see you're getting good performance now. Have fun and go outside sometime!
  11. W0w

    W0w TS Rookie

    Fps issue's when playing W0w

    Hi Guys

    I run a Gateway Nv44

    Processor Pentium (R) Dual Core Cpu T4200 @ 2.00 GHz

    Memory (Ram) 4.00 GB

    System type 64 bit Operating system

    I've been playing w0w for a very long time and recenlty got this new laptop and in game my fps is super low how can i max my fps and keep it up.
  12. Matthew

    Matthew TechSpot Staff Posts: 5,313   +100

    Considering the fact that your laptop's hardware is about as good as it's going to get (your RAM is presumably maxed and you can't upgrade other relevant hardware), there's not much you can do.

    Make sure your power profile isn't throttling your hardware, and turn down WoW's display settings. Other than that: buy a computer with more muscle.
  13. Relic

    Relic TechSpot Chancellor Posts: 1,379   +16

    Like Matt said, turn down your settings like resolution, play it on medium/low, turn off vsync and you should see improvement. Play around and see what works best for you, but overall you wont see amazing FPS in heavy raid environment if that's what you're looking for W0w. It'll always be it's lowest in the most intense situations.
  14. engadgeteer

    engadgeteer TS Rookie

    A thread from astrayamatu...

    I ran into a FPS issue this weekend on my pc where any outdoor environment would drop it down to a great 11 or 15 FPS until I can stutter back indoors. With a fresh WTF and Interface files, it still did the same thing. After poking with it for a bit, it seems that the game maxed out Terrain Distance for some reason without showing it on the Video Options slider. After manually playing with some numbers, my FPS went back up to 60+ FPS (with my custom UIs). Try using my config.wtf (World of Warcraft folder -> WTF folder) and replace yours with this:
    for me it worked out good hope for you too

    SET hwDetect "0"

    SET gxColorBits "24"

    SET gxDepthBits "24"

    SET gxResolution "1024x768"

    SET gxMultisampleQuality "0.000000"

    SET fullAlpha "1"

    SET lodDist "100.000000"

    SET SmallCull "0.070000"

    SET DistCull "500.000000"

    SET farclip "177"

    SET pixelShaders "1"

    SET particleDensity "1.000000"

    SET unitDrawDist "300.000000"

    SET movie "0"

    SET movieSubtitle "1"

    SET mouseSpeed "1"

    SET Gamma "1.000000"

    SET MusicVolume "0.5"

    SET SoundVolume "0.80000001192093"

    SET MasterVolume "0.90000003576279"

    SET cameraPitchMoveSpeed "90"

    SET cameraYawMoveSpeed "180"

    SET cameraPitchSmoothSpeed "45"

    SET cameraYawSmoothSpeed "180"

    SET cameraDistanceLast "8.188390"

    SET cameraPitchLast "26.300028"

    SET cameraWaterCollision "0"

    SET cameraDistanceMaxFactor "2"

    SET AmbienceVolume "0.60000002384186"

    SET minimapInsideZoom "0"

    SET uiScale "0.8299999833107"

    SET useUiScale "1"

    SET autoClearAFK "0"

    SET minimapZoom "0"

    SET alphaLevel "0"

    SET gameTip "47"

    SET guildMemberNotify "1"

    SET gxRefresh "60"

    SET SoundZoneMusicNoDelay "1"

    SET cameraView "4"

    SET specular "1"

    SET UnitNamePlayer "0"

    SET EnableErrorSpeech "0"

    SET readScanning "-1"

    SET scriptMemory "131072"

    SET weatherDensity "0"

    SET DesktopGamma "1"

    SET ffxDeath "0"

    SET lod "0"

    SET realmList "us.logon.worldofwarcraft.com"

    SET EnableMusic "0"

    SET checkAddonVersion "0"

    SET CombatDamage "0"

    SET lastCharacterIndex "6"

    SET gxMaximize "1"

    SET gxFixLag "0"

    SET baseMip "1"

    SET M2Faster "0"

    SET gxVSync "0"

    SET ffxGlow "0"
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...