Frequent Disconnects During Large Downloads

  1. Let's get my hardware/software setup out of the way first:
    OS: Windows 10 Professional 64bit
    Mobo: MSI-7850 Motherboard
    Proc: Intel Core i5-4570
    RAM: 8192MB DDR3 1600MHz
    NIC: Intel Gigabit CT Desktop Adapter
    Router: Linksys EA6200
    Modem: Motorola SB5120 (Provided by ISP)
    Speedtest Info: My most recent result shows my download speed at around 16Mb/s, upload speed at about 1.11Mb/s. I am on a LAN connection, not WiFi.

    Every time I download a large file and am using as much of my bandwidth as possible for an extended period of time, my connection drops after only a few minutes, reconnects, and resumes downloading at full speed. Lather, rinse, repeat. This is especially annoying when I am simply trying to download a game off of Steam. Grand Theft Auto V literally takes me days to download because of this irritating interruption. This problem has persisted for many months.

    I have updated all of my network drivers, configured all of my IPv4 settings for transmit and receive, checked through all of my router settings, tried several different routers with no change in the behavior, and connected directly to my modem. The drops appeared to cease when connected directly to the modem, but resulted in speeds between 300Kb/s and 1Mb/s download which, given my speedtest results, was completely unacceptable.

    The exact settings for my Intel Adapter are as follows:
    Adapative Inter-Frame Spacing: Disabled
    Flow Control: Enabled
    Gigabit Master Slave Mode: Auto Detect
    Interrupt Moderation: Enabled
    Interrupt Moderation Rate: Adapative
    IPv4 Checksum Offload: Rx & Tx Enabled
    Jumbo Packet: Disabled
    Large Send Offload V2 (IPv4): Enabled
    Large Send Offload V2 (IPv6): Disabled
    Locally Administered Address: Not Set
    Log Link State Event: Enabled
    Maximum Number of RSS Queues: 2 Queues
    Packet Priority & VLAN: Packet Priority & VLAN Enabled
    Receive Buffers: 512
    Receive Side Scaling: Enabled
    Speed & Duplex: 100Mbps Full Duplex
    TCP Checksum Offload (IPv4): Enabled
    TCP Checksum Offload (IPv6): Disabled
    Transmit Buffers: 1024
    UDP Checksum Offload (IPv4): Enabled
    UDP Checksum Offload (IPv6): Disabled
    Wait for Link: Auto Detect

    Since my connection does not use IPv6 configuration, all options for it were disabled by me.

    Internet Sharing options have been disabled by me.

    I am the only computer on this network, and the only computer attached to this router. I have Google'd this problem off and on over the past few months with no leads and no successful tweaks. I even attempted to download a 1.8GB file on a Linux-based machine and the connection drops persisted.

    I am, at this point, wondering if this problem is due to an upload limit problem or if it is a bad modem. If there is anyone out there that can shed some light on this issue or confirm my suspicions, I would greatly appreciate it. I am completely out of ideas on what to try next.
  2. IvanAwfulitch

    IvanAwfulitch TS Booster Topic Starter Posts: 218   +11

    [RESOLVED] I did some diagnostics on my PC over the last few hours.

    I started downloading a large file on my PC with Wireshark running so I could see the packet traffic.

    Next to it, I ran a wireless laptop running Windows 7. I opened a command line on the laptop and ran the "ping ______ -t" command where the underscores are some IP address that would send back a constant reply. For my purposes, I set the address to a Valve server address.
    ping -t

    As soon as my PC connection died, I saw the traffic in Wireshark indicating a crash, and the connection on the wireless laptop died as well. I could see the laptop ping returning No Reply. I looked over at my modem as soon as this event happened, and noticed it resetting its own connection.

    The final diagnosis is that my modem is bad, and I need a new one. Hopefully this thread might give a clue to someone else out there that has this issue and has tried everything in the book like I have.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...