Frustrating Windows 7 internet, will not connect

By Bluemouse ยท 52 replies
Nov 14, 2009
  1. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Hm, thanks guys, I'll give both the virtualization and the resetting the winsock a try.

    Hmm, maybe you're correct about the bad drivers and the APIPA not going together. I can "connect" via the wired nic once in a while, but it seems to be sporadic, and I still don't get internet (wired). As for the wireless card, I do get a valid IP and can surf the internet as normal, but the signal is too low to actually use it reliably from my location.

    I haven't installed any other software at all aside from firefox yet, and windows firewall is disabled, so it can't be a third party software issue. It's a fresh install, and ubuntu has worked fine for a while now.

    I was thinking it was an addressing thing with it being 64-bit and all, but I don't know...
  2. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Hmm, still not working after resetting winsock.
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Actually Asus do not support your Model (driver wise) with Windows 7
    I suggest Windows update for driver updates, but not much use without network
    Mind you, the drivers for your network should have come with Windows 7 anyway (as they are not listed under Vista 64Bit at Asus)

    You may be best to purchase a new PCI Network card to mount internally (that is obviously compatible with Windows 7)
    I have actually mounted a new network card and then got on the Internet for driver updates, then removed the new card and found everything then works (ie it may just reset something)
  4. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Like I mentioned, I don't have room for a PCI card, so that's kind of not an option.

    I've tried the drivers that come with windows update, they don't work either. That's the problem..
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Look, my best guess is non compatible network hardware to Windows 7
    ie Please make room for another $10 PCI Network card (and note: this may be temporary)
  6. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Again, I have no room, since I'm using the two pci slots that I do have..

    And I thought that if the drivers work for windows vista, they should work for 7? Same kernel for the most part. There ARE drivers for windows 7 provided by Marvell and from windows update....why wouldn't they work? Clearly they are at least supposed to support the nic.
  7. detoam

    detoam TS Rookie Posts: 74

    It's not a malware or a virus. It also happens in other OS. I am not sure why though. Usually it happens when you use a router. A few times that it happened to me I did the following:
    I reinstalled the drivers for the network adapter.
    Than I connected everything. Modem -> router-> PC
    Than I restart Plug in the modem ( when using the router I plug it in after the modem is fully on)
    Than I enable the network adapter on the PC.
    Usually the least I get (when using router is ability to get into the routers admin page).
    If the problem is still the same I go into routers admin page and check whether it shows the real IP or the 169.*.*.*. If it shows the real IP but the network adapter shows the 169.*.*. i simply reboot the router and then refresh the ipconfig on adapter through cmd.
    That usually works for me.
    when it does not i just connect the PC straight into the modem and restart the modem by unplugging and waiting couple of minutes and then starting again following the ipconfig reset on the network adapter.
    Hope this helps.

    I do have to agree that Win7 has some very strange behavior with networking. I am on the 15MByte/s line, but on win7 I can barely get 3Mbit/s. Tried various tweaks and disabling a lot of stuff and I still get the same. And IPv6 doesn't work at all.
  8. detoam

    detoam TS Rookie Posts: 74

    I just had the problem again. This time I was not using the router. I installed a firewall with anti-virus and anti-spyware and the problem showed up as soon as I restarted. I removed the program, but while i was doing that I also checked the windows network diagnose. I did that a couple of times and always noticed that among invalid IP message it also shows trhe missing protocols. I think it's a bug in the Win7 as well as anti-virus/firewall apps (guessing here) always mess with the windows network settings.
    If You check in the status of connection you will see that there is no IPv6 connection, but the protocol IS installed (or so it shows). I think that might be causing a problem. Sadly I am no tech so It's all just a guess and a bit of exp here.
    I tried restoring the protocols and it says that it does restore them. However a minute later the protocols are gone again.
    I did as I've mentioned in the previous post and got my connection back. I am wondering for how long though. I don't think i'll be restarting my PC anytime soon. LOL
  9. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Nah, I get it regardless of whether or not I'm connected to my router, and I have never installed any virus scanner/firewall on the OS since it's a clean install.
  10. detoam

    detoam TS Rookie Posts: 74

  11. detoam

    detoam TS Rookie Posts: 74

    I just turned off the IPv6 protocol completely and now everything just flies like mad
  12. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Yeah, I've tried that. Still doesn't work, even without IPv6. We have completely different problems.
  13. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    still won't work :(
  14. detoam

    detoam TS Rookie Posts: 74

    Sorry to hear that. My only suggestion would be to get a whole different adapter.Sometimes the built-in cards just aren't up to par.
  15. boosterx78

    boosterx78 TS Rookie

    Same config, same problem

    Exactly same config, exactly same problem.

    I tryed everything like you without success

    The only workaround I found was to switch to version x32 and it works... but loosing 1GB...

    And of course, my network cards work perfect with xp, vista, ubuntu... you are not crazy :)
  16. ColdPreacher

    ColdPreacher TS Rookie Posts: 56

    I had this problem

    I had this problem early on, on a fresh install. I would log on and i wouldnt be connected to the internet although i would be wirelessy. It was strange as i all devices where working fine, i could SMB my server which was on my LAN. So i tried in the device manager disabling my ethernet devices and it worked. I was connected to the internet. So every once in awhile i had to disable and re-enable. Then microsoft had a driver update for my Ethernet driver i installed it and it also works now for a week going. I dont know if it helps but perhaps you keep installing the same driver and keep getting the same event to happen.
  17. boosterx78

    boosterx78 TS Rookie


    As I can see on other topics there are no way to solve this issue.

    4GB on board seems to be the problem with the ethernet controller on x64 win system

    no way
  18. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Yeah, I really don't care to reinstall windows again unfortunately :( Anyone have any new ideas? I suppose it isn't possible to downgrade to a 32 bit version of Windows without formatting like I can do in ubuntu?
  19. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's right :rolleyes:

    But I've also heard that getting another network card made for Windows 7 (this of course on a PC Desktop computer only) works too

    But my true understanding of this big issue (so I've seen) is to always use the > manufacturer driver, not the MS Windows Updates driver
  20. merkin

    merkin TS Rookie

    I have asus p5nsli and have exact same problem as you under windows 7 64bit. The adapter works fine under windows 7 32bit. I only have 3gb of ram installed. Clearly the issue is driver related.

  21. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    hmm, yeah, there doesn't seem to be any solution there either :(

    I've contacted ASUS support, they say to use XP, so I contacted higher level support and they say they'll let me know when a new driver is released, but nothing more than that.
  22. AfricanTech

    AfricanTech TS Rookie Posts: 69

    I eventually solved a similar problem by buying a cheap (USD15) PCI network card (ensuring it was not the same chipset as my motherboard NIC), disabling the internal NIC and voila, all my problems went away (also an ASUS board)

    I know it's a "dirty" solution but life's too short to put up with the frustration of a flaky connection to the Internet.
  23. tipstir

    tipstir TS Ambassador Posts: 2,474   +126

    Realtek works wonders with Windows 7 32-bit or Realtek / Atheros for Windows 7 64-bit version
  24. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Up, just seeing if anyone has found a prettier solution yet?
  25. AfricanTech

    AfricanTech TS Rookie Posts: 69

    I found a driver on the Realtek website that fixed the problem. I then made sure that the Realtek Network Card Update offered via Windows Update is marked as "hidden" so that I don't install it by accident (which is what led to problem in the first place).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...