1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Gateway M-1625 acting like Windows Key is held down

By mopar man
Aug 8, 2009
  1. I was helping a friend out by helping him clean (software wise) and fix a few things that bothered him. Nothing went wrong, when I was done, I restarted, no problems.

    All I really did was run Ccleaner, remove a few programs that he didn't need... at all. And Installed Avira Free.

    It was also getting just past the Boot screen then restarting again, sometimes 2 or 3 times, but it's been doing this for quite a while and I have no clue what could be causing it.

    Now, after he got it back, he texted me claiming "my Windows key isn't working!", then "The insert key isn't working, nor delete, nor backspace, or really half the keys. I somehow got the windows key working..." then he said that it was acting like it was held down... and it is.

    Press R- "Run" is ran. E- My Computer. so on and so forth.

    Any ideas what's going on?

    OS: Vista Home Premium
    CPU: AMD Turion 64 X2 Mobile TL-60 2.00GHZ
    Ram: 2GB
    GPU: Radeon X1270

    Random things that may or may not matter:
    On Screen Keyboard DOES work properly, including the windows key.

    Keyboard shows up as "Standard PS/2 Keyboard".

    Started right after a guy set the password(s) in bios to his name, so we had to enter it like 2 or 3 times to get into Windows...(he tried and failed to "hack into windows" because he didn't know the User password...)

    What I have done: Checked the key, it seems to be fine, it's not being held down physically I believe...

    Running Virus scan now, nothing...

    Searched for Driver updates, just in case.

    Googled the problem, most were faulty keyboard drivers, but, I'm weary. I saw a few cases where CTRL or Shift keys were doing this, but the only ones similar to this were from a Remote Desktop error...
  2. strategic

    strategic TechSpot Paladin Posts: 1,020

    Try swapping keyboards. If you can do that or just buy a cheap one for $5 just to see.
    You don't need a special driver for the keyboard to use the keyboard unless there are many hotkeys like the MS 5000 for example.
    That's my opinion, I think the keyboard my be faulty.:approve:
    You can also try this, if the Windows key doesn't work, try [CTRL] - [ESC], it does the same thing.
  3. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,379

    it might not be a special driver, but it's a driver nontheless, correct? so it could possibly be corrupted? And I will tonight, I have a spare keyboard...
  4. strategic

    strategic TechSpot Paladin Posts: 1,020

    If it worked fine for you, then a corrupted driver is unlikely. Or did you even use the keyboard when you tried it?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...