Gigabit Lan on Asus A7n8X-E not registering.

By Ironbasher ยท 45 replies
May 30, 2004
  1. ELW

    ELW TS Rookie


    Marvell LAN card was conflicting for memory resources with Appian video card.
  2. Captain_Jon

    Captain_Jon TS Rookie

    I just put a computer together with a A7N8X-E DX motherboard and AMD Athlon 2600+ processor.

    I am having the same problem as a number of others in this thread... i.e. I cannot get the system to recognize the Gigabit port!

    There is no sign of the device when I open Network Connections ... Nothing happens when I connect a cable to that port at the back... I double checked that the jumper on GLAN_SW was properly set (I even tried it the other way!)... When I load the ASUS CD I don't get the option to load the Marvell Gigabit LAN Driver which suggests that the system is not detecting this port as an installed device... Finally, when I look at Device Manager, there is nothing in the Network adapters except the NVIDIA NForce MCP Networking Controller and the 1394 adapter!

    I did notice though that I had two unknown devices showing up in Device Manager... an ethernet controller and a RAID controller!

    I have to assume that the ethernet controller is the Gigabit device... so I loaded the Marvell Yukon driver from the CD that came with the ASUS motherboard. However, when the driver installs it looks for unbound devices and didn't find any!

    Any thoughts on whether or not the unknown ethernet device is in fact the Gigabit device and if so how would I go about getting the driver properly installed?
  3. Justin

    Justin TS Rookie Posts: 942

    In BIOS, try finding and setting "Reset configuration data" to ENABLED and restarting.

    I have the A7N8X-E DELUXE and use it with four operating systems - it works well with all.
  4. Captain_Jon

    Captain_Jon TS Rookie

    Soul Harvester... Could you be a bit more specific please... where in the BIOS does one find "Reset configuration data"? Also, what does this do?

    You mention that you use this board with 4 OS's... but do you use the Gigabit port?
  5. Justin

    Justin TS Rookie Posts: 942

    Yes captain john, I use the gigabit connection for all four. Windows 98 SE, Windows XP Pro, Gentoo Linux (2.6.8) and Debian (2.4.20)

    I forget where that option is, I am at work now but will check it when I get home
  6. Train22

    Train22 TS Rookie

    I just obtained an A7N8X-E Deluxe MOBO to replace a A7N8X Deluxe which had gone bad. I am using Win XP Pro and had both LAN ports on the A7N8X enabled and working.
    Since installing the new A7N8X-E Deluxe, I, like many others here cannot get the Marvell LAN port to work. When I went to install the drivers from the CD, the choice to install the Marvell LAN did not even show up.
    When I rebooted, I got the Add New Hardware wizard popping up and asking to install drivers for an Ethernet controller. I downloaded the drivers from ASUS and installed them as instructed. No luck. I emailed tech support at ASUS and they said to make sure the jumper block was enabled. :knock: NO ROCKET SCIENTIST THERE!! :knock: I did check the jumper block again, rebooted but no luck.
    Has anybody come up with a logical solution to the problem yet?

  7. ziozeus

    ziozeus TS Rookie

    I also have this problem.
    win2000pro, a7n8x-e deluxe
    ethernet controller is there in the system management, but in no way am I able to make windows recognize any driver for it.
    I thought it was a 3Com 3C920B-EMB and installed a matching driver forcing windows to do it. Obviously there's a malfunctioning icon and report about it.
    Now I read here that the integrated lan is changed in the latest board version.
    I'll search for a Marvell 88E8001 Gigabit Lan PCI Controller driver and see.
    Am I right?
  8. ziozeus

    ziozeus TS Rookie

    I'm happy to say I solved my problem downloading a driver for the right gygabit device.

    Marvell 88E8001 Gigabit Lan PCI Controller

    I forced window to install it and now it works!!!!!

    NB: It was definitely not included in my asus installation CD nor in any nVidia package.
  9. JoVankaam

    JoVankaam TS Rookie

    MARVELL and A7N8X-E

    Hi, guys, may be this could help some of you

    The PCI Ids in the .INF file for MARVEL drivers DOES NOT MATCH the one the MARVELL 88E8001 chip returns, this prevent the driver to install.

    To get the network on download the last driver for XP/2003 from the Marvell web site, unzip the file and update the .INF file with the correct PCI id

    The one in the original .INF file is VEN_11AB&DEV_

    replace all the occurences of VEN_11AB with VEN_1148 (the ID the 88E8001 returns) using the notepad.

    Then use the manual installation process and wonder all is right now.

    I do not understand why this PCI id is wrong maybe MARVELL change its vendor ID due to some conflicts or legal issue.

    Hope this could help anybody.
  10. Train22

    Train22 TS Rookie

    Thanks for the post JoVankaam, I tried this and now my Marvell Gigabit LAN port is working.

    Where did you find this information? I have not been able to track anything like this down anywhere I have searched.

    Thanks again.

  11. Grimmy

    Grimmy TS Rookie

    Hi all

    Just ended some hours of debugging my friends p5ad2, we got the "usual" problem.
    Marvell NIC completely unavailable in System management->device manager, added to that some of the PCI Express Root hubs were also marked with the yellow icon.

    So when did it turn up?
    When XP SP2 was installed! Everything worked just fine before with SP1. After install all NICs were unavailable and the PCI Express root hubs had warning symbols on them (Error code 12: This device cannot find enough free resources that it can use)

    When looking at the installed driver for these Root hubs it turned out that the pci.sys has updated to version xpsp2, we performed a rollback driver on them and viola, everything got back to working condition.
    (How to rollback: enter device manager, right click, select update driver, press the rollback button)

    Additional info:
    During our quest for working network we did install the very latest drivers found in the intel ftp referenced in previous post LAN_XP2K_7.24.1.3_PV.exe

    NICs worked on SP2 with the supplied driver so I dont think this matter but you never know!

    Dont touch a working system! We did manage to get it working again but who knows what fixes are missing now as we "downgraded" from pci.sys sp2 to sp1.
  12. ELW

    ELW TS Rookie

    It Worked!

    Thanks Grimmy! :wave:

    Thanks to your post, I too discovered that the root cause of my problem was the pci.sys upgrade from Win XP Service Pack 2.

    In addition, I have an Appian Graphics video board that may be another element interacting to cause the problem.

    The pci.sys from SP2 prevented the following Asus P5AD2 motherboard devices from loading in Win XP's device manager:

    Intel 82801FB/FBM PCI Express Root Port - 2662
    Intel 82801FB/FBM PCI Express Root Port - 2660

    This in turn prevented the onboard Marvell LAN controller from loading.

    When I downgraded the pci.sys file to the SP1 version, the two PCI Express Root ports loaded properly, and Windows finally was able to 'see' and enable the Marvell LAN Controller.

    Version 5.1.2600.1106 of pci.sys is attached. This is the older version that fixed my problem.

    Go into safe mode and install the file in \windows\system32\drivers\. Safe mode is required because in regular mode I found that Windows reverses any modification of key system files, such as pci.sys -- e.g., I would copy in the replacement SP1 pci.sys and within a couple seconds the SP2 file would show up again in its place. Hover over the file in a file manager window and you can see its version number.

    Having said all this, I'm not comfortable with this as a long term solution. Pci.sys is now out-of-sync with the rest of the SP2 files. It will have to do for now.

    We need to let Asus know about this problem so that they can pursue a proper solution with Microsoft.

    Good luck.

    Attached Files:

      File size:
      37.9 KB
  13. trachei

    trachei TS Rookie

    My friend has this board and we can't get his LAN connection to work. I downloaded the latest drivers from the site, the 7.2413 version and I changed the VEN numbers as you said, but when I go to chose those drivers it says its not compatible. I assume its cause the vendor IDs don't match. If I leave them alone the drivers will install but I get no improvement in the network.

    On a side note, it did install the LAN connection(Marvell Yukon 88E8001/8003/etc) in my network connections but it will constantly stay at "acquiring network address" when I plug a connection in. The first network connection is the NVIDIA nForce MCP Networking and that doesn't work either.

    As of right now he has no way of getting on the net or getting a LAN connection, what are we doing wrong?
  14. -Rodri-

    -Rodri- TS Rookie

    Hi all. Same problem here. I did everything that you say, but can't make this thing work.
    One question. How do you "force" Windows to install a driver?
    And another. How may I know the PCI id from my Marvel 88E8001 chip? Because I tried the solution proposed by JonVanKaam and XP keep saying that the location doesn't have information about the hardware.

    Thanks in advance, and sorry about my lame English.
  15. ewizard2

    ewizard2 TS Rookie

    Gigabit Lan on Asus P5GDC Deluxe / Now working

    Hello Everyone,

    Thank you so much for posting this information. I finally got my onboard nic working with the help of this posting.

    After I install service pack 2 I was not able to use my onboard nic card (Marvell 88E8053 PC Express Gigabit Lan Controller)

    I also noticed the following devices were not working properly:

    Intel 82801FB/FBM PCI Express Root Port - 2662

    So I rolled back the drivers and not my nic card is working.

    To roll back the drivers
    go to my computer
    --> manage
    --> Device Manager
    --> System devices
    ---> double click on driver name
    ---> go to driver tab
    ---> click on Roll back

    Thanks again.
  16. xaverion

    xaverion TS Rookie

    Thanks a lot for this...
    I had the same problem. After doing a lot of search I finally found this Forum and your advice. Everything now works pretty well !!
  17. Stock Lady

    Stock Lady TS Rookie

    Pci.sys change worked for my Appian-NIC conflict also!

    Thanks so much to Grimmy and ELW! I was running my Appian Rushmore quad video card fine on my networked Dell Dimension 4600. But when I installed everything on my new Dell Precision 470, the onboard NIC did not show up in device manager. Your instructions for downgrading the pci.sys file to the 5.1.2600.1106 version were super. I now have everything working. However, whenever I restart or shut down, I have to re-enter the file again. I did copy the file into c:\windows\system32\drivers while in Safe Mode as you suggested. Any ideas? Should we revert back to SP1 entirely instead of just this one file? Thanks a bunch again--I'd been working on this problem for two weeks. Please let us know if you find a permanent solution.
  18. anarior

    anarior TS Rookie

    Is it a A7n8x-e deluxe damage?

    I have one here, that can't configure gigalan, tried modify driver, but windows don't recognize. Why few persons have this problem? thanks
  19. XToaster

    XToaster TS Rookie

    I am having a similar problem with mine but with a little twist.
    It never did see the marvell adapter. When I decided to add a couple SATA drives I enabled SATA and put the drives in. The SATA bios did not appear. I tried many thing to fix this. Thinking I can't use the gigabit connection anyhow, I disabled it with the jumper. I rebooted the system and my SATA is now working, if I enable the gigabit, SATA does not work. And the gigabit is missing. :confused:
  20. anarior

    anarior TS Rookie

    really, its a damage in your mother board

    In 8 (eight) moterboards, only one was with this problem. I supose that it's damage. i give this motherboard to fornecedor (store) ande the other is ok. I think that de gigabit lan was avariated.
  21. ELW

    ELW TS Rookie


    Stock Lady, do a search of your entire hard drive for pci.sys. There is probably a copy of the newer Sp2 version sitting on your hard drive somewhere. Replace all copies with the older SP1 version. Reboot and do another search. Hover over each file to check the version number.

    In the end I scrapped my Appian card and switched to 100% Matrox cards. My opinion is that they are better.

    Good luck.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...