Graphics card/irq problem

By Kaiser · 18 replies
Jun 6, 2002
  1. I am not sure where to post this so I decided to choose this one because it has to do with video/grahpics.

    People told me that having componet's irq number matching another componets number is bad. But I really don't know for myself, sorry I am dumb when it comes to this, so I need someone to let me know if the irq window pic below is good or bad. My Gerforce 3 matches with two other componets and need to know if I should try to change the numbers/reinstall drivers.

    thanks for your time....

  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Maybe you could start off with some info on your System's hardware & OS. Things aren't solved the same way if you're using a Win9x OS or 2K/Xp one.

    Before you start messing around with anyting, I have to ask you this : Is your system giving you problems as it is ? People say a lot of things, not much of it is true.;)
  3. uncleel

    uncleel TS Rookie Posts: 980

    IRQ conflict?
    control panel> system> device mgr> computer>
    did you check for Yellow (!) any conflicts?
    What irq's your using (they're listed)

    Depending on your Motherboard & Bios:
    Go into BIOS,see if there's a pnp/pci configuration.
    on the Rh side should be four "pirq" settings.

    Manually assigning the IRQs is possible in the "PnP/PCI configuration" BIOS submenu.
    PIRQ_0 is for AGP and PCI-1
    PIRQ_1 is for PCI-2 and PCI-3
    PIRQ_2 is for PCI-5
    PIRQ_3 is for PCI-4, PCI-6 and USB controllers.

    The AGP slot and PCI-1 share an IRQ
    PCI-2 and PCI-3 share an IRQ
    PCI-4, PCI-6, and USB controllers share an IRQ
    PCI-5 has its own IRQ

    Locks up in 3D applications
  4. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    okay, before, the geforce 3 had the same irq number as the sound card. which was causing locks in 3d apps a lot.

    I fixed that, by reinstalling the drivers, but yesterday I noticed the geforce 3 sharing with other devices again, (as in the pic I posted) and its sharing with the two usb controller.

    so far, I haven't ran into any lock ups, YET.

    I plan on running 3d mark and leaving some 3d demos on for 4 hours or so to see if nothing locked up.

    but so far, nothing bad happend.

    I checked device manager and I came across no errors, I checked the nivida display moniter icon, says its working properly.
  5. TS | Crazyace

    TS | Crazyace TS Rookie Posts: 275

    There should be a setting in the bios that assings a specific IRQ JUST FOR VIDEO..
  6. Vehementi

    Vehementi TechSpot Paladin Posts: 2,704

    Gah...Kaiser, how can you read your Windows color scheme...Black on dark blue, :dead: terrible for your eyes.

    After unc's post I really don't have anything to add :dead:

    Just thought I'd remark on your color scheme :stickout:
  7. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    alright, now I am noticing lock ups in games, usually after 6 or 8 minuites when I am playing 3d games.

    I have a MSI Kt7 Turbo for my mobo, I hate messing with the bios, so can anyone guild me to fix the irq problem. I just want to make where my geforce 3 isn't sharing any irq numbers.
  8. JAV

    JAV TS Rookie Posts: 210


    Hmm, what version of Windows are you running? My card shares an IRQ with my modem, but I have a PCI card. No problems tho'.

    Been so long since I looked at my IRQ's I can't remember how. LOL! Refresh my memory on how you pulled up that window you posted, please. :blush:

    Do you have anything connected to those USB ports? I have a mouse, keyboard & JS on mine & can/do also hook up a camera. No conflicts. All are set at 'Auto-Configure' in system>device manager>properties too.

    If you can remind me how to get that 'table' I'll look at mine & we can compare & *maybe* that will help. ;)

    No answers (sorry) but I'll try to help you diagnose it, if I can
  9. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    Windows 2000

    for my usb, I am using a external floppy and my dsl modem.
  10. JAV

    JAV TS Rookie Posts: 210


    Process of elimination then: disconnect each & see if there is a difference. I don't *think* it's the floppy drive because you prolly aren't using it when playing, but that DSL ... :confused:

    If you unplug it & the problem ceases: change it's IRQ thru 'Device Manager' would be my suggestion.

  11. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    I have 5 components sharing irq 11 and havent had any problems.
  12. uncleel

    uncleel TS Rookie Posts: 980

    IRQ's in the BIOS submenu

    Read my above post
    RE: Manually assigning the IRQ's in the "PnP/PCI configuration" BIOS submenu.
  13. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    Re: IRQ's in the BIOS submenu

    I hit enter on irq slot 11 and I was given a choice between pnp and Legacy isa.
  14. uncleel

    uncleel TS Rookie Posts: 980

    Re: Re: IRQ's in the BIOS submenu

    Make sure nothing goes in the 1st pci slot under the agp slot.
    see if you can manually assign IRQ 9 for your vid card
    & IRQ 5 for your sound card. You may have disable PnP aware OS. Leave the rest on AUTO.
  15. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    well, it appears my sound card is below my video card, so tomorrow I'll move the sound card to the next slot.

    btw, is there any way to change the irq numbers in windows?
  16. uncleel

    uncleel TS Rookie Posts: 980

    Rather than radomly switching cards around in pci slots...
  17. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    in the bios, I have PIRQ_0 selected, it on the right side of the screen it says

    devices used:

    bus 1: Display controller
    bus 0: usb controller
    bus 0: usb controller

    no matter what number I changed in the PIRQ_0, it always share those three.

    I changed it to 5 and now those three are sharing irq 5, and still causing conflicts.

    PIRQ_3 isn't being used, how can I get it to use the usb controllers? I tried having it use irq 11 but still no luck.
  18. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If you don't have any USB devices, you could just disable USB controller(s) from BIOS.
  19. Kaiser

    Kaiser TS Rookie Topic Starter Posts: 25

    thats the problem, I am using both usb slots for my dsl and external floppy drive.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...