Guide: Bypass access denied error when accessing data from different XP/2000 install.


Posts: 4,049   +13
Rick said:
If you are running Windows XP Home Edition, in order to have access to the Security tab, you must first start in Safe Mode and log on with an account that has Administrative rights.
Read more carefully, mmak ;)
Thanks for the help.
I'm running XPmedia and on an external firewire drive, I thought I had lost/corrupted some media files when I moved them from one folder to another. I enabled sharing and I was able to view them again.
Thanks again.

Victor Fabian.

solution found through google-to here.
This post is great, it helped me get all of my old locked files back, but now i have another problem...

i changed all the ownerships on the folders which i needed to access, and then i made a couple of new users, trying to get this install of XP Home as close to the last one as possible, but now, only one user can be logged on at a time. what happens when a user is already logged on and you try to log on another from the log in screen, is the screen just flashes blue for a second and the returns to the log in screen.

i need help bad! thanks alot for helping me so far!!
Vigilante said:
I've done this a lot on hard drives when hooked up to a 2nd machine, to get data off. Go Microsoft, make it so easy to protect all your data and hide it. Only to make it equally easy for someone to take it right back :)

What about installing a PARALLEL Windows OS on the same disk (without formatting and leaving current file system intact of course) and then "take ownership" of the other user's documents (user that is password-protected and has admin privileges) from there? Can it be done?
ok guys heres one for you to ponder over. i had my pc on when i was called for my dinner. so i went to eat it and when getting back to my pc i realised it had shut itself down. i could not load it back up as it would just fail before it got to the windows xp logo. i realised that my motherboard must have died on me. so for the time being i had no working computer. when i finally got a new one i put my old hardrive into my new pc as a slave and everything loaded fine. however i can acces all folders in my old drive except for my users folder. this had some very important documents within it which i need back. i have tried everything mentioned on this forum, except for running it in safe mode. this is because when i attempt it, it gets to a certain point of loading(the black screen with all the white writing) and then it freezes! However when i try to run my new hardrive on its own in safe mode it works fine. can someone please tell me what is wrong as i cannot take control of the folder as i cannot obviously access the security settings. please do not tell me my hard drive has died aswell. i will try to get the name of the point at which it freezes. thanks guys
Hmm - I have a problem with the 'Use simple file sharing (Recommended)' option (in that it's not visible!)

Any ideas would be greatly appreciated! Thanks,

Simple file sharing : /

Hi guys, im having the same proplem PLEASE can you help! I cannot see the option for simple file sharing in the folder options > view > advanced settings area! I have tried what someone said previously about running the network setup wizard first with file sharing enabled, and then with it disabled and still cannot see the option there! This is so frustrating because every fix I can see anywhere including the microsoft support website requires you to disable simple file sharing and noone tells you what to do if it isnt there!! So pls pls pls im begging you can you help me! I have tons of stuff that is locked in an old my documents folder that i cannot access because I had to reinstall my operating system! This is life or death lol
Thanks for your time and efforts

OK! An update, I have done it! I made a mistake that is that I thought I was using XP Pro, but in fact I was using XP Home! So by starting in safe mode I was able to take ownership of the folders retreiving my info! Thanks a lot guys I dont know what I would have done without you! :D
Techspot ROCKS!


Posts: 9   +0
Hit windows key + R (or Start > Run), type this into the Run window:

This brings up the console, now type:
cacls g:\* /t /c /g everyone:f

cacls <- change acls (security descriptors granting/denying permissions)
g:\* <- my old hdd, the \* means to affect every file/directory in the g: directory (but not the subdirectories)
/t <- makes it affect subdirectories and files
/c <- makes it continue when it encounters an [access denied]
/g <- grant permission
everyone:f <- give everyone full control

Access Denied

Ok, I read the entire thread and did as suggested.
Here is my scenario...
I had a hard drive from anouther system, both winxp home.
the second drive is denied my access to all the files on that drive.
I did a backup, reformatted the drive, installed the drive using maxblast.
I restored the backup, tried the safe mode method, I enable full control for all users, still denied.
Now when i reformatted the drive there was still a folder on the drive after format, "volume information" or simular to that.
I cant get rid of that folder and wonder if thats where the permissions are getting messed up.
I lose you yet?

Maybe I am getting Too old.... :confused:


Posts: 6   +0
how about if you are running windows vista sir? i want to delete the old xp installed folder (windows.old.001, if remember it correctly), "access denied" everytime i tried to delete this folder.

I know this is a pretty old thread. I am setting up this account to say thanks to Rick. Your tips has helped me to save my document files before I format the infected drive.

Thank you!!!