1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

HDD won't show up on my computer!!

By Jim1556 ยท 10 replies
May 31, 2006
  1. Hi ppl,

    I'm new on here so any help would be appreciated.

    OK, After several days of annoyance, I decided to reformat my PC... I've been running XP on a 120GB HDD - 2 partitions both NTFS and approx 60GB C: and D:.

    All my important stuff is kept on/transferred to an old 20GB drive (FAT32) from my first PC which I've never had problems with.

    Successful reformat of C: and D: only to find I can't access anything from my old drive, it doesn't appear on My Computer but is recognised on the BIOS, Device Manager and Disk Management, it has no label or drive letter assigned to it and right clicking on it in Disk Management only allows 'Delete Partition' and 'Help'.

    Windows Help or Troubleshooter are no help at all.

    There are no crosses or conflicts on the drive in Device Manager which says the drive is working properly.

    It seems the drive is still working and if I could assign a letter to the soddin thing it'd work (maybe).

    Sorry its a bit long winded, I thought I'd include all the info I have.

    Please help as I've got docs, music, and a lifetime of pictures that are irreplaceable!

  2. PDusome

    PDusome TS Rookie Posts: 21

    Drive Away

    You may have a drive lettering collision. Was the old drive attached to the system when you did the original transfer or did you transfer across computers?

    Is it possible to reinstall the old drive in the old computer and copy across a network?

    Can you see the old drive when it's the only one attached (if not bootable, can you see it when booting from floppy?)

  3. Jim1556

    Jim1556 TS Rookie Topic Starter

    Thanks for replying...

    Its been fine in the current configuration for the last year, I've also tried the drive in a mate's computer with the same results (visible in BIOS n Disk Management etc but no drive letter or access).

    The old PC is knackered (PSU problem) and was thrown out last year.

    Not tried the bootable floppy - The old drive has no operating system (slave) is this still possible?

    Just to clarify, the drive was my back up and remains inaccessible, formatting while possible isn't an option cos of the data it has on it.
  4. PDusome

    PDusome TS Rookie Posts: 21


    I'm not sure where to go from here. The bootable floppy may work. Nope, you don't need to have OS on the drive if booting from floppy.
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    could always try 3rd pary manager like paragon or acronis
    they may force a drive letter ,it has worked for me
    they will tell you what type of file system is on disc
    all fails a recovery software will find all and get back
    when you right click (in device manager) can you nav here
    do not use cable select in tests
  6. Jim1556

    Jim1556 TS Rookie Topic Starter

    Cheers guys - still no closer...

    Its a Seagate drive by the way but Acronis thinks its an unsupported drive (worked fine for 7 years) and another freeware data recovery program can't see it (no drive letter) so won't attempt recovery.

    Its FAT 32, I get the usual options in device manager but still no drive letter or access.
  7. wlknaack

    wlknaack TS Rookie Posts: 143

    Do you have WinXP installed in only one of the two partitions, or do you have it installed on both partitions, and are in a dual-boot situation? Are the two partitions C: and D:? Please explain the setup.

    What was the drive letter of the 20GB HDD before you reformatted the 120GB HDD? What are the drive letters of any other storage devices you have installed on your computer. Were all storage devices installed when you reformatted and rebooted the 120GB HDD? Please list all storage devices and what their assigned letter was/is before and after the reformat.

    You may have a conflict in the recognition/duplication of drive letter assignments. If so, we can look at possible solutions when we know the answers to the above questions.

    Also, to save time, please go to bootdisk.com and download and create a Win98 Boot Disk. It is possible you may need it to sort things out.
  8. Jim1556

    Jim1556 TS Rookie Topic Starter

    The big drive is C: and D:, XP is only on C:

    The old drive was E: and as I said was fine for a year or so in that set up...
    I have 2 CD Drives, currently F: and G: (I can change all drive letters in Disk Management except the old HDD - DM won't give me the option.

    Just tried a Diagnostic boot up floppy from Seagate's website but it crashes half way through a quick scan/test of my old drive.

    Its soo frustrating to see everything connected, visible in the BIOS n Device Manager but not be able to get to any data!

    Thanks for the help so far but no success yet.
  9. Jim1556

    Jim1556 TS Rookie Topic Starter


    Erm, not quite sure how... I've been trying allsorts and eventually after reinstalling Norton Systemworks 2005 for the 2nd time (after this morning's reformat cos of internet problems, nothing changed after the first).

    iRecover works to get files back from an invisible HDD, costs n the free version would take days to do it properly but thanks to those guys anyway.

    Anyway, suffice to say I'm backing up all my data onto DVDs n I hope no one else goes through what I did.

    Thanks to all those who offered help n advice.
  10. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Just out of curiosity> How did you have that drive jumpered?
    If you were using Cable Select, I have seen confusion in XP with this setting. I know that it is best to use the exact configuration settings eg. Master/Slave.
  11. Jim1556

    Jim1556 TS Rookie Topic Starter

    There are no jumpers ie, the pins are all clear as it is printed on top of the drive if its to be used in slave mode.

    Wasn't using Cable Select.

    It seems fine now though.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...