1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Help interpreting minidump contents

By cybersyn ยท 4 replies
Nov 22, 2007
  1. Hello everyone,

    I'm a little new here so please bear with me, I'll try to be as thorough as possible.

    first, the prologue:

    After about 9 months of rock solid performance, I was sitting at my pc one night when I experienced a totally random reboot. Never a good sign I know, but being the busy, somewhat lazy person that I am, I didn't pay it much attention. Well, it happened a couple more times over the last 3 weeks, and then last night after a lot of cs:source I restarted my computer and received a message saying:

    Windows could not start because the following file is missing or corrupt:


    You can attempt to repair this file by starting Windows Setup
    using the original Setup CD-ROM.

    Select 'R' at the first screen to start repair.


    I reboot a couple times but just keep getting the same thing. and then just before I was about to start the repair option, windows booted up like normal.....or so i thought for about five minutes before it bluescreened on me, with this stop ID: 0x0000008e 0xc0000005 ....................It then proceeded to BSOD with that stop message within 3 minutes of turning on OVER AND OVER regardless of the many things I tried. I could get into windows, but once there I couldn't execute anything. I could move files around (I backed up some stuff on my other hard drive before the BSOD happened. But I couldn't run any kind of program)


    So, i started testing hardware.

    1. Ram: this was really strange. I have 1 gig of crucial ballistix pc4000 that is about 9 months old. has tested in memtest fine in the past. I ran memtest and the first time there was a restart, then the second time there were ALOT of errors, like 385 on the first pass.....I was actually kind of happy, i thought that was the end of my trouble, a simple RMA would take care of things. WRONG. when I ram memtest on each stick individually to find out which one was the culprit, they both passed fine. I then ran the test on both of them again, and it passed! i let the test go through 5 passes and it passed with flying colors. WEIRD.......maybe a dust issue? i have since cleared the ramslots with compressed air and havn't had any further ram issues

    2. Video card is definately not responsible, tried several others all with the same results

    3. Hard drive. Now I could have sworn this was the end of it. I swapped out my hard drive for another which I know for a fact works perfectly, and when I did I didn't get any errors at all, booted up like a champ. SWEET, so the problem is either a physical issue with the drive, or something related to the software on the drive, right? cool. so with that in mind...........

    I then decided to slap the more than likely "problematic" hard drive back in, boot to the windows cd and run the repair option........thats all done, NO MORE BSOD's! instead, i started getting hard locks instead, but now they were at any time, not just after boot.

    Several hours of google-fu later, I've learned about the windows debugging utility (a little) and so I start taking a look at the dump files associated with all the crashes i've been having in the last 24 hours. (i'll post the text from the debugger in a second)

    every single minidump file refferences: ntkrpamp.exe

    here is the contents of the latest dump file (which was actually several hours ago, longest period of time between crashes since this began happening)

    Microsoft (R) Windows Debugger Version 6.8.0004.0 X86
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [C:\WINDOWS\Minidump\Mini112107-23.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: SRV*c:\localcache*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows XP Kernel Version 2600 (Service Pack 2) MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 2600.xpsp_sp2_gdr.070227-2254
    Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055c700
    Debug session time: Wed Nov 21 09:06:31.718 2007 (GMT-8)
    System Uptime: 0 days 0:02:07.421
    Loading Kernel Symbols
    Loading User Symbols
    Loading unloaded module list
    * *
    * Bugcheck Analysis *
    * *

    Use !analyze -v to get detailed debugging information.

    BugCheck 1000008E, {c0000005, 806354df, ae99299c, 0}

    Probably caused by : ntkrpamp.exe ( nt!HvpGetCellMapped+5f )

    Followup: MachineOwner

    0: kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    Arg1: c0000005, The exception code that was not handled
    Arg2: 806354df, The address that the exception occurred at
    Arg3: ae99299c, Trap Frame
    Arg4: 00000000

    Debugging Details:

    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

    806354df 8b4304 mov eax,dword ptr [ebx+4]

    TRAP_FRAME: ae99299c -- (.trap 0xffffffffae99299c)
    ErrCode = 00000000
    eax=00000400 ebx=00000400 ecx=867ba480 edx=00000003 esi=e1038008 edi=00000041
    eip=806354df esp=ae992a10 ebp=ae992a58 iopl=0 nv up ei pl zr na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010246
    806354df 8b4304 mov eax,dword ptr [ebx+4] ds:0023:00000404=????????
    Resetting default scope




    PROCESS_NAME: services.exe

    LAST_CONTROL_TRANSFER: from 8062dee4 to 806354df

    ae992a58 8062dee4 e1038008 00640041 e1038008 nt!HvpGetCellMapped+0x5f
    ae992a74 80636d3c e1038008 cf290a7c e1038008 nt!CmpMarkValueDataDirty+0x44
    ae992a90 80636fe1 e1038008 0025f738 cf3030cc nt!CmpMarkKeyValuesDirty+0xcc
    ae992aac 8063707e e1038008 0025f738 cf1a073c nt!CmpFreeKeyValues+0x17
    ae992ae8 806378bc e1038008 000f0f40 cf0f1f44 nt!CmpSyncKeyValues+0x26
    ae992b2c 80637a2f e1282000 00000400 00000003 nt!CmpCopySyncTree2+0x1f4
    ae992b5c 806244e9 e1038008 000001b8 e1038008 nt!CmpCopySyncTree+0x4f
    ae992ccc 8062013a 00010002 ae992d64 ae992ce8 nt!CmpSaveBootControlSet+0x2a7
    ae992cdc 8054086c 00000004 ae992d64 804ff995 nt!NtInitializeRegistry+0x5e
    ae992cdc 804ff995 00000004 ae992d64 804ff995 nt!KiFastCallEntry+0xfc
    ae992d58 8054086c 00000004 0007fe8c 7c90eb94 nt!ZwInitializeRegistry+0x11
    ae992d58 7c90eb94 00000004 0007fe8c 7c90eb94 nt!KiFastCallEntry+0xfc
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    0007fe8c 00000000 00000000 00000000 00000000 0x7c90eb94


    806354df 8b4304 mov eax,dword ptr [ebx+4]


    SYMBOL_NAME: nt!HvpGetCellMapped+5f

    FOLLOWUP_NAME: MachineOwner


    IMAGE_NAME: ntkrpamp.exe


    FAILURE_BUCKET_ID: 0x8E_nt!HvpGetCellMapped+5f

    BUCKET_ID: 0x8E_nt!HvpGetCellMapped+5f

    Followup: MachineOwner

    any help or insight with this problem would be greatly appreciated.

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You don`t get any problems at all with the other hard drive your tried?

    If that`s the case, then I suggest you test what may be a faulty hard drive with the manufactures diagnostic utility. If you can`t find it, take a look at this thread HERE.

    Please let us know the results.

    Also, go and read this thread HERE and see if it helps you to identify the culprit.

    If it doesn`t, please attach 5 or 6 of your latest minidumps.

    Regards Howard :)
  3. cybersyn

    cybersyn TS Rookie Topic Starter

    No, I was not getting any problems from the other hard drive at all.

    So, after i posted this thread last night, i defragged my computer while in safemode, then decided to let memtest86 run while I was asleep.....turns out that the memory was generating errors again (i'm definately replacing the ram) so once again, I thought I had found the source of the problems. I turned my computer off, took out the faulty ram, put in some good ram, then turned on the computer......

    blank screen, no POST.

    tried again with the memory in different ram slots on the board....no POST.

    tried another set of ram. no POST

    everything else in the computer turns on, all the fans run, the leds on the motherboard and videocard turn on, the lights on the monitor and the dvd drive turn on, but the computer doesn't post.

    So, i tried putting my original ram back in to see what happens. It still didn't work of course but I noticed somthing interesting......you see, i had been using 1 gig of crucial ballistix tracer pc4000. It has multiple LED's that blink when the computer is on, there are red and yellow LED's on the top of the ram, and blue LEDs on the bottom. When i turn on my computer with this ram in, the blue LED's on the bottom flash once and the red and yellow LED's don't turn on at all anymore.

    another interesting thing about the situation is that, when i turn on my computer, my dvd drive lights up, then turns off, then lights up again all the while making little servo noises, as if the dvd is repeatedly trying to do somthing, it sounds like a broken record.


    at this point here is what I am thinking that either my power supply, motherboard, RAM, or some combination of the three are malfunctioning.

    I'm going to RMA the memory and the powersupply right away, install the replacements and see if that solves my problems. if not, i'm betting on the motherboard being fried.

    des that make sense?
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Yes, that makes perfect sense and I must admit, I too am starting to suspect a faulty psu/mobo.

    Let me know how it turns out.

    Good luck.

    Regards Howard :)
  5. cybersyn

    cybersyn TS Rookie Topic Starter

    cool, at least my reasoning is sound, if not my hardware :)

    I'll update this thread as my returns are issues and installed.

    in the meantime, i'm looking at possibly having to replace my motherboard, and since socket 939 has been discontinued (for no freaking reason I might add) my choices aren't exactly as great as i'd prefer. I have found a good deal on an asus a8v-xe, anyone know if this is a decent overclocker?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...