How to remove write protection of USB mass storage with no visible lock/unlock

I am seeking help either immediate help or as soon as someone gets a chance... please.

I bought a usb flash drive (my laptop recognizes it as a generic usb mass storage device) from the library... cheap I know... anyways I was using it prepairing to restore my pc... I removed it without clicking on the safely remove button and now it says cant remove files because its write protected... and it wasnt before... did I mess it up if not then how do I remove a write protection if I have no lock/unlock switch deal? I scaned it for viruses/malware etc... I can view all the files but cant delete them and I wanted to clear them off so I can use it for another purpose... can anyone help please...
 

jobeard

Posts: 13,970   +1,778
insert the USB device, then

control panel->Admin Tools->Disk Management

Your boot drive will show as C:\ and under
Layout will be Partition
File System will show NTFS

How does your USB show up?
 

LookinAround

Posts: 6,430   +186
One more thing to check:
> Click Start->Run, enter: regedit
> Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
> Does sub-key StorageDevicePolicies exist? If yes, right click to delete this sub-key
 
  • Thread Starter Thread Starter
  • #4
an answer for both of you....jobeard and lookinaround

well....the usb mass storage device in question shows up as drive F D or E depending on which usb whole thing...im soooooo aggrivated over this whole ...no pun in intended was just a typo....thing isnt good....anyway um...im gonna try both of the suggestions...and ill let you both know what happenes tomorrow...thank you for responding....


also i got anitvirus issues i didnt even know about until earilier today.....argh
 

jobeard

Posts: 13,970   +1,778
hmm; how does the Disk Mgr show the layout (not the drive letters)?
If it doesn't show Partition, then we need to reformat the device.
 
I have this same problem and the usb stick is an emtec 32gb. It has no switch and I have looked all over the registry to see if I could find that entry Storage Device Policies and it is not there anywhere that I can see. I cannot format the drive as it is write protected and it will not allow me to delete or change the partition either. I am at a loss as to what to do. Is this a one-way event which has now made my usb drive useless?
 
The same problem about write protection issue.. and it messing me up.. I don't store any file on my USB. it always lead to write-protected thing..I can't reformat also because of that write protextion.. can you help me take this issue thank you
 

jobeard

Posts: 13,970   +1,778
I found this; how to make it R/O
To setup read only USB storage device operation, follow these steps below:

Click on the Start Button and type in Regedit and hit Enter.
Navigate through HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
Right click on Control and select New and then Key. Call the new key StorageDevicePolicies.
Right click on StorageDevicePolicies and select New and then Dword. Call the new dword WriteProtect.
Right click on WriteProtect and select Properties. Set the value to 1 and hit OK.

The computer is now configured to disable writing to USB storage devices.
So if you go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
look for StorageDevicePolicies -- if found, open it and look for WriteProtect - - delete the key
 
One more thing to check:
> Click Start->Run, enter: regedit
> Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
> Does sub-key StorageDevicePolicies exist? If yes, right click to delete this sub-key

if storage device policies doesnt exist? what do I do now. im having the same problem. thank you in advance
 
I do everything like shown below: But again when I want format USB drive 8 gb show me message write protected.
WHO CAN HELP SLOVE THIS PROBLEM, PLEASE

[SIZE=12px]To[/SIZE][SIZE=12px] setup read only USB[/SIZE][SIZE=12px] storage device operation, follow these steps below:[/SIZE]

[SIZE=12px]Click on the Start Button and type in Regedit and hit Enter.[/SIZE]
[SIZE=12px]Navigate through HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.[/SIZE]
[SIZE=12px]Right click on Control and select New and then Key. Call the new key StorageDevicePolicies.[/SIZE]
[SIZE=12px]Right click on StorageDevicePolicies and select New and then Dword. Call the new dword WriteProtect.[/SIZE]
[SIZE=12px]Right click on WriteProtect and select Properties. Set the value to 1 and hit OK.[/SIZE]

[SIZE=12px]The computer is now configured to disable writing to USB storage devices[/SIZE]
 
Run regedit
click on edit/permissions
make sure read and full control are checked for permissions for all that are listed
unplug USB replug it in
write protect should be removed
 
Depending on the type of usb stick it could be a mechanical issue..I have a stick that I could not format due to a write protected error...I popped open the housing of the stick only to find a capacitor looking device shorting against the contacts of the memory chip..I moved the device away from the contacts ,plugged it back in to the PC and was able to preform a format...so if you have dropped or tapped your stick ,this could be a fix ,it was for me
 
There seems to be no help in this forum. You must begin as if people have no idea of what they are doing.
I have the problem of not being able to write on a flash drive. I sell flash drives and used one I sell. I downloaded 4 movies on the flash drive and suddenly I got the message that it is write-protected and I can not write on it. I did use expressfile to download them but expressfile messed up the internet connection. I would not recommend that to any.
None of the above solutions work. I wonder how the write-protected got on to the flash drive after downloading so many things. It was not write protected but suddenly became write protected.
 

learninmypc

Posts: 9,276   +684
There seems to be no help in this forum. You must begin as if people have no idea of what they are doing.
I have the problem of not being able to write on a flash drive. I sell flash drives and used one I sell. I downloaded 4 movies on the flash drive and suddenly I got the message that it is write-protected and I can not write on it. I did use expressfile to download them but expressfile messed up the internet connection. I would not recommend that to any.
None of the above solutions work. I wonder how the write-protected got on to the flash drive after downloading so many things. It was not write protected but suddenly became write protected.
Be patient, you'll find better help here than other forums.
 
I have the one and only answer. But 1st, let's dispatch some myths: #1 - This is not a Windows or software problem. #2 - There is no registry fix, and this is not malware related. So, I have had this problem over time, with many different makers USB flash drives. I can assure you that the problem is with the physical drive and not the PC. So, what needs to be done is reset the physical USB device, and to do this you need a utility to do this. Formatting the device will not work, you essentially need to reset the controller on the device with a utility that specifically does this. I can almost 100% guarantee all data will be lost on the device, so make a backup before doing a reset. Start off with the HO format utility, but when that does not work you will have to Google for the reset utility, it was from a known flash drive maker, maybe Sandisk or Crucial? It is simple to run, it reset the controller onboard the flash device, then you are free to format it and use it like normal. Sorry I could not find a copy of the file, not sure where I put it. David
 
I have the one and only answer. But 1st, let's dispatch some myths: #1 - This is not a Windows or software problem. #2 - There is no registry fix, and this is not malware related. So, I have had this problem over time, with many different makers USB flash drives. I can assure you that the problem is with the physical drive and not the PC. So, what needs to be done is reset the physical USB device, and to do this you need a utility to do this. Formatting the device will not work, you essentially need to reset the controller on the device with a utility that specifically does this. I can almost 100% guarantee all data will be lost on the device, so make a backup before doing a reset. Start off with the HO format utility, but when that does not work you will have to Google for the reset utility, it was from a known flash drive maker, maybe Sandisk or Crucial? It is simple to run, it reset the controller onboard the flash device, then you are free to format it and use it like normal. Sorry I could not find a copy of the file, not sure where I put it. David
SOLVED My Friend

Thanks a lot, it was very helpfull, I just signed at this site to can give you all the thanks.

Keep on Howard
Greetings from Puebla, Mex
 
I downloaded it and it did not recognize the flash drive. I had 2 flash drives plugged in and it did not see one flash drive.
Hello,

Is the port you are using USB2 or USB3? I have found the best results are using an older USB2 port, as the USB3 chipsets vary more than USB2 chipsets and the tool was written for USB2 as USB3 was not available when the tool was designed (at least not in wide production). You can tell by looking at the USB port, is the plastic part of the USB port blue or black plastic? Most, but not all, USB3 ports have blue plastic. You can also look in Windows Device Manager.
 
Ok, so I start off with a 64GB usb flash drive that has gotten itself stuck in write protect mode, still accessible, can still view the files on it.
First I do the regedit and delete the storage policy, no change.
Then I check discmanager, it shows up as a healthy exFAT formatted partition in disc manager.
Then I try format, unable to format.
Then I download this Driver Format Tool UFIX-II, now my before I run that my computer says I have to format the drive before I can use it and it doesn't show up in the drop down of UFIX-II.
There is no physical switch on the device for anything, it slides in and out of the cover but that's it.
I stripped it down to just the actual stick that does the work, saw nothing that looked like any capacitor or anysuch I've ever worked with before, just circuits on the board, an LED and the contact strips, saw no sign I recognized as anything shorting out, put it back together and it still says must be formatted before it can be used but when I try to format it, it says "Windows was unable to complete the format" followed by a second window that says
"Windows can't format G"
"Check to see that the disk and drive are connected properly, make sure the disk is not read-only, and then try again. For more information search Help for read-only files and how to change them."