I reseated a RAM card and now my computer won't boot

By ritchie1979 ยท 15 replies
May 17, 2008
  1. I wanted to see what RAM I had so I could upgrade. I took it out and reseated it. Now my computer powers up, but my monitor remains blank! Here's what I think I've confirmed... Power supply seems to be ok, power supply fan is on, light on mother board is on. Booting up, the harddrive light activates but then remains off (does not blink). I have tried reseating both RAM cards, my video card, even my cpu. Check connections, all seem ok. I know my monitor works because I plugged my laptop into it. I'm not sure where the issue is. Before when I turned on my pc, it would beep once, now there is no beep. Doe this indicate something? HELP! I'm poor and can't afford a repair!
  2. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    Who isn't poor these days heh?

    Try clearing your CMOS and booting again.
  3. ritchie1979

    ritchie1979 TS Rookie Topic Starter


    What is my CMOS and how would I clear it if I can't I can only interact with my PC hardware?
  4. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    Because you clear it via the manipulation of PC hardware heh.

    Go take a look at your PC or motherboard's manuals. Run a search for "CMOS" or "jumper", you'll find it.

    Alternatively you can just try popping that round battery on your motherboard out for 10-15 minutes and put it back in.

    This will clear any BIOS configurations and it essentially sets your BIOS back to the factory default settings.

    Do you have an integrated VGA along with the one in an expansion slot by chance?
  5. ritchie1979

    ritchie1979 TS Rookie Topic Starter

    Thank you for your help so far :)

    I have removed the battery and am waiting now.

    I have Intel integrated graphics as well as my nvidia graphics card. I have tried using both video outputs to see if that was the issue, but it wasn't. Everything seems to have power, but nothing is processing. Maybe bad motherboard or cpu.. I'm not sure.
  6. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    If this doesn't work, which it has the potential not to, as by default the integrated VGA will probably have rights over the expansion slot card, leave your expansion slot card out of the system and try just getting a signal with the integrated VGA.
  7. ritchie1979

    ritchie1979 TS Rookie Topic Starter

    Still no luck. Looks like I may have to bite the bullet and bring it somewhere. Any last thoughts?
  8. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    If you've tried removing the expansion slot video card, then I am fresh out of ideas :). Now is when I'd remove the motherboard, and grab a hammer.

    Hang tight though, seriously. Someone else might have a suggestion or two for you.
  9. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Try restarting with only one RAM module installed at a time. Perhaps one is bad. You could have also inadvertently zapped something with static electricity when you removed the RAM the first time.

    BTW, next time an easier way to find out what kind of RAM you have is to download the freeware CPU-Z.
  10. ritchie1979

    ritchie1979 TS Rookie Topic Starter

    Ok, I tried that. Now when I turn the power on, neither fan (power or cpu) turns on. I can see that the motherboard light comes on, but that is it. Nothing else. Could this indicate a power issue?
  11. nickc

    nickc TechSpot Paladin Posts: 923   +11

    did u try each stick of ram separately, one at a time? to me that sounds like ram.
  12. ritchie1979

    ritchie1979 TS Rookie Topic Starter

    Yup, tried that!

    I tried each card of ram separately..... now since then when turn on the power, no fans come on. I can see the power light on the motherboard, but the cpu and power fans no longer come on. Any further thoughts?
  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Huh, three seconds has always been enough for me.

    It's possible that static charge damaged the memory sticks when you touched them - did you ground yourself before tinkering with the PC components? Can you test the memory sticks in another computer?
  14. Zilliak

    Zilliak TS Booster Posts: 164

    Hey just thought id say something this could be a power supply because my computer did the same thing i did all the same things you did and it was a powersupply now im getting a new motherboard after getting the powersupply someone dropped my computer and fried my proccesor socket lol
  15. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    Aye, usually, it won't take more than just a few seconds. However, one of the hardware books I've read suggests leaving it out for up to 10-15 minutes.

    If you'd like something more "in practice", some time ago a poster here attempted to clear their CMOS via popping the battery and it wouldn't work after letting it sit for a few minutes they claimed. They had to resort to using the jumper (which indeed worked). :) If you care enough to dig around for that, be my guest (I posted in the thread if it helps).
  16. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    check your PSU with a tester tool and a multimeter
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...