JetFlah USB Drive (TS1GJF2A/120 USB)

By StuCazz
Jul 30, 2007
  1. Hello,

    I'm new here and posted that here since I had a problem as well.

    The morning of 7/29/07 I went to start up my PC, which said could not load or boot. I assumer bootmbr needed repaired, so I used MS setup disk to try to repair, that did nothing/ I then tried to install on top of the old, which it would not allow me to do. So the only choice I had to reformat. Once I got everything restored to the way it was, is when I discovered the problem.

    I plugged my USB flash drive in, which was not plugged in during the above procedures. Once I double clicked it, it did not open rather it said it needed to be formatted. There was no way I was going to reformat it, because I had just updated my backups that were on there. I can not lose those, I had very important medical documents etc on there and I don't understand what could of happened. If anyone could help I would certainly appreciate. Please please, I really need help restoring this.

    Thank you very much in advance

  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Chances are that if you plug it into another PC it will work, maybe one that is running Windows 98SE if you can find one. Depends on how the drive was formatted - NTFS?
  3. StuCazz

    StuCazz TS Rookie Topic Starter Posts: 45

    You would think that would the case, however, it worked on my PC the night before, which was NTFS.

    Thank you

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...