Jump/Flash drive not recognized

By realillusion ยท 6 replies
May 9, 2005
  1. I have been using an Attache 512MB flash/jump drive for a while with my computer, my lap top, and PCs at school. This was gifted to me after my last jump drive was broken beyond repair by my school's computer settings, so I have only used it in our school library (instead of the computer lab) which doesn't have crazy security. So, naturally, when the tool that does our computer networking found out, he upped the settings in the library, and after I tried to use my jump drive at school today it seems to only half-work. It works in my lap top (where I made a back up of its contents) but not on my home computer.
    When I plug it into a USB port (I have tried two, and both ports are working fine) the PC gives me an error message saying that a device has been plugged in but it doesn't recognize the device. When I click the message for help, the great advice I get is to reinsert the device, and then replace it if that doesnt work.

    So if anyone has any idea how to fix this, I will be much obliged.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    your flash drive is hosed.

    I have had this happen to me before. Your chip either got low-level formatted in which case you'll have to send it to the factory to fix (might be more expensive than replacing it)

    OR (even worse)

    static zapped the chip.

    ALWAYS stop the device before removing it and always remove it when formatting other drives.
  3. realillusion

    realillusion TS Rookie Topic Starter

    Are you sure it is hosed? It still works in my lap top, perfectly fine.

    Also, I couldn't safely remove the jump drive from the computer in my school library because the computer refused to recognize/install the hardware (since I didn't have the security clearance to...) so there was nothing to remove, safely or otherwise.
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    Then you know it works. Your school computer system won't allow foreign connections.

    You USB drive is one, and therefore won't work on the school computer. The system adminstrator won't allow it. (It potentially could introduce viruses to the network.)

    If it doesn't work on your home computer, you'll need to get the right driver for it.
  5. realillusion

    realillusion TS Rookie Topic Starter

    (I have used it on my home PC in the past, so it's not a driver issue)

    Problem solved though. My mom fiddled around with it for a bit, and apparently the hardware list... said there were three installed USB devices when in fact there were two, so we uninstalled then and let the PC recognize them all over again. I don't know. She understands hardware, I don't, and it's fixed now--thanks for your time :)
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    then in fact it WAS a driver issue! TOO many!! :grinthumb
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Another common problem to USB, or other devices if you use Virtual Drives, is that they conflit, and usually the virtual drive wins that battle, and shows up, not your USB device. Just a heads up in the future :)

    :wave:Welcome to TechSpot:wave:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...