Keep losing my LAN connection

By tommytomotom ยท 15 replies
Nov 22, 2007
  1. Hello all,

    Leaving for work in 5 mins so will reply to any questions later. I've just built my PC and got everything up and running. Have one problem though, every 2 or 3 mins I get the pop-up in the bottom right saying that a 'Network cable is unplugged' and it reconnects literally a second later. This causes 2 or 3 second lag spikes on online games which is really annoying. It's connected to the same router as my other PC, which is having no problems. I have also tried a different cable but it made no difference. My board is an Asus P5KC and the connection that is being lost is an Attansic L1 Gigabit Ethernet controller.

    Thanks for your time,

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Try another port on the router?

    Download and install the latest driver for your network controller. If that doesn't help, try setting the network link speed and duplex manually in the NIC properties.
  3. tommytomotom

    tommytomotom TS Rookie Topic Starter

    I've tried all the ports on the router, and installed the latest driver for the network controller. I've also upgraded the router firmware, which didn't help. I'm afraid I don't know how to set the network linkspped and duplex.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In device manager, choose the properties of your NIC, go to the advanced tab. You should have some settings there about network speeds (10/100/1000/Auto) and duplex (half/full/Auto).
  5. tommytomotom

    tommytomotom TS Rookie Topic Starter

    These are all the properties and the options I have checked for them:

    Bundle ID - Not present
    Flow Control - on
    Interrupt moderation - on
    Max IRQ per second - 5000
    Maximum frame size - 1514
    Media Type - Auto
    Network address - Not present
    Number of receive buffers - 256
    Number of transmit buffers - 256
    Shudown wake up - off
    Sleep power saving mode - on
    Sleep speed down to 10M - on
    Task offload - on
    Wake up capabilities - Magic packet and Pattern match
  6. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Your GIGnet device is drowning the LAN and it is getting reset;
    try this

    Maximum frame size - 1500 << match your MTU
    Sleep power saving mode - OFF
    Wake up capabilities - OFF/none, (if available)​
  7. tommytomotom

    tommytomotom TS Rookie Topic Starter

    Ok thank you, I've made these changes, will get back to you with the results. :slurp:

  8. tommytomotom

    tommytomotom TS Rookie Topic Starter

    Made all these changes (Maximum frame size to 1500 if that's what you meant) but it's still happening. :( Only things I can think of trying are updating by BIOS, although that's probably a long-shot, or using a USB connection with my router instead of an ethernet cable.
  9. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    TCP does not travel via the BIOS so that's NOT it.
    Assuming the NIC driver and router firmware have been updated, have you tried
    reducing the network to the smallest number of devices,
    and test that for reliability. if that's good, then go to
    modem--router --just-1-system
    and test again.
    this will isolate the failure to a box and we can go from there
  10. tommytomotom

    tommytomotom TS Rookie Topic Starter

    Sorry do you mean making it so there is only one PC in connection with my router? I am a bit of a noob at networking.

    I'm also getting weird things like I'm just browsing the internet and I get a message from xfire saying I have "Timed out waiting for a response from the server" even though it says my network is still connected. :(:(

    Should I just disable the Attansic Controller and buy a PCI LAN card??
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Ignore jobeard. He read about TCP and MTU, but hasn't gotten to ethernet framing yet..

    I would guess the link speed is under the "Media type" setting.
  12. tommytomotom

    tommytomotom TS Rookie Topic Starter

    Ok so under "Media type" I can choose the following:

    1000Mbps Full Duplex
    100Mbps Full Duplex
    100Mbps Half Duplex
    10Mbps Full Duplex
    10Mbps Half Duplex

    It's curently on "Auto".
  13. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    yes. Isolate the network to the minimum devices, just the modem--system.
    if that works, then the router is causing the problem, otherwise it's the modem OR your NIC card in the system (which may need more tweeking).

    Nodsu; let's make sure your tweeking the failing component and not some innocent victum in the path
  14. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    These messages you're getting is either the router has a problem or the ports are crappy on the router. You could try this...

    Router Port 1: ------ 5-port switch Port 1: then connect your devices into this other switch and free up the router to do another task. This might help and this is the way I am doing it now.. Good results.. But if you still see those popup messages saying WAN connected and LAN connected then the Router has a packet loss issue.. To test if this is what's happening you need to disconnect from the router and connnect the PC directly to the modem. Test that for a few hours and see if you still get those messages?
  15. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Try all of them.

    Jobeard: Exactly, so please leave the frame size alone.
    If you need to be spoon fed in order to learn something, please consider:
    MTU defines the packet size at the network layer.
    Frame is the transmission unit at the data link layer.
    Isn't it bleeding obvious that the network layer payload should fit inside the data link layer unit? And therefore the link layer unit has to be bigger than the MTU to accomodate layer-specific headers and stuff so we don't use the network inefficiently?

    Did you, like test it, before claiming that this setting would cut off the physical layer because it is compatible with the network layer???
  16. tommytomotom

    tommytomotom TS Rookie Topic Starter

    Hello again,

    Went out and bought a non-wireless router and it works fine now. For some reason the wireless router wasn't working even though I had a wired connection. :S No internet on my iTouch or DS now. :(

    Thanks for the help everyone and sorry for wasting your time.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...