Latitude C840 is DOA - HELP!

By mamadurf
Mar 20, 2007
  1. Latitude C840 is DOA

    Last week I was using my computer at work. We expereinced a power spike (yes I was plugged into a surge protector.) Shortly after that I noticed small things were happening...when I would try to exit an application in my taskbar, the window that controls the taskbar would pop up and not go away...things were running slowly, etc. When I got home that night I scanned my computer for viruses, nothing major was found.

    I then opened PowerPoint and was going to show someone the presentation I had worked on all day...unplugged the computer and it shut off. Oops! So I plugged it back in, restarted, etc. and tried it again...the computer shut off, conclusion...fried battery. So I plugged it back in, restarted again and checked the battery was at 90% even though it had been plugged in for over 10 hours.

    Next morning turned on computer, checked email, checked the battery strength and after being pugged in overnight it was still at 90%, worked for about three more hours on the presentation. Shut my computer off, packed it up and left town. 12 hours later (after a long road trip) I pulled out my laptop, plugged it in and tried to turn it on...Nothing! No lights, no beeps, nothing. The powercord light is on. Tried pulling the battery using with just the power cord...still nothing!

    From what I have read here and elswhere I'm thinking it is the motherboard or PSU....any thoughts...and how hard is it to replace a mobo??

    Can't really tell you a whole lot about the computer itself, other than it has a 40 G HD, 512 + 256 of RAM....
  2. HPCE_Larry

    HPCE_Larry TS Rookie Posts: 132

    You may have suffered battery damage. if it isn't going over 90% then something is wrong. You may be able to get a replacement battery for it. Try calling dell to to see if your warranty covers it at all.
  3. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Take out the battery and boot up the PC see if it still runs slow? Also if the battery hasn't charged all the way to 100% then it's gone DOA. Have tell send you a replacement. Hopefully you'll get a new one or they might just send you someone elses problem one fixed.
  4. mamadurf

    mamadurf TS Rookie Topic Starter

    I tried it without the battery, it still won't boot up. This is a refurb I bought about 1 1/2 years ago...unfortunately I haven't backed it up since last summer and it has all of my wedding photography on it (At least I have those burned to CD!)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...