Latitude D420 invalid disk?

By nuttyballs ยท 9 replies
Jun 12, 2010
  1. Hi all, i have a latitude D420 which has no floppy, no cd/dvd just the HDD. when i power up i get invalid system disk, replace the disc and retry. The HDD is there and connected i have opened it up to see. So i changed the boot sequence to flash drive boot first, no joy same error. This unit is brand new never even had op system on it, is there something i need to do as a one of before first operating ?. I also ran the diagnostics from the bios and it gives error no Hdd. What gives. Any help from someone who may have encountered this before would be tops.

  2. kaldrouby

    kaldrouby TS Rookie

    ok first of all reset the HDD ( unscrew pull it out and push it back in again ) and reset the Cmos.
    let me know if that works
  3. nuttyballs

    nuttyballs TS Rookie Topic Starter

    cmos clear

    Hi, thanks for reply, clearing the cmos, is that by just taking the button battery out on this model ?

  4. kaldrouby

    kaldrouby TS Rookie

    Yes pull it out for 10 seconds then put it back .
  5. nuttyballs

    nuttyballs TS Rookie Topic Starter

    clear cmos

    Hi, did that and tried to boot from usb drive still got invalid etc, so i ran diagnostics and it does a short test on HDD, this time was found ok, all tests ran ok. Tried to boot and got same invalid etc. Still triing to boot from usb flsh drive with an iso image on it. I have a USB floppy, should i try boot win 98 then upgrage ?

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Have you tested your USB flash on a different machine (i.e. you sure it's a bootable flash)

    2. Otherwise, i think using your USB floppy is next best step

    G;luck - let us know how it goes
  7. nuttyballs

    nuttyballs TS Rookie Topic Starter

    tried the usb floppy with win 98 boot disk in sound loads everything ready to go, now i'm thinkin i still got no cd support. Can i put the win 98 on zip and get it to assume that the zip is a cd ? or can i do all this with xp and save having to upgrade it

  8. jameshendrix46

    jameshendrix46 TS Rookie

    Check the HDD if its in the BIOS if not RUN PC check on boot
  9. nuttyballs

    nuttyballs TS Rookie Topic Starter

    cant do that james i got no optical drive. Drive is seen in bios, in fact i have managed to extract onto it from the win 98 boot disk, ran scandisk no probs all seems fine. After hours of burning iso's i now find that i get the same error with xp pro, 2000 pro and win 98 se trying to boot from a flash drive.

    "STOPxoooooo7e(oxcoooooo5,oxf7a5f208,oxf7a5efo8) pci.sys - address f7613obf base at f760cooo, datestamp 367d855c"

    I ran the dell diagnostics which are pre loaded and this did a dst short test on the HDD, passed. Then ran full tests and got this

    "pre boot system assessment no diagnostic utility partition identified"

    UHH ! it just used the diagnostic utility to give this error message

    Just 1 more thing when i use fdisk and look at partition information i see 100% for c drive usage, but i know the disk is almost empty.

  10. jaunetravolta

    jaunetravolta TS Rookie

    reinstall the system, you will win a lot of time and make a ghost in case of
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...