Long complicated issue with nForce2, SIL3112, EPOX, and freezing

By Vigilante ยท 34 replies
May 6, 2005
  1. parallel-killer

    parallel-killer TS Rookie

    hi vig, thanx 4 your help! :wave:

    it already drove me mad this weekend... :evil:

    i can't wait anymore, today i try to buy a new pci sata ctrl and I DISABLE FOREVER THAT DAMNED 3112! my dear 3112, go for die... :dead:

    do you know if the latest SiI chipsets, like 3114 or 3512, have the same problem???

    3114 seems to belong to 3112's family, but with 4hdd supported,
    and 3512 would be the successor of the f*ck*ng 3112...

    after my experience with 3112, i don't trust at all in these new chipsets! :suspiciou

    bye bye :hotouch:
  2. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    The 3114 should be fine. I would go back to Silicon Image's web site to the download support section and make sure they are actually updating this chip! Cause they removed ALL knowledge of the 3112 from their web site. Perhaps they better support the 3114 or higher. Otherwise go for a Promise chip instead.

    Good luck.

    And by the way, the whole purpose of a dedicated SATA chip is for the performance. Because often the SATA that is built into the main chipset is just a SATA connection riding on the IDE bus, which doesn't have much performance gain. But a dedicated chip should give the "true" SATA speeds. So I would suggest the PCI SATA card, maybe with a Promise chip. Or a new motherboard with a different chip.
  3. Suntzu

    Suntzu TS Rookie

    Just to let you know that I had the same issue with my SIL3114, I have fixed this issue by going to the device manager then I have uninstalled all the components linked with the SIl3144 control and then I booted my computer. When my computer was back again I never had this issue anymore.

    I guess that forcing windows H/W detection and having Windows installing again all the Sil3114 components was the right thing to do. :angel:
  4. cha05cat

    cha05cat TS Rookie

    Ok, i have had exactly the same problem and solved it...

    I solved it through downloading the right driver directly from Silicon Image the direct download link is:


    extract and install and enjoy... I believe the problem stems from a slight incompatibility between the 3112 and 3512 (and possibly the 3114) and specifically Seagate hard drives.

    I do seriously hope I have helped out, as I was stressed to the max when I had the same problem.


  5. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Interresting it is under their "docs" folder.

    Well if I should dust off the old Epox and load it up again, I'll be sure to hang on to the file just in case!

    You may have saved lives if it really works!
  6. Chris5gd

    Chris5gd TS Rookie

    This is very similar to my spec... but I've also had a lot of the dreaded freezing, with accompanying click (doesn't your blood run cold when it clicks like that :( ), and "An error was detected on device \Device\Harddisk0\D during a paging operation" in the event log.

    However, I think I've solved it, and it's turned out to be completely unexpected, albeit obvious in retrospect.


    Asus A7N8X-E deluxe
    AMD Athlon XP 2500+
    nVidia nForce2 Ultra400 chipset
    On-board SATA controller - SiI 3112a

    Here's the story...

    One of my original IDE drives died, so I replaced it with 2 x 200 Gb Maxtor DiamondMax 10 SATA. Installed XP Pro SP2, included the SiI SATA RAID controller at the "f6 to load 3rd party SCSI controllers" prompt, all fine, both drives recognised, mirror set built, all cool.

    In use a couple of weeks later, on a reboot, and a message from the RAID controller to the effect that the RAID set had dropped out. :confused: . Anyway, rebuilt using the "f4 to configure RAID" thingy, just before Windows starts up. All fine, no data lost. It happens again, a few days later. And again, a few days after that. Several times in fact, the intervals getting shorter and shorter.

    So I break the RAID set and use the drives independently. Ok again for a few days.

    Then the clicks start. Disks aren't supposed to make that noise... messages in the event log looking very ominous.

    They get more and more frequent. Games become unplayable, though no data actually seems to be lost. (Meanwhile I'm searching the forums, looking for alternate drivers, anything in fact, that would make sense of all this).

    Eventually, the paging errors get so frequent that the PC is unusable. Deterioration like this can only be dud disks, right? So I buy an IDE drive, and rebuild the whole lot. I have a working PC again. All set to return the SATA drives under warranty, but then...

    ... I discover that in the frantic DVD-burning that took place before the thing became a completely useless heap of junk, I missed a few things out of the backups - doh! So I figure that with a stable machine, I'll have a go at recovering some data from the dud drives. With all the cabling in the PC now neatly routed, I didn't want to pull it all out again, so I pull a molex cable off the DVD-ROM to power the SATA drive, which I run leaning against the PC with the side off. Precarious, but it's only gonna be for a few minutes.

    The drive works perfectly. No clicks, no events in the log, perfect. :rolleyes:

    Bottom line: both SATA drives are working perfectly again. I can change the BIOS boot sequence and boot off them, install and run Far Cry off them, they're fine.

    So WTF was going on?

    I now think that the PSU was simply overloaded, or one of the 12V rails was, anyway.

    Originally, I had one of the 12V outputs from the PSU going to the optical drives, and the other to the hard drives (two IDEs at the time). And the graphics card which has its own molex socket. And a case fan. And the CPU fan.

    And what did I do? Duhh... I took out one HDD, and replaced it with two more. So that PSU output (with various molex splitters that had somehow accumulated over several years) was now running:

    - 3 x HDD
    - graphics card
    - 2 fans


    The other one, of course, was running a big fat nothing, since the optical drives and floppy are taking no power at all most of the time.

    So I've reinstalled one of the SATA drives, using the connection off the PSU that was running the optical drives. I very rarely have the DVD-ROM and the DVD-RW going at the same time, so their power just comes from a splitter, leaving one connector for the SATA drives.

    All working fine now. I've also run it with both of them back in, all mirrored up - also fine, but they were too close together and consequently a bit on the hot side. So I'll rearrange the drives in the cage to leave a nice gap when I can work up the enthusiasm.

    So the moral? Get a PSU with enough grunt, or at least make sure the load is distributed properly.
  7. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    In respect to your comments, and for future readers:

    This page has various calculators for finding out just how many watts your system is really using. You also want to add a good 30% safety buffer to the numbers:

    Choose your system type, AMD, Intel, or Server, and go through the numbers.

    Though just off the cuff, it's a good idea to have at least a 400w power supply these days. If you run a speedy x64 system, 500w at least.
  8. Chris5gd

    Chris5gd TS Rookie

    Just a little update on this...

    Although it seemed fine after I changed the wiring, it did occasionally throw random I/O errors of one kind or another, and would sometimes not boot.

    I finally changed the PSU to a Seasonic 600W. It's now been completely stable for almost a fortnight, with all three disks running.

    I'm completely convinced now that it was the (cheapo) PSU all along. I guess you get what you pay for.
  9. tommythecat

    tommythecat TS Rookie

    I have almost the same setup as you, and have had similar problems. I have been able to work out all of my issues and am running this combo with relative success. I have a few suggestions:

    Do not use the drivers for the 3112 from silicon image or microsoft.

    Stick with the drivers from the epox site. They are sever revisions older but are stable and are the only ones that will work with the integrated sil3112 chip. If you read through all of the info on silicon images site they explain that there drivers are for the add-on cards, not integrated setups like you will find on the 8rda3+. Stick with the epox drivers.

    Also, if you are still unable to get the sata working in raid or single drive configs, then forget dumping the mobo. Just get an add-on pci sata or sata raid card. It will cost much less money, be much easier of a swap, and will likely give you good performance gains as well.

    The integrated raid host adapters like the sill3122 on the epox 8rda3+ are notoriously problematic. Also, they offer minimal performance gains in RAID 0 configs and slow rebuild rates and poor performance during rebuilds relative to dedicated hardware raid controllers.

    Don't get me wrong, I am happy with my 8rda3+ configured as RAID1 (originally setup as RAID0 until a variety of benchmarks revealed absolutely no performance gain on the RAID 0 configuration) Despite the fact that mine is currently cool, I did have a variety of problems from locking, bluscreens, poor performance and unexplained rebuilds before i realized that the root of all of my problems was trying to use the microslop and silicon image drivers.

    Get yourself the drivers from epox here http://www.epox.com/USA/article.asp?ID=1043 and be sure to tell windows update to hid the MS WHQL certified drivers it will be trying to push on you.
  10. Artursc

    Artursc TS Rookie

    Hi Epox EP-8RDA3+ with SATA drives users

    I have all the same problem with freezing system, when working with large files.

    After weeks of experementing, reading, changing drivers, so on,

    I found only driver, what working without freezing at ASUS drivers.


    Noone driver before or after this, working properly with integrated SIL3112 SATA chip. I try all of them.

    Dont forget clear all Si3112r.sys drivers from windows driver folder.

    Hope it will help you too,
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...