Long complicated issue with nForce2, SIL3112, EPOX, and freezing

By Vigilante · 34 replies
May 6, 2005
  1. Alright, get ready for long, complicated issue that few have solved.

    EPOX 8RDA3+ motherboard
    AMD Athlon 3200+ Barton CPU
    Corsair TWINX1024-3200C2PT matched XMS RAM(400fsb, dual channel)
    Seagate ST3120827AS SATA 120GB w/ NCQ 7200rpm HDD
    XP Pro SP2

    Also very important details to this problem:
    Motherboard uses nForce2 chipset
    SATA Raid adapter is SIL3112r (though on POST screens is says 3112A)

    This problem shows itself by freeze behavior and error log entries.

    The freezing is just that, it will seem fine, then boom, it freezes solid and you can't do

    jack for a good 40 seconds. Then it unfreezes and comes to life and acts like nothing ever

    happened. This appears to be the only problem I know about. That is, maybe it causes other

    problems too? But the freezing is the main end result. And this freezes all activity, not just

    HDD operations. In other words, if I have an MP3 playing, it freezes silent too. Then starts

    playing again where it left off when it comes back.

    Also, during the "freeze", keyboard strokes and possibly mouse movements, are still cached. So

    when it comes back, letters I was typing will appear, and the cursor will jump around.

    Lastly, it is extremely random. Sometimes it will freeze many times in a hour. Sometimes it

    will run good for days. I could be playing a game, or just reading a text file and not doing

    anything HDD intense. Nothing except the freeze period are timely. I would venture to say that

    the freeze time is dang near exactly the same each time. But absolutely random to get there.

    Promptly after a freeze an error log entry is created:
    Type: ERROR
    Source: si3112r
    ID: 9
    "The device, \Device\scsi\si3112r1, did not respond within the timeout period"

    Naturally I've researched this error ID, this error message, and have tried many different

    drivers. To no avail. This problem, across different HDDs, and different mobos, creates the

    same error log and has the same behavior. Meaning the problem is not just one model

    motherboard or HDD. But the Silicon Image chip is the common ground. So people have seen this

    same freeze behavior and error log on ASUS, Gigabyte, EPOX, and other motherboards. And on

    SATA drives like Seagate and Maxtor, IBM, and I believe one or two have had WDs.

    There are two other error log entries that happen occasionally, relating to this problem:
    Type: WARNING
    Source: disk
    ID: 51
    "An error was detected on device \Device\Harddisk0\D during a paging operation"

    Type: WARNING
    Source: disk
    ID: 11
    "The driver detected a controller error on \Device\Hardisk0\D"

    [note these may say "hardisk0" or "harddisk0" with two Ds or not, I've written them down both


    The last warning, ID 11, has only happened once, though this problem has been going on for

    weeks. However, because other people online with my problem have had this error regularly,

    I've included it here.

    Now then, the first obvious thing is, is my drivers and BIOS up to date? Well they are. I have

    the latest BIOS from EPOX, and the latest nForce chipset drivers. As well as the latest hard

    drive driver, and SIL driver. The SIL driver is from EPOX, not nForce or Silicon Image.

    Silicon Image doesn't seem to have any records or files for this chipset anywhere on the site

    when I tried searching it.
    The SIL driver is even driver signed by MS.
    Yet with all the updated stuff, the problem remains.

    Now for a list of various things I've done:

    -updated drivers and BIOS - duh! BIOS is ver 6.00PG (newest). HDD firmware seems to be version

    3.42. SIL driver says version and dated 8/27/04.

    -Done all updates and patches for MS

    -System is pretty fresh load of XP Pro

    -Checked for viruses and spyware and all that jazz

    -Changed/removed page file (in reference to error on "paging operation")

    -Changed various BIOS settings relating to HDD (not many)

    -Changed memory timings to what Corsair says they are on the site (2.5-3-3-6) down from


    -Ran Seatools, all checks on all hardware that it could, no problems

    -Changed SATA cable

    -System is running cool, temps are fine. PS is fine, 550watts clean.

    -Windows actually had a 2nd driver in the section for SCSI/RAID adapters. The SIL one is

    called "Silicon Image SiL 3112 SATARaid Controller". The 2nd was called "GXC108P SCSI

    Controller" which had a "generic" driver, until I updated it. It then loaded an MS driver and

    renamed it just "SCSI and RAID controllers". But then, after taking it apart and changing the

    cable. This driver disappeared entirely and now only the SIL shows up.
    All through this changing the problem continued.

    -Researched like mad. Seems to be mostly, if not ONLY, with SATA HDDs on nForce2 chipsets with

    a SIL3112 chip.

    -Removed all CD-ROM emulator apps, well, GamesXCopy and Daemon tools.

    -I've done lots of small tweaks here and there that I can't think of now.


    Now after saying all that, I have some questions:

    - What is the cause of the freeze? Obvious answer is "bad HDD" or "bad mobo". However, I think

    it's more of an incompatibility of some kind. What's your thoughts?

    - What exactly is this "paging operation" mean?

    - What exactly is the "timeout period" that my SIL is "not responding" within? Because this

    - What is the significance of all the different names for the SIL? Cause I've seen "SIL3112r", "SIL3112A", "si3112r1" and "si3112r"? And maybe more combos.

    "timeout" is undoubtedly the same exact time my system is frozen. A timeout period of about 40

    seconds. Note that other people with this problem have had different times. Some more like 20

    or 30 seconds. Some for minutes at a time. Some would be multiple freezes over and over


    - What is the significance of "\Device\hardisk0\D"? I find it interesting that it uses "D".

    Hard drive "0" makes sense, by why D? I only have the ONE HDD in the case on SATA. And one IDE

    burner that is all but new.

    - Who's fault could this be? If the HDD doesn't like the mobo, do I blame Seagate or EPOX or

    Nvidia? If the HDD is not compatible with the SIL, do I blame Seagate or Silicon Image? If

    nForce2 and Sil don't like each other, do I blame Silicon Image or Nvidia? Or blame EPOX for

    putting the two together?

    - If I were to try to get "something" replaced, what would I try first? I don't think

    replacing the HDD is my first choice. Because I love the drive, it's wicked fast. Just not

    when it freezes up entirely :(
    I'd rather not replace the mobo. It just seems drastic. But do you think a motherboard

    manufacturer would just give you a new board because you think it's incompatible? No I think

    they'd just tell me to get a new HDD.

    - Does is seem to you, after reading this, that a BIOS upgrade of the SIL would be the fix? If

    so, how might I go about it? Because SIL doesn't have an update and neither does EPOX. Though

    in EPOX' latest BIOS is has this listed: "Update Sil3112A ROM version to V4247(For 8RDA3+)".
    Here you can see the reference to "SIL3112A" instead of "SIL3112r" as Windows lists it. Still

    not sure what that means.

    - What would your next step be? If EPOX put out an update to SIL3112A firmware, would that

    require a new driver for Windows to match the new firmware? Or would those be independent of

    each other?

    - Most people online either gave up or replaced the whole motherboard. I'm sure if I got a new

    mobo with a diff SATA chip I may not have any problems at all. But that doesn't mean my mobo

    is "bad", so that leads back to the question, who is to blame?


    I would have posted this problem on EPOX forum, if, if they had a forum. They don't seem to

    have a forum, or a support area, or support E-mail. Or anything really. So I would have to go

    forward simply by E-mailing them or calling I guess.

    The strange part about this is that it hasn't happened the whole time I've had the box

    together. I was on a 40gb Maxtor IDE with this EPOX for months before upgrading, no problems.

    After upgrading, I had the Maxtor and the Seagate on at the same time. This seemed to cause

    many problems, and this problem started soon after trying to use both drives. And the problem

    has remained. I'd say the system worked fine for many days, only until I was doing

    backup/restores to/from the Maxtor, using the drives together, that the freezing began. And

    not just freezing then, but whole crashes and a few BSODS. Until I disconnected the Maxtor.

    When all errors stopped except this freezing.

    Where many forums have failed, I hope this one will pull through. Or at least, maybe someone

    has a suggestion or two I haven't thought of. I consider replacing the board, or even doing a

    reload, a drastic option and want to avoid that. If I wanted to do that, I wouldn't have

    posted here first. I'm hoping there may be some possible way to actually find out for SURE,

    which part could be the cause of this, and why. Using some kind or tool, or test, or system

    monitor, or some other device that can point a finger at the culprit.

    In the mean time, I think I'm going to send EPOX an E-mail. Or try to call them. Because this

    problem happened on many diff mobos, whenever it was EPOX, it was this model, or very similar.

    So thank you if you managed to read through this.
    And thank you for your suggestions if you have any.

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Found this on the web (but pertaining to SIL3114):
    From what I also picked up on the web, the NForce4 Standalone Driver package could also work on the NForce2 (at least the IDE-drivers do).

    Someone else said to use the WHQL certified SIL drivers from the MS website

    Do a Google with epox sil drivers problem
  3. Jank

    Jank TS Rookie

    I've gotten away from Epox motherboards . . .

    Even since Epox started using nforce chipsets, all hell has broken loose with their MB (at least the Athlon MBs that I've used).
    This may seem simplistic, but since I switched to Asus mb's and Seagate SATA drives, all of the problems you (and I) seem to be experiencing have disappeared.
    Currently, I'm working with Asus A7N8X and A7N8X-E Deluxe mb's with Seagate SATA HD's and have no problems except for this: You MUST set BIOS to failsafe settings before installing OS (except, of course, for booting into the SATA drive(s).
    I don't know what's going on over at Epox; I used to use their products exclusively until I began running into problems too numerous to mention.
    Asus and Seagate seem to be the "failsafe" combo at this point in time.
    Don't ask me to explain this phenomenon.
    It just seems to be the case.
  4. Jank

    Jank TS Rookie

    Trash the Epox MB . . .

    . . . and get yourself either an Asus A7N8X or A7N8X-E deluxe motherboard.
    I used to use Epox MB's exclusively until they started to incorporate nforce chipsets . . . and then all hell broke loose!
    It seems that nothing I tried could get the Epox jobs to either install an OS or keep the OS from DXing--IF I happened to get it up and running.
    Keep your Seagate drives. I've tried Maxtor and IBM SATA drives and would more often than not get the "click of death" when I powered up the mothers.
    Something weird is happening in computer land these days: things are just getting too complex and the manufacturers aren't taking the time to thoroughly test their products (especially with all of the components that will be used with them).
    Seagate and Asus and nforce seems to be the trick at this point in time.
    Anyone got a better suggestion . . . I'm prepared to listen.
  5. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    It would seem that a new motherboard is the only solution. Though after reading various reviews and articles about the SIL3112 chip itself, supposedly it's real nice.

    I tried E-mailing EPOX but at the time the E-mail form wasn't working. I'll try again.

    Blackstuff, my BIOS doesn't have the SATALink, or Genie BIOS. Though I'll take another look around. I think that mostly covers the SIL3114 chip, which does come on one or two upgraded EPOX boards I might try to get. Other than that, I've been reading this article at Toms Hardware (which includes my board):

    And I was looking at getting an upgraded model of one of their winners, a DFI:

    There is also an MSI model or two I had my eye on. And I was browsing around on ASUS' site, I'll check out that model.

    So besides checking the BIOS again. Which part is to blame do you think? Seeing as how the EPOX is okay on very few brands. And yet the SIL3112 gets pretty high marks. And of course nForce2 Ultra 400 seems to be the go-to-guy for an Athlon based system. I'm still undecided.

    Thanks, keep em coming.
  6. Jank

    Jank TS Rookie

    Epox tech support is amateurish.

    Like you, I've had a hard time contacting Epox. And when I received a reply it was as if some technically-ignorant guy from the mail room happened to intercept my question and tried to answer it.
    Here's the situation as I see it: The only way you are going to solve your problem is to dedicate many, many hours of trying everything you can possibly think of while perusing this site and others to get hints here and there.
    No matter what you or anyone else thinks is happening vis a vis the chipset, SATA controller, hard disks, motherboard, memory . . . whatever, the fact is that you are working with a system that is unnecessarily complex and hasn't been tested thoroughly by the manufacturer. Add to this situation the fact that every component does not necessarily work with everything else in the system, and you've got several obstacles to overcome before you even power the sytem up (IF you can power the system up).
    I've built several dozen systems utilizing motherboards from Asus, Epox and Chaintech. Here's a summation of what I've found thus far . . .
    (1) Maxtor and IMB hard drives are difficult to get to work with any motherboard I've tried, especially their IDE drives on MB's with SATA controllers.
    (2) To get things to work as soon as possible, eliminate everything from the system except the basics (hard drive, floppy, graphic card, memory, CD) and load setup defaults (except boot sequence if using SATA drives) in BIOS.
    (3) Before doing anything, clear RTC RAM by removing jumper/battery and don't reinstall for at least 12 hours.
    (4) Most important . . . odds are great that there is nothing wrong with any of the components you put into a system. The problem lies in getting these components to communicate with each other. Like I said in my previous entry, for some strange reason unbeknownst to me the combination of Asus motherboard (nforce chipset version), Seagate SATA drive and Athlon 1800 to 3000+ processors usually work right off the bat (although there are always problems getting XP to install the first time).
    Hope what I have said helps you to finally get a system that works.
  7. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I gather from you, Jank, I should get a new mobo. I kinda figured I'd end up going that route.
    To bad, since the EPOX I have is only a few months old. Seems like a waste.
    Though I do believe that EPOX could release a new version of the SIL firmware or BIOS, it could fix the problem. Because I think this is a programatical error.
    Sucks that EPOX is tuff to get a hold of, but I have to keep trying.

    I don't suppose Newegg would exchange my board back for a newer model? I doubt it.

    The only solution I read online was that someone may have been able to basically "hack" a new SIL BIOS or firmware into the BIOS without having to upgrade the whole BIOS (because EPOX doesn't have an upgrade).
    Though it sounds very iffy and dangerous to me.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Have you tried any of the 3114 or NForce4 drivers?
    If that mobo is to be exchanged, why not try it?
    Otherwise, disable rAID altogether, stick an IDE HD on it and sell it.
  9. Jank

    Jank TS Rookie

    The newest nforce driver set is great, but . . .

    . . . I've had trouble with the IDE controller that comes bundled with everything else (removed it and reinstalled Windows XP's generic IDE controller and things work great now with DMA recognition).
    I don't know what Newegg's return policy is, but they've been pretty liberal with me in the past--go ahead and ask.
  10. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    can you disable drive caching
    also video shadowing
    I have heard of (via chipset) freezing and long writes errors.
    and I to will not use epox anymore, have tried loads of times ,to get help and no response.
  11. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Okay I did a search and got a SIL3114 from EPOX, it was for some other board. XP didn't like it. I didn't force it on.

    Then I went right to Silicon Image web site and downloaded their 3114 driver. And for some reason they have NO 3112 driver there. Hmm.
    XP didn't like that one either. So I went ahead and force loaded that one. And got BSOD on startup. Used Last Known Good to get back.

    I checked the BIOS again, and there isn't anything for SATA besides turning it on and off. And no special "RAID" functions either. Though, outside the BIOS, I haven't been inside the built in RAID utility. But then, I'm not using RAID anyway.

    I don't want to disable the caching. I've been using the system crippled as it is, running slower RAM and HDD etc... Until I bought all these upgrades to release the full power. And this is what happens.
    But I guess, just to experiment, I'll try disabling that. Though this is Nvidia chip not VIA. But we'll see.

    I might also see if MS has a driver of their own. Maybe it'll work better the EPOX' I don't know.

    And right now I'm downloading the nForce4 driver. But it XP baulks, I won't force it.

    Incidentally, I won't be selling it blackstuff. The plan is, I'll take this mobo out, put it on my 40gb IDE. Then I'll buy a cheap CPU and RAM, video and a case. Stick my own used parts in it. And build it into a server. Then I'll buy the MSI K7N2-Delta2 Platinum for mine.
    This way, for $400 I can get a new mobo and build a complete 2nd machine to use. And I'm currently selling an old laptop of mine for $300. So all this I can do for $100 to $200 depending.

    That's the plan. Unless I can, or EPOX can, fix this SATA issue.

    Thanks, not done yet.
  12. Jank

    Jank TS Rookie

    I don't know if this is any help, but . . .

    . . . I bought a PCCHIPS mobo a while back to be used in a computer for a "cheapo" customer. This board, which will accept up to 3000+ Athlon and PC 2100 memory, fired up without a hitch and was really fast from the get go (although I didn't formally test it for speed--it just seemed to zoom).
    Again, it is a board without an nforce chipset.
    I'm getting the distinct impression that nforce is great when you can make it work with other components. But when you can't . . . you can't!
    Keep us informed about what you finally discover during your trip down computer lane.
  13. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I'm definitely getting a new mobo. I really like the MSI K7N2-Delta2 Platinum.
    Then I'll use the EPOX as a server on IDE. What a shame.
  14. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    pagefile config

    I was having similar temp freezes like a pedemal siezure.
    then everything came back to norm.
    How have you setup your pagefile?
    same disk as os/partition, spanned(multi disk not os disk) or set on separate hdd?
    The tweak xp guide I used, recomended:
    1 gig ddr ram
    I've set mine on primary os drive:
    max: 50mb
    on the seagate I set it to:
    1.5 x amount phys. ram
    I used diskeeper to configure MFT & pagefile optimization.
    this seemed to help my systems.
    maybe you too?!
  15. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I've played around with the page file. Setting diff sizes, and turning it off completely.

    As of right now, it's set to min/max of 1512. Which is about 1.5x, which is the recommended I know.

    As for drive config. I just have the one Seagate on SATA, no other HDDs at all. And just one big partition. Nothing fancy, no boot loaders or nothing.
    Though I haven't used diskeeper or any other drive utilites.

    The other day I tried to do a virus scan from Bitdefender and the thing froze like 12 times by the time it reached 15000 files. It was barely 10% done scanning my drive. I had to cancel it.
    Crazy stuff.
  16. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966


    Have you had any new Luck?
    I wonder if there maybe a conflict in seek timimg
    with cache & buffers?
    I'm new to sata/scsi
    so far I like it.....

    I just bought into an Asus A7N8X-E ($97.00 usd)
    AMD atholon xp 2700+
    nVidia nForce2 ultra400+ chipset
    sata silicon image Sil 3112
    I have a sata drive:
    WDC wd800jd-75jna0
    I'm running it as OS drive
    it all seems to be werkin fine so far.
  17. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    WD HDDs did seem to do better on the 3112 chip. Most people had problems with Seagate, IBM and Hitachi stuff I believe.
    At this point I don't think it's the HDDs anyway, it's got to be something with the way EPOX put the 3112r and nForce together. Or a bum BIOS or bad firmware.

    An update for those of you watching, I just ordered the MSI. Gunna spend my Saturday backing up and reloading it. Fun fun.

    So any suggestions are welcome until I wax it.
    SOcRatEs, you wouldn't know off hand where such things as cache and buffers are changed? Cause it's not in BIOS. Some registry settings I'm sure.

  18. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966


    These are what I use
    tweak guide I use

    From the tweak guide:

    Cacheman is a free utility that provides a user‐friendly interface for making most of the memory and cacherelated
    changes covered in the Memory Optimization section. Note that I recommend the free version of
    Cacheman, not Cacheman XP. All the important changes can be made using Cacheman. To access
    Cacheman, download Cacheman 5.50 default distribution from the Cacheman Website, install it and then
    launch the program.
    The best way to change settings in Cacheman is to go to the ʹShow Wizardʹ menu and select All. Run
    through each setting as prompted, and if you want to know more, click on the Help button on the main
    screen. My recommended settings that correspond with the related settings I recommend in various other
    sections of this guide are as follows:

    Disk Cache: Balance
    Icon Cache: Set large maximum Icon Cache size
    Unload DLLs from Memory: Enable
    Disable Paging Executive: Enable
    IO Page Lock Limit: Large IO page lock limit value
    Disable NTFS last access update: Enable
    Disable creation of short filenames: Enable
    Reserve more space for the Master File Table: Do not enable
    Defragment hard disk when idle: Enable
    Hung App Timeout: Optimize
    Wait to Kill App / Service Timeout: Optimize
    Menu Show Delay: Optimize
    Filename Completion: Do not enable

  19. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I downloaded it, haven't had time to play with it yet.

    But I think we have closure here fellas.

    So I went and got the K7N2 Delta2 Plantinum edition. Great board. But doesn't have the dual LAN like the EPOX.

    So get this, I spend all Friday night backing up data and installing the new board, and guess what happens? Yes, it freezes during setup. I tried like 3 times making various little changes. I thought for sure now the Seagate had problems. But I remembered what someone said eariler about the BIOS and Fail-Safe. So what the heck, I took out the battery and unplugged it and set the CMOS clear jumper. All overnight.

    Then on Saturday morning I started it up again, and had to change only the time, boot priority, and CPU speed (to get full 3200+) in the BIOS. Now it's been a while but I don't remember if I ran setup at this point, or if I actually did set Fail-Safe or not. I believe I DID set Fail-Safe defaults.

    And that time, setup went through without a hitch, and I never went back into the BIOS to change anything. If it works without freezing, that's good enough for me.

    So now it's been 5 days and no sign of trouble, running like a champ.

    Some day the EPOX will rise from it's lonely cell to reign again...
  20. Jank

    Jank TS Rookie

    Yep, clear CMOS and invoke fail-safe . . .

    . . . does it (most) every time!
    You might want to go back into your BIOS settings and change the things you don't really need . . . like built-in onboard game, midi, LAN, audio, etc.
    Glad you got a motherboard working!
  21. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    It might not have dual-lan NICs but it has Gigabit Ethernet & the SATA is integrated in the southbridge rather then on an add-on chip connected via the PCI bus. :)
  22. bayouboy

    bayouboy TS Rookie

    I don't have the same problem with freezing, but I also have the Silicon Image Sil3112 on my Gigabyte GA-SINXP1394 mobo. I have had countless issues with my SATA in both raid and normal functions. I have used all the drivers availiable and get the same results. I have massive degregation/corruption of my files and then the eventual result of losing my partition index ever time! I've tried many different brands and models of HDs and anything else I can think of. All the other drives work on my friends comps just fine. My ATA raid works great! So if you ask me, stay away from Silicon Image Sil3112, my next mobo will not have it. Also, I find it very odd that they do not have any listing for the Sil3112 on their website.
  23. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Yea, supposedly the 3112 was a good chip based on some early reviews. And the fact that it is a dedicated chip it should have better performance then a chip built into the southbridge. Or northbridge, as the case may be.

    My new mobo has been running now for, well, since my last post in here. And have had no problems with my SATA Seagate yet. Even alongside my IDE. Cause the IDE and SATA are controlled by the same chip. But at least it works.
  24. parallel-killer

    parallel-killer TS Rookie

    hi to all!


    i have the same problem! (freezing with 3112 sata)

    this is my configuration:
    enermax 400w active PFC
    asus a7n8x-e deluxe nforce2 ultra400 bios 1013
    athlonxp 2600 fsb 333 thoroughbred 2.08ghz (with a big coolermaster copper heater)
    2 x kingston memoryx 512mb 400mhz dual channel (2-3-3-7)
    ati 9550 128mb agp8x, creative live! 5.1 digital, modem conexant hsf56 pci

    never had cooling problems in my room, even on the italian summer (in these last days, here in italy we have over 35°C during the day and more than 23°C the night, and we are in june. i don't know how hot it will be on august... :dead: ).
    the cpu, motherboard and hdd are very well cooled. cpu goes from 35°C to 51°C, mb goes from 30°C to 40°, all 4hdd i have now from 35°C to 43°C.

    i always do my best to have the latest windows patches, drivers, bios, etc... everything is always up to date. :stickout:

    my problems began few months ago, after I began to use the SiI 3112a
    integrated chipset. I never used before and pc worked fine for more than 1year.
    before I had 2maxtors in the first ide channel, a 40gb 7200 2mb and a 80gb 7200 2mb. in the second channel, a samsung combo dvd/cdrw and an iomega dvd-rw 4x. I put another 2hdd, 2 maxtor 120gb 7200 2mb, attached to a SiI 0680a PCI controller in IDE mode (and not RAID mode).
    I repeat, in this configuration, everything worked for more than 1year, the pc turned on 365d/365d and 24h/24h.
    a few months ago, the 40gb and the 80gb left me and went away for a journey! but they didn't come back... :suspiciou
    so I said I buy 2 SATA hdds and I begin to use the onboard 3112a controller.
    I put a 80gb maxtor 7200 2mb on SATA1 and a 200gb maxtor 7200 2mb SATA2, but they are not used in RAID, they are standalone as normal IDE drives.i removed the pci 680a controller, and attached the 2 120gb maxtor on the first ide channel. the 2 optical drives are still in the secondary channel.
    In the 80gb I installed w*n20*03*s*r*v*s*p1 in a NTFS formatted partition.on the first 120gb maxtor, there's a little 4gb partition, used for booting windows (because i installed win in the sata hdd) and for the swap file
    i always used the latest driver from silicon image website.
    i know that the one in asus site is older.
    and i know the are 2 kind of drivers, SATA RAID or SATALink.
    i went again in the website in these last days and immediately i didn't find at all a driver for 3112a. it seems to not exist in SiI website! :eek: after some pain, i finally found the drivers and bios. the latest drivers are for SATA RAID and for SATALink.
    the bios of my 3112a is 4.2.47. i noticed that there an upgrade, version 4.2.50, i downloaded it but when i try to flash the bios, the utility says that i can flash only add-on cards chipsets and won't work on mb onboard chipsets.perhaps it works, but i'm not sure, actually i don't know to try flashing bios or not.
    i tried to install many times windows with both the 2 drivers (one time in SATA RAID mode, another time in SATALink mode).
    i tried to install many times xp sp2 to be sure it was not a 2003 problem.
    i tried to slow down FSB, memory frequency and timings.
    i tried to change every setting in the bios, i tried to change cables, i tried to change many times the position of the PCI devices, i tried to remove soundcard,modem,dvds...etc...
    I DID EVERYTHING AS VIGILANTE DID, to find out where's the problem,
    but nothing changed.
    after i began to use SATA controller, my pc now sometimes still freezes. it's about a 30s freeze, or sometimes it freezes at all and i have to reboot.
    sometimes in the event viewer are logged the same error IDs of Vigilante. and sometimes no.
    sometimes it works fine for days and days, always on 24h/24h, and sometimes it freezes even during win bootup after to not be used for 1day.
    it's a very strange thing.... :confused:

    i will try next week to use only 2IDE parallel hdd to see if the really problem is the SATA 3112 controller.

    in the meantime, i hope the best for you.

    bye bye :hotouch:
  25. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Hey, sorry to hear about the problem! It drove me mad as it probably does you.

    If you are in the same boat I was, all I can say is: either go back to IDE only and skip using SATA. Or install a dedicated SATA PCI controller, with a better SATA chip! And see if that works. Plus disable the onboard SATA if you do.

    I ended up getting a whole new motherboard, and my SATA HDD works fine now. So I never did fix this issue. But a PCI SATA controller may not be that expensive, and at least you wouldn't have to get rid of your drives or take them back etc...

    Hope you work it out soon, it's aggravating!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...