Malfunctioning Platinum 32GB flash drive

  1. I have a relatively new Platinum flash drive (yellow 32GB) which has been working well for the past few weeks on my Windows 7 laptop and a Windows XP PC at home. Not sure why (possibly unplugged before it was 'safe to remove'?) but it is now not opening stored files when inserted into any USB port, although the device is recognised in F: drive (removable device / USB mass storage device)) and Microsoft troubleshooter is reporting that the device is working properly and it comes up as recognised hardware but when trying to click open the files held on the device it simply says 'please insert device in F drive' or similar. I am pretty sure it is not a physical fault ie device not damaged. The light on the device is pulsating instead of continuous light (when it was functioning properly). Is anyone able to suggest a way to fix the problem? I have looked at the solutions on the current forum but none of these have restored the flash drive. I have tried other flash drives and they work so the problem lies with the flash drive itself, not the drivers on the PC or laptop. I don't mind losing the files if there is a way to 'clean' the device and re-upload new drivers? The drivers, incidentally, are showing to be up-to-date. Some one has suggested that the flash drive is not recoverable, in which case I hope some one who has had similar experience, can just tell me that I would be wasting time and money trying to open the files on this flash drive! Regards Jonathan
  2. wrt54gs7

    wrt54gs7 TS Enthusiast

    Have you tried plugging it to another USB port or on a different computer?
  3. Jon Calderbank

    Jon Calderbank TS Rookie Topic Starter

    Yes , both of these. And exactly same reaction. Which makes me think it is a problem within the flash drive. I have tried the suggestions in previous posts re. accessing flash drives eg via device manager
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Does attempting to copy the files to a local hard drive have the same problem as opening? If you can't copy them and are willing to lose them (outside of file recovery software I'm not sure you have a choice), I'd just reformat the flash drive (ideally exfat rather than ntfs) and see if it works then. If it doesn't work, try to get a refund or get the drive replaced, should be covered by some sort of manufacturer's warranty.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...