Microsoft Office works on one admin account but not another on same machine

Difficult technical issue. I have iMac (Retina 5K, 27-inch, 2019) running macOS Monterey version 12.1. The latest version of Microsoft Office was previously running on this admin account but unclear when it stopped working. I have another admin account on the same machine and this admin account runs all Microsoft Office apps. Symptom: Admin account 1: Click on any Office app and Microsoft Error Reporting Window opens with message: There was a problem with Microsoft xxxx (any app gives same error) and we apologize for the inconvenience. Upon clicking on "More Information" a rather large Error Report is generated which starts with Exception: EXC_Crash (SIGABRT) and among many things reports the Crashed module name is merp. Full error report is attached.
Steps I have taken to resolve:


  1. Removed Microsoft Office with Microsoft level 1 and level 2 technical support assistance. Deleted Microsoft instances from library applications plus all Microsoft instances in Container and Group Container and Cache. 1a. Re-install Office and same error occurs.
  2. Re-set user folder privileges. They were set to: Custom and changed them all to Read/Write, which is what is set for the admin account 2 on which the apps work. Does not fix the issue.
  3. Re-installed the Monterey operating system. Does not fix the issue.

Microsoft says the issue is with the iMac and not Microsoft since it works properly on a different admin account on the same machine (I would tend to agree).


I'd rather not go thru the rather lengthy process of moving all docs and folders from one admin account to the one that works properly. I'd rather find the issue on admin 1.


Any thoughts on a step 4 to resolve this? I can find a way to link to the error report if that is needed. Seems like this should be easy to find since it works flawlessly on one admin account on the same machine, but not another admin account on the same machine.
 

Attachments

  • MS crash report.pdf
    327.2 KB · Views: 1
I seem to recall that issue is permissions. Check this out and see it helps:

My sense is that this is on the right track. The issue I'm having now is, with the Monterey OS, the links which show a reset of the home folder permissions are not there. I can research this on my own. I tried following the instructions but when I boot to recovery mode and go into the terminal, pressing "reset password" does work, but there is NO reset Home Folder permissions and ACLs. I will research further.

I appreciate you taking the time to send me that link. Now if I can only figure out how to do this on the latest Mac OS, I'm betting I will have fixed the issue.