Microsoft Windows Search Protocol Host closing

By gnrtool82 ยท 6 replies
Jan 2, 2008
  1. I keep getting popups from Windows (vista) that this program needs to be closed. After running the Event Viewer, it told me this:

    Windows cannot access the file C:\Windows\AppPatch\AcSpecfc.dll for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Microsoft Windows Search Protocol Host because of this error.

    Program: Microsoft Windows Search Protocol Host
    File: C:\Windows\AppPatch\AcSpecfc.dll

    The error value is listed in the Additional Data section.
    User Action
    1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
    2. If the file still cannot be accessed and
    - It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    - It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
    3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
    4. If the problem persists, restore the file from a backup copy.
    5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

    Additional Data
    Error value: C000009C
    Disk type: 3


    I tried to follow their suggestion briefing but it hasn't solved anything as far as I can tell
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We need to know the details on the equipment you are attempting to install or update... motheboard or computer brand and model, devices installed, version of VISTA, and whether your VISTA is a full install, and OEM install, or a recovery disk or other computer manufacturer disc install.
  3. gnrtool82

    gnrtool82 TS Member Topic Starter Posts: 28

    well that's kinda the thing, as far as i know i'm not updating anything. definately not installing anything. if i had to guess, a windows update or something triggered this. i do have a recovery disk, but i don't actually know it's purpose as i have no interest in really using it. my vista is probably a full install, and i'm not exactly where i can find the rest of my information.. it's just a dell inspiron 1521 laptop.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    All the same, since we do not know the equipment with which you are dealing, we cannot make useful suggestions.
    The Inspiron 1521's we have seen arrived with either Windows XPH installed, or Windows XP Media Center Edition, then a VISTA upgrade appeared two or three months later in the mail.
    That may not have been the case with your system.
    We have seen problems with the VISTA upgrade install.
    The Dell disk set which was shipped has five discs of applications, device drivers, patches, etc. They are generally blue and white CD discs. But some are DVD discs, if you got the Media Center Edition.
    The Dell operating system recovery discs were either maroon, a yellowish green, or a pale beige/light brown.
    Both installs, or recovery installs, will require inserting the other disc set to complete the install. The Inspiron will search for what it needs and extract the needed software to install.
  5. gnrtool82

    gnrtool82 TS Member Topic Starter Posts: 28

    well i guess i was wrong with my previous post. it seems that when i try to use excel, the same problem occurs and excel does not open, referencing that same file. so it appears that file needs to get fixed in a bad way

    my vista cd is greenish if that helps at all
  6. raybay

    raybay TS Evangelist Posts: 7,241   +10

    So this is a Microsoft Office error?
    Which version of Office are you using... 2000, 2002, Office XP, Office 2003, or Office 2007?
    First thing I would try is to go to, then to Office Updates, and see if you can download and install the service packs over again... they will often repair an office file set.
    Otherwise, I suspect you will need to remove and reinstall your office software.
    Good luck.
  7. gnrtool82

    gnrtool82 TS Member Topic Starter Posts: 28

    how do you block particular protocol searches or whatever, cause that could solve this for the short term? i know there is a way, but i cannot find out how to do that again
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...