1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

More Removable Drive problems under win 2000

By JW1 · 14 replies
Mar 8, 2005
  1. Hi there,

    I have now developed a new removable drive problem under windows 2000 and am out of ideas to fix it. Please can someone help!!

    basically whenever I connect my USB flash drive to the PC, It appears in my computer as Local Drive(E) with the HD icon. If you try to open the drive I always get an error mesaage saying "cannot open drive, parameter not correct". I have tried formatting the drive, deleting the partition and reinstating it but it does not work. I have also tried mounting it under a directory and changing the drive letter. Neither seem to have any effect

    The drive still seems to work ok on other pc's though. It did not come with any drivers and as far as I can tell was designed to be driverless for all versions of windows from 98 onwards

    When I plug in my digital camera, which also appears a removable drive. I get a similar problem. This time though I get the removable drive icon and the drive is called removable drive(E) but when I try to open it I just get a message telling me to insert a disk as you would expect it you clicked on floppy drive without a disk in the drive.

    With both items under properties they show as full with 0MB space and 0Mb capacity.

    I am totally out of ideas and am now stuck with a plash disk I can't use and a camera with pictures on that I can't download. I do not want to have to completely format and reinstall windows unless I really have to.

    Has anyone else had this problem or know how to fix it or if there is some software I can get to do it.

    Please help!!!!:(
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your USB storage drivers may be corrupt.

    In Device Manager enable hidden devices and remove all USB devices you can find. Reboot and let Windows reinstall them.
  3. JW1

    JW1 TS Rookie Topic Starter

    Didn't work

    Hi, Thanks for the info.

    I have gone through the PC as you suggested but unfortunatly it had no effect on the problem.

    Thanks anyway - do you / anyone else have any other ideas?
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try reinstalling the USB-drivers that come on a CD with the motherboard, or get the latest version of them from the mobo-website or chip-manufacturer (e.g. VIA, nVidia etc.)
  5. JW1

    JW1 TS Rookie Topic Starter

    Thanks but this did not work either.

    All my other USB devices (printer scanner etc) are working fine. It only seems to effect my Removable storage devices. I have also found now that my MP3 player (which comes with its own drivers) is being effected in the same way. This also appears as removable storage.

    Any more ideas? Is it possible to edit or reset drive parameters using Disk management under win 2000 pro?
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  7. JW1

    JW1 TS Rookie Topic Starter

    Worked but Now have More Problems

    Excellent! That did the trick and I can now access my Flash drive and camera and have received some valuable pictures.

    Also before trying this I check my not often used floppy drive and as it turns out didn't work either until this fix.

    Thank you very much for pointing me in the direction of this link and saving from pulling out the rest of my hair.

    Unfortunately in doing this I have a couple of new problems.

    Firstly Nero InCD will no longer work. I just get a message saying “InCD is not working correctly. Reinstall InCD”
    If I reinstall it then the registry is changed back and I have the removable disk and floppy drive problem again. Any ideas?

    Secondly While trying to find the problems originally I deleted the partition on the flash disk. Now it is working again I find that can only create and format a partition with a maximum size of 24MB as opposed to the original 32MB. I have been using disk management tools to do this. How can I increase the size of the Flash disk partition to its original size of 32MB.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    How about updating InCD rather than reinstall?
    If all else fails, go get the free Avast! from www.avast.com instead of AVG.
    I run W2K/SP4 with all available MS-updates, and use AVG7. No Nero though.
    I have no problems whatsoever.
  9. JW1

    JW1 TS Rookie Topic Starter

    Thanks any Ideas on flash drive?


    I'll give that a try.

    Any ideas on how I can solve the capacity problem on the flash drive That i put in my previous post?
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go into Control Panel/Add/Remove Hardware/Uninstall/Unplug.../Uninstall
    then when it shows you the list, tick the box 'Show hidden devices'.
    Go through the list and uninstall all USB-keydrives and what have you, such as no longer existing devices, all duplicates, etc..
    Then reboot and try it again.
  11. JW1

    JW1 TS Rookie Topic Starter

    Didn't Work


    Tried this but it caused other devices to reinstall them selves after reboot. I then had to reinstall their drivers and reboot again.

    After connecting my flash drive, new hardware was detected and installed but it capacity of the drive remains at 24MB instead of 32MB.

    I tried using disk management again but still cannot increase the partition size.

    Is there no other tools / software that might help to adjust the size?
  12. JW1

    JW1 TS Rookie Topic Starter

    All problems solved

    Hi there,

    Finally solved the size problem using good old fashioned software. I attached the flash drive to a PC running win 98 and run the old FDISK prgram. This allowed me to see only 90% of available drive was being used.
    I then deleted and created a new partition with 100% of drive to get my 32MB back again.

    So it was Good old FDISk to the rescue. Shame it is no longer packaged with later versions of windows.

    Thanks to everyone for helping solve these problems I have had.
  13. Smurf

    Smurf TS Rookie

    Hi all

    I've got the same problem as the original poster. I tried the link to the AVG site but the message isn't there any more. Can anyone tell me what the problem is and how to fix it? I assume it involves removing AVG???
  14. JW1

    JW1 TS Rookie Topic Starter

    Hi, are you running an old version of Nero InCD? The issue I was having was caused by a conflict in the registry between this program and the drivers for removable media and the floppy drive
  15. Smurf

    Smurf TS Rookie


    It's not a problem with incd, it's similar to the original problem with the flash drive. My flash drive and multi card reader keep dissapearing.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...