NAS gone dodgy!

By Odyssey ยท 12 replies
Jan 3, 2010
  1. I have had a 500GB SimpleShare NAS attached to my network for some months and it suddenly stopped showing files.

    A few days ago, I had to restart one of the computers on the network and when it came back up and I tried to access the Simpleshare, the device did not show up (and neither did Workgroup). The restart may be purely co-incidental however, as it might have not been working for a few days previously and I just wasn't accessing it.

    In My Network Places, one of my computers still shows the SimpleShare "place" but when I click on it, I get a message that I am not authorized to view it. Strange, I was a few days ago.

    I can reach the NAS device via Explorer at and sign into the admin panel, but here is another issue.

    When this device was originally set up it's network group name was somehow set as Workgroup, while all of my Windows computers are on MSHome. That did not seem to be a problem as "Windows Network" showed both and when I clicked on Workgroup, the SimpleShare drive was there.

    So through the admin panel, I attempted to set up a new network name as MSHome so as to match the computers on the network and was able to do so, but when I click on the SimpleShare under MSHome in My Network places, it shows a netfolder, but there is nothing in it. I was hoping that it might somehow show me the files on the hdd.

    I am reluctant to set up a new "Workgroup" network name for fear of it conflicting with the existing one (but which is no longer showing up in under My Network Places) and not allowing me to see the files.

    The hard disk is running as I can feel the vibrations of a running drive by just putting my hand on the NAS.

    The fact that I can reach the admin panel of the NAS is encouraging (but this is probably a matter of reaching the controlling software of the device rather than reaching the hdd inside the box?), but also when I click on the new netfolder under MSHome, I can copy files into the share, open, close, and delete them. Hopefully this confirms that the drive is not dead.

    It seems that others have had similar problems, but no one has yet posted a solution, so this looks like a good bone for those who understands NAS's to sink their teeth into. Please help as I, and others, have a lot of important data there.
  2. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    NAS has two levels of access
    1. the network stuff (workgroup name, ipaddress)
    2. the NTFS permissions for each directory on the HD
    Was that the orignal folder name and the container that had all the files in it
    was that just one of many?
    if (1-2) above are correct, then YES, that should have worked
  3. Odyssey

    Odyssey TS Rookie Topic Starter Posts: 23

    Only one network group name

    Prior to the problem, there was only one network group name, Workgroup. So, if I understand your post, the new network group name, MSHome, should have shown me the files, no?

    So the conclusion must be that I did not understand your post. Please elaborate. Thanks.
  4. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    You understood correctly -- the files should have shown up.

    Can you verify the Permissions on the Drive and then on the folder (netfolder)?
  5. Odyssey

    Odyssey TS Rookie Topic Starter Posts: 23

    Sorry for the delay, but I have been trying, unsuccessfully, to determine the permissions. May I ask you how to do this?
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Did you ever create logon access passwords for the NAS or shared folders?
    > Try mounting the device/folder using Explorer, are you prompted to login? Can you login?

    Also, I'd guess the device must have a master reset button/option that should restore all NAS factory options (and shouldn't affect the file/folder data). Try resetting the NAS
  7. Odyssey

    Odyssey TS Rookie Topic Starter Posts: 23

    I am now and have been able to sign into the admin panel using a browser. I believe this is what you refer to.

    I have reset the device using a paper clip. The device returned to the same state that it was in before the reset.

    In the admin panel, I have created a "new" Workgroup now in hopes that will lead me back to the existing files, and enabled them in remote access, but it also didn't seem to change anything.

    The hdd seems to be working, but something has interfered with my access to the numerous files that were there before the share stopped showing them to me.
  8. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    good question.
    AFTER the disk or directory is accessible, its right-click->properties->security.

    However, that is too late if you don't have <full control> ; this should be a setting on the NAS
    ADMIN page(s) somewhere.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No. You're talking about being able to access the NAS admin screens

    I believe that'sdifferent from when Windows tries accessing shared folders. Though once you did the reset i would think that should;ve removed any password requirements for shared folder access.

    But still advise you try
    > Open Explorer
    > In the address bar enter \\SimpleShare (or whatever the server name)

    Do you connect to the NAS? Are you prompted for logon? Can you logon? Do you see your folders?
  10. Odyssey

    Odyssey TS Rookie Topic Starter Posts: 23

    Yes, I can reach the device by entering " //simpleshare/ ", and it gives me the options:

    The link below will let an administrator configure SimpleShare settings


    The link below will let a common user browse shares that have been created in SimpleShare.

    each of these links takes me to an admin screen

    And if I put in \\simplshare\netfolder , it shows me the file that is presently there (one I copied in and left).

    But if I put in \\simpleshare\workgroup, it does not show the files that were there before. I can however add and manipulate new files.

    I can't work out where the previous files are. Clearly I can reach the device, but somehow the numerous files that have been there for months, and which I believe to still be there, are not visible.

    This appears to be some sort of share or permission issue, no?
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'm curious about the opinion from others.. but i'm concerned about the info you state.

    1) There are many reasons why accessing a share from Network Places might return "No access privilege" type errors

    2) BUT... if you can successfully connect to a shared folder from Explorer (e.g. by using \\SimpleShare\foldername) i think you should then be able to see everything inside of that folder

    If you aren't seeing your data in the share from Explorer, then i'm concerned if it's still there.

    ?* EDIT */
    I'm guessing you checked to see the names of all shares on the drive? And you've looked inside each share?
    Also, if data is missing, you might be able to recover by removing the hard drive and then attaching it to your computer as a local hard drive. You could then try running data recovery tools (not certain but i think you need the drive to be local to attempt the recovery)
  12. Odyssey

    Odyssey TS Rookie Topic Starter Posts: 23

    Thanks for yours.

    I am now updating. I have been in touch with Simpleshare (SimpleTech, which is a division/sub/something of Hitachi) tech support.

    The extent of their meager assistance was to advise that the NAS device uses a file system called "reiserfs" and that it might be possible FOR ME to recover the data using specialized file recovery software for this file format, but they had no interest in assisting, even though this appears to me to be a fundamental device fault. Probably needless to say, I have bought my last SimpleShare hardware.

    Anyway, I have been googling for software, and have found some, but now need some guidance and recommendations as to which package/s I might use. Writing off the drive was expensive enough, but I hope to not add to that by finding either freeware or inexpensive shareware to attempt the task.

    Has anyone had any experience with this format? If so, have any of you done a recovery?

    Many thanks.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Wow. I never heard of "reiserfs" before...

    But some maybe (hopefully) good news.. There's a data recovery tool called TestDisk (and it's freeware!). I've never had occasion to use it myself but have read posts by many people in various forums who've used it with good results
    AND i checked. It supports the reiserfs filesystem as well

    I think you'll still need to deal with removing the hard drive to connect it locally before you can attempt recovery. Also is helpful to create a copy of the drive image before attempting recovery as recovery tools will write to/modify the drive. So even if a recovery attempt goes wrong you can still get back to the drive image as it currently exists. [post=836788]See this post also[/post]
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...