Need help fixing broken Gamecube

By SirSpanky0 ยท 10 replies
Dec 28, 2005
  1. So my gamecube randomly stopped working. When I turn the power on, the fan turns on but that's it. No picture, no light, no disk spinning. Is there a quick remedy for this? Has this happened to anyone else? Do I have to buy another cube?
  2. crazdude

    crazdude TS Rookie Posts: 183

    sounds pretty f*** to me, lol, if I were you i would sent it back to nintendo or something... if u havent got any experience with electronics like that then I recommed dont try to do nething urself...
  3. SirSpanky0

    SirSpanky0 TS Rookie Topic Starter

    can i get a response from someone who can spell?
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Certainly does sound like the power circuitry when caput. Perhaps it gets power to the motherboard (thus fan spin) but nothing else?

    Couldn't say there is any "quick" fix for that. Some whole component likely needs replaced, assuming your power supply and cabling and all is in good shape.
    Sure you don't have a warranty on it? See what Nintendo has to say.
  5. LordScythe

    LordScythe TS Rookie

    Oooh, burn.
    Sorry, I've got no idea.
  6. omegaweopon

    omegaweopon TS Rookie Posts: 25

    I have come across the same problem. Keep calm. Run a few tests and check back..

    1st test)Check your disks carefully it might be a disk problem. And yes it is quite possible ALL your disks are screwed up. If they are all broken then thats why

    2nd test)Insert your disk into the machine and keep the tray open. there is a button just by the open button on the inside hold it down. This is the button that tells the machine the lid is closed. Check if the disk is spinning. WARNING! in leaving the case open while the laser is running exposes you to harmful radiation. Dont open for too long. If none of your games work then there is a chance your motor has burned out.

    3rd test) JIGGLE THE HELL OUT OF THE CORD.. you have no idea how many times that has happened to me.

    Check back with your findings
  7. omegaweopon

    omegaweopon TS Rookie Posts: 25

    wow i reread what you wrote and umm i think i misinterpreted what you were asking umm. JUST GNORE MY ADVICE! I WAS NEVER HERE!!!!!!!!!!!
  8. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Well, to start- you have to ask yourself if it's even worth the time and hassle. Refurb Gamecubes are about $79 and new $99. You might spend the better part of a full day just diagnosing/isolating the problem before nailing it down to what's broken.

    Does the power light flash once then turn off? Or is it totally dead- not coming on even for a moment?

    If there is no light, it's definately a bad/burned out component. I don't know of any quick/easy or common issues where the power light is dead on power-on. It's usually something more invasive internal to my knowledge.

    The best case is there IS a fuse in the unit that is fairly cheap to replace, but it's not user serviceable. You need a special screwdriver (4.5mm) to get into the thing and the fuse isn't in the easiest location to replace (requires some internal surgery). If you know a local that mods these things (for Japanese games or whatnot), they might have the tools and expertise to check/repace the fuse.

    If you want to try this, I'd try googling and usenet on how to install a USA/JPN mode switch as the surgery is similar. You'll have to remove the mainboard and get under this to get to the fuse. You'll still need the special 4.5mm security screwdriver to get the unit apart though.

    And yes, the fans will still spin if the fuse is blown. It's a mainboard fuse only on the power lines to the GPU/CPU. It's commonly blown by overseas users using incorrect power converters.
  9. stephf

    stephf TS Rookie

    I had the same problem after I lost my power cable/adapter when moving & bought a 3rd party adapter off ebay.

    All was going fine for a day or so, then it stopped working with only the fan would run on boot. I've tested it using a mates power adapter and all was working ok so I'd try using a different power adapter before changing the fuse or taking the thing apart. Though quick note... a bit of info from 'Kinsman' on another thread that worked for me was to melt a plastic biro and press it to the GC screws instead of having to buy the special pikey!
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    I had a power supply on my GC die as well. I got a new one and everything has been fine since.
  11. hairyviking

    hairyviking TS Rookie

    Did you ever get to the bottom of this? I am in exactly the same position now, fan but no LED. I have tried google to try and find which fuse may be blown but with no luck.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...