New build - powers on, black screen

By Severemc ยท 10 replies
Jun 10, 2010
  1. Alright... Now I seem to have another problem with my set up. It powers on, all the lights work, fans work... but nothing shows on screen and I don't hear any beeps. I've made sure the system speaker is connected correctly.

    Here is a list of everything I have connected.


    * XCLIO Windtunnel Fully Black Finish 1.0 mm SECC Chassis ATX Full Tower Computer Case

    * CORSAIR CMPSU-750TX 750W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS Certified Active PFC Compatible with Core i7 Power Supply

    * ASUS M4A89GTD PRO/USB3 AM3 AMD 890GX SATA 6Gb/s USB 3.0 HDMI ATX AMD Motherboard

    * AMD Phenom II X6 1055T Thuban 2.8GHz Socket AM3 125W Six-Core Desktop Processor Model HDT55TFBGRBOX

    * CORSAIR XMS3 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CMX4GX3M2A1600C9

    I've disconnected everything else. I even tried both sticks of memory, one at a time.
  2. kaldrouby

    kaldrouby TS Rookie

    start with trouble shooting the "BIG FOUR"
    Graphic card

    in this case i suggest reset the graphic card and make sure all connections are seated well after that if it dosent work you could fix it by swaping the Graphic card with a different one to determine if its a GC issue .

    one question you see black screen ? do you even get to see the bois menu or nothing at all?
  3. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Are you using the onboard graphics?
  4. Severemc

    Severemc TS Rookie Topic Starter

    Yes, I'm using onboard graphics. No bios or anything.
  5. cartera

    cartera TS Evangelist Posts: 365   +113

    I would find it unlikely to be your RAM since you should get the Bios screen and a beep if that had failed. I think your looking at a mobo failure or processor, have you made sure that your processor is installed correctly and check the pins on it as well, they are very easy to break!

    The only real way to check your processor is to mount it on a different mobo, even with a bare set up of just the mobo and processor connected to the psu you should get a beep and the bios screen!
  6. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Did you connect the 4 pin ATX 12V connector on the motherboard to the power supply?
  7. Severemc

    Severemc TS Rookie Topic Starter

    Yes. I've tried both the 4 pin and 8 pin connector.
  8. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    What is the condition of your PC? That is, is there an operating system installed yet or did you just build it and this is what you are getting? Or has it been working and this problem suddenly started?
  9. Severemc

    Severemc TS Rookie Topic Starter

    I just built it and this is what is happening.
  10. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    It might be the BIOS needs to be updated to recognize the new 6 core processor but the motherboard needs to post first or maybe the motherboard itself is defective.
  11. trooper_ai

    trooper_ai TS Rookie

    It is most likely that you have the CMOS jumper in the reset position. Check the manual to see where it is and of it needs setting to normal?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...