New Hard Drive Problem (What's going on here?)

By NiceGuyEd ยท 35 replies
Oct 12, 2004
  1. What's going on here??

    Hello all.

    I'm having a bit of trouble with a new harddrive I bought.

    Here's the deal:
    I have two old systems still kicking around, both with Windows 98se on them. One system has an 80gb WD JB80 and a 20gb Barracuda in it. And the other system has just a 7gb WD in it.

    I just bought another 80gb WD JB80 drive to add to that second system. However, there was about 30gb of data on my first system's 80gb drive that I wanted to move to the new 80gb drive.

    So I hooked up the new 80gb WD drive to my first system (the one with the 80gb WD & 20gb barracuda) and ran the utitlity off the Western Digital website that partitions it and makes the drive ready to use.

    I transferred the 30gb or so of data from the first system onto the new drive. Everything worked flawlessly. All the files there and working when I opened them. However, when I then put that new drive into my 2nd system.... the drive showed up in Windows Explorer but many of the folders were missing and all of the files had some strange garbled foreign looking text!?

    What exactly could be the problem? I did put that drive back into the first system to check the intergity of the data that I had just copied and all was well. And everything is FAT32 and Windows 98se.

    Any ideas as to what the heck is going on here?

    - Please use proper thread titles
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    The Western Digital utility probably put some coding on the first harddisk in the PC where you copied from.
    This code is missing in the second PC, so it probably cannot read the new disk properly. Perhaps you could run the same utility in the new PC as well. Worst case, you have to recopy the data from the first PC again, but the receiving PC is now ready for it when you finally put it back in again.
    You still with me?
  3. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Thanks so much for the reply.

    I'm not sure I'm exactly with you... :D

    The utitlity that I ran formats and partitions the WD drive. Are you saying that I should just put the new drive into my 2nd PC and run the utility on it from the WD site? This will format my drive, correct?

    If that's what you are saying, then in effect won't the same thing happen except opposite? Wouldn't my first PC (the system I'm copying from) have problems recognizing the drive?
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    No, the information that WD puts there, goes to either the MasterBootRecord MBR or into the HD's system area (from the bootdisk of that PC).
    When you run this util in your new PC, with the new HD in it , it will also put this info in the MBR/System Area of that other PC. If it formats the new HD, it should still be the same as if it had been formatted in the first PC.

    To recapitulate:
    -put new HD in old PC, run WD-util
    -put same new HD in new PC, run WD-util
    -put new HD back in old PC, copy data onto it
    -put new HD in new PC
    -enjoy data from old PC in new PC
  5. Justin

    Justin TS Rookie Posts: 942

    You speak a fallacy. There is no "Bootdisk/system area" of a PC. The MBR on a hard drive contains the partition information and signals the bootable partition and then the partitions themselves contain the start of the bootloader, assuming it is a chainload (otherwise the bootloader resides in the MBR). MBR will not change no matter what PC you put it in.
  6. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Ok.. so what should I be doing? :confused:

    I tried running the WD utility on the other computer and recopied all the data, but it still appears all garbled and corrupt. When I put the drive back in the computer I copied it from, it all worked fine.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. Justin

    Justin TS Rookie Posts: 942

    You said PC, not the hard disk. I was assuming you meant some form of storage located on the motherboard itself. And it doesn't matter anyways because there is absolutely no information of the sort you speak or other form of "tag" information in this particular scenario that would/could cause a disk to be "partially" unreadable in another machine. Pure fallacy. Trust me, I know in great detail how a hard disc works and how the BIOS interprets it.

    NiceGuyEd: I think your problem stems from either a bad IDE controller or missing support in Windows98. Firstly, use windows update on both machines to ensure you have all the latest updates. Afterwhich, I advise you to reformat the new disc once using Windows98, not using the WD utility. After this, transfer your data again. If the same problem occurs, then I suggest you partition the new disc into 3 partitions, each less than 32GB in size, and then transfer your data once more. If you STILL have the problem, try another computer. If it does not persist on another machine you may have a bad IDE controller on one machine.
  9. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter


    Both machines are fully updated from Windows Update.

    So I should run FDISK on this drive instead of the WD utility? If so, does it matter what computer I run FDISK on it from? Since this is a storage drive, what do I partition the drive as once in FDISK?

    Thanks again for your time fellas! :)
  10. Justin

    Justin TS Rookie Posts: 942

    It does not matter which computer you use FDISK in. Since you will not be booting off this disc, you should probably create an extended partition spanning the entire disc, and then logical drives (just 1 at first using all the space, then later 3 if it still doesn't work) inside the extended.

    Actually, now that i think of it, you may have another problem. Read this article:;en-us;263044

    This copy of FDISK here:

    Supports drives >64GB.
  11. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Although I'm not getting anything on that link. Is there another place I can grab that version?
  12. Justin

    Justin TS Rookie Posts: 942

  13. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Well I found the link at the bottom of "New Fdisk for Hard Drives Over 64Gig"... but when I go to the link, I end up at that Microsoft page and there it states:

    I'm not experiencing that problem...

    It then says:

    Is that still what I need to run? Wait... perhaps your saying run FDISK and then I'll get that problem. And then download the that FDISK fix.
  14. Justin

    Justin TS Rookie Posts: 942

    Yes sir, that is what I mean.
  15. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Awesome... thanks Soul Harvester.
    I'm trying it right now. :)
  16. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Ok, I created a Logical DOS Drive in an extended DOS partition. As assumed, it showed my harddrive as 10GB. I then ran that FDISK patch and restarted the computer as it said to.

    Strange, but now the drive is not accessible. I'm getting the drive letter, but it is saying "D:/invalid media type" when I do a 'dir' on D: in MSDOS and in Windows it is giving me "D:\ is not accessible."

    Any ideas? This is just rediculous... :confused:
  17. Justin

    Justin TS Rookie Posts: 942

    You need to FDISK it again after applying the patch, deleting all old partitions and creating a new extended +logical. Try that and post again.
  18. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Ok. I'll try it right now.

    I forgot to mention that this drive is going to only used as storage. The 7gig drive that is already in this sytem is used for the OS and applications.

    I'll report back with my outcome.
    Thanks again. :)
  19. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    Ok. I ran FDISK again and created a Logical DOS Drive in an extended DOS partition on the 80GB WD. Which is the D: drive.

    For some reason, it still is showing maximum capacity being 10GB and in addition, it is still giving me the inaccessibility errors as before.

    I installed that patch from within Windows before I redid the FDISK. Have I missed something? :(
  20. Justin

    Justin TS Rookie Posts: 942

    Do you have a computer running Windows 2000 or Windows XP?

    I'm not sure why the fix isn't working. I would suggest you search for another version of FDISK that has >32GB support.
  21. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    No, just 98se.

    I'll take a look for another version of FDISK. Thanks so much for your time.
  22. Justin

    Justin TS Rookie Posts: 942

    Not a problem. As long as you are still able to post I will try to help with this situation.
  23. NiceGuyEd

    NiceGuyEd TS Rookie Topic Starter

    I couldn't find a better/different version of FDISK. I just can't figure out what's going wrong here.

    I think I'm going to try just running the WD Utility again on the new drive installed in the computer that it is going to sit in, and then transfer all the data to it from the other WD drive via LAN.

    What do you think about that approach? 30GB of data transfer over a LAN sure won't be very speedy... :D
  24. Justin

    Justin TS Rookie Posts: 942

    That sounds like a decent plan and hopefully will work. Shouldn't take too long if you have a 100mbp/s networking device and both machines have 100mbp/s cards.
  25. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    After you FDISK, you also have to FORMAT.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...