New mobo leads to USB, DVD rom problems

By MellyJC ยท 10 replies
Jun 15, 2005
  1. Hopefully I'm posting this in the right place...If someone knows better please let me know.

    I got a new mobo, I guess the old one shorted out or something. I tried to install the drivers that came with it for the USB ports, however, the CD kept telling me to "install SP 2 first". SP2 is already installed. So it takes me to a webpage and I followed the instructions, which were to go in and install them through the device manager. Which I did.

    The problems I'm having: When I boot up, the computer does not register the mouse (through USB) until I unplug it, then replug it into the socket. Then the light on the back of the mouse comes on and I can use it. If I reboot at this point, the mouse is still recognized; it's only from a complete powerdown. I'm currently using a PS2 adapter and having no problems since I'm not going through the USB ports.

    The extra USB ports that came with the board and fit into the PCI slot don't work at all for some reason.

    My camera: I have an old Kodak DC3400 digital camera. With all the new USB ports (my old comp didn't have them), I'm finally using those to connect instead of having to go through the serial port to get my pictures. This is much faster, of course, except for connection problems.

    The camera has to be plugged in and turned on in order for me to connect to it. If I plug it in after booting, it makes the sound that it's connected new hardware and opens a window for "what would like to use to connect" although nothing shows up. I go into it like another drive, nothing shows up in the window, even though it's there to click on in the drive letter menu. If I click the bar on the side to "get pictures" it says that no scanner or camera is detected.

    The only way I can access my pictures is to boot up with the camera already attached and turned on. Even then, I cannot go into it like another hard drive; it says the camera is "busy or unavailable" and to try again later. I have to use the "Scanner and Camera" wizard, which, given that it hung up halfway through last time I was downloading 800 pictures and therefore had to go through in segments, manually CHECKING EVERY INDIVIDUAL BOX, I don't care for. I would much prefer the drag and drop ability.

    Definitely seems like a USB port issue. But I don't know what to do about it. The manager says they're all "working properly".

    And...the CD rom. The green light is on constantly. I can swap CDs and play them in iTunes, but nothing else is recognized. If I put a CD in after bootup, it's not recognized and tells me to insert a disc. I have to reboot for it to acknowledge the disc, and I know this isn't right. I didn't used to have to do this.

    What's up with my system? What can I do with the USB ports? Is the constant green light on my CD player any clue? My dad says it should show up in diskmgmt.msc or it should not be recognized in "my computer". It always shows up in "My computer", but only in diskmgmt if I've booted up with a CD in it.

    Please help...I'm tired of rebooting.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    you didn't provide any specific hardware detaile, but i'd say you need to reinstall windows to get it working right with your new hardware.
  3. MellyJC

    MellyJC TS Rookie Topic Starter Posts: 36

    The hardware stuff is in my profile, I think. Abit Athlon Sempron 3100+ set.

    Of course the USB are all integrated into the mobo, and we had to reinstall Windows in order to even get a working OS, so that *shouldn't* be it since it's already been done.

    I don't have the details on the DVDrom. I think it's 10x, but that's all I know off-hand- I'm not at home right now.
  4. Grok451

    Grok451 TS Booster Posts: 85

    When you installed the motherboard, did you install all the drivers from the CD that should have come with it? If you've already done that, visit the mobo manufacturers website and download and install the current set of drivers, which will probably be newer than what's on the CDs.
  5. MellyJC

    MellyJC TS Rookie Topic Starter Posts: 36

    Yes I did. Of course with the DVD problems, it took a lot of reboots, but anyway.

    I mentioned it in my original post I believe- the USB drivers said to install SP 2. Which was already installed. So it sent me to the website with instructions, which I followed, and installed the drivers for the USB through device manager. I've since tried to "update drivers" and uninstall/reinstall the drivers, but with no progress- it says I have the best drivers for them.
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Check in the BIOS that USB is enabled, that might be your problem.
    If you look under Control Panel/System/Device Manager, are there any red or yellow 'flagged' items?
  7. MellyJC

    MellyJC TS Rookie Topic Starter Posts: 36

    Don't recall seeing USB anywhere in the BIOS, but I'll check again.

    No flags, a couple red xes, but I know what those are- cutting out the defaults of built in sound and network card. Everything else is fine, supposedly..
  8. Grok451

    Grok451 TS Booster Posts: 85

    Since you already have a sound card as well as a network card(?), while you're in the BIOS setup, you should go ahead and disable those functions. Also, I wasn't clear about your drivers - were those the Microsoft Windows drivers are the Abit drivers for you mobo, specific to you chip set? Just double checking that you've installed all of the mobo drivers, not just the standard Microsoft drivers for your hardware.
  9. MellyJC

    MellyJC TS Rookie Topic Starter Posts: 36

    Yea, thought it was odd how it included built in surround sound and network card but the mobo didn't have a port for the monitor!

    Anyway, reverted to the old ones because I had trouble getting them working. Sound card was only going to one set of speakers, and I don't remember all the funkiness surrounding the network card, so I just defaulted to what I know works. I think I found out the soundcard problem, and we've since gotten a new router, so maybe the network card would too, but I don't see the point at this time. Since they're disabled and not being used, what would be the benefit of disabling them in the BIOS?

    The mobo drivers for the USB wouldn't install, so it told me to use Microsoft to install it's using the Microsoft drivers now.

    Interestingly enough just booting up now I got the message that Windows recovered from a "serious error" caused by a device driver. Lucky me. I'm kind of scared because that's the message I got before my last mobo died.
  10. Grok451

    Grok451 TS Booster Posts: 85

    Disabling in BIOS just eliminates one more thing to worry about and I *think* frees up some IRQ's just in case there's some problem there. Admitedly it's a shot in the dark, but I always go for the easy things that can't hurt - you never know.

    I am concerned that the mobo USB drivers wouldn't work - I'd focus on that issue. Try looking at this website: Maybe you'll get some tips or at least things to try!
  11. redmistpete

    redmistpete TS Rookie Posts: 38

    I have the same problem with my Microsoft USB keyboard and mouse - I have to unplug and re-plug to get it to recognize them. I don't think it's a USB driver issue though as all my other devices, Camera, Modem, Hard Drives, Memory drives etc work fine and my drivers are up to date. Any ideas please?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...