1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

New PC, Not recognizing boot devices

By FlawlessApe ยท 8 replies
Sep 24, 2005
  1. I just got finished assembling a PC last night. The problem I'm having is I can't get the os on it. When I go to put in the Windows XP installation disc it just continues on showing all the connected hardware. I have the same problem if I try and put in a bootable floppy disk, it shows the connected hardware inside my computer and then ends by saying "Error No OS", which is apparent. I've tried a few different boot sequences but the computer just fails to recognize the disc or floppy is even there. I've checked to make sure the floppy disks and drive are working and if the Window XP disc is readable. I just put the DVD drive into another PC to make sure it works and it had no problems, I had an audio CD playing with it. If anyone can help me with this it would be greatly appreciated.

    My PCs Specs are:
    ASUS A8N SLI Deluxe
    Chaintech GeForce 6600 256MB PCI-Express
    AMD Anthlon 64 3700+ 2.2GHz
    256MB DDR400 RAM
    Samsung DVD Drive
    120GB Western Digital 7200rpm HDD (Master)
    8GB Maxtor 5400rpm HDD (Slave)
    Some old floppy drive, Still works though...
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Hello! Welcome to TechSpot

    Are you getting the post screen?
    if so,
    Sounds like boot priorty in the bios.

    You need to make sure how the devices are setup ie;
    hdd as master/slave.....jumpers on the drives.
    cdrom master/slave....""
    Then in the bios you need to select what device you
    want the mother board to boot from first, in this case the cdrom.

    If you have now hdd or cdrom hooked up will the machine
    see the floppy drive and boot to it?

  3. FlawlessApe

    FlawlessApe TS Rookie Topic Starter

    I've had some people telling me that earlier. I double-checked the jumper settings on my 2 hard drives and the disc drive they both seem to be fine and the bios recognizes that they're all connected. My boot priority is CDROM, Hard Drive, Removable, None. The bios seems to be ignoring the fact that i changed the boot priority and goes straight to the Hard Drives. When i take out the HDDs it says DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER. I'm starting to wonder if i bought a defective motherboard... :(

    When i take out the cd drive and the hdds it still does not boot to the floppy, I rearranged the priority to Removable,None,None,None also. I just get this error, which seems to be coming up whenever i take out the hard drives "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER".
  4. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966


    If the bios is seeing the devices and boot priority, that generally means
    it's passing the devices it doesn't see boot files on and going to the hdd
    ie; message above.

    This can only mean that the cdrom/floppy is dead or the ide 1/2 channels are.
    I'm thinking its the cdrom and the floppy disk are bad. Most likely the hdd
    and floppy drive are ok. Is the system at least trying to boot from cdrom?

    Do you have the means to test the hdd on another system or
    have access to another cdrom?
  5. FlawlessApe

    FlawlessApe TS Rookie Topic Starter

    I know for sure that the disc drive and floppy drives work. I tried a few bootable floppies and the system says that there are no floppies inserted. And i do actually have another PC i can test the hdd in, when i tried it out it was working fine and i tried installing the os disc on the other PC that I was testing the HDD in and it installed fine, so theres no problems with the Windows XP disc. The OS on the Hard Drive now doesn't work in the New computer that i'm building now, I guess thats because they have different bios settings. Along with the HDD, I tested dvd drive and floppy drive in that PC as well and they were working fine.

    Before the computer goes to start up the HDD the disc drive starts to make a really loud sound like its going to start up the cdrom for about 10seconds, but then it just says No os.
    I don't understand how either of the drives or IDE channels could be dead though, if the Bios is recognizing the hardware whenever I connect them to the motherboard. That's why I'm starting to think that its the actual BIOS that's broken or defective.
  6. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    This is getting weird

    Your trouble shooting is awesome...
    This is starting to sound like maybe bad ram or even
    a bad ide cable(s).
    I had one once that had tiny little
    holes in it that were the same distance apart as
    jumper pins (like the cmos clear jumpers). I did get
    the OS installed but had continual bsod's.

    No point in suggesting bios update if the floppy
    isn't working on this MoBo.

    Looks like you'll need more ram, 256 will work but 512 is
    the best.
    How old is the MoBo? Still under warranty?
  7. FlawlessApe

    FlawlessApe TS Rookie Topic Starter

    I bought the Motherboard on the 19th so it does still have the warranty, which is good. I understand that I don't have too much RAM atm either, I'm waiting for my 1GB ddr to come in, this ram is actually from one of my other computers. So I know for sure that the RAM works, unless theres something i don't know about the compatability of it with my motherboard. I'm going to go test some other IDE cables, as you suggested they may not be working correctly. I have some other ones that should work fine on this.
  8. FlawlessApe

    FlawlessApe TS Rookie Topic Starter

    Well, I tried replacing the IDE cables for the Floppy Drive and Disc Drive. The ones I had in there were the ASUS ones packaged with the motherboard. I replaced them with the IDE cables that came with the actual devices. The floppy drive is now connected to its original IDE and the disc drive is connected to the one packaged with it. I didn't bother replacing the IDE cable connecting the HDDs because the system is having no trouble booting to the hard drive. Unfortunately it doesn't seem that anything has changed from before. The "ASUS Speech POST Reporter" is still saying "No Floppy disk detected" and the Windows XP disc is not booting (there isn't a POST reporter that says the bootable CD is not detected).

    Let me know if you have any other suggestions. If not, I'm probably going to have my Mobo shipped back and replaced. The sooner I do that the sooner I'll get it back. If there is any else I've missed though, I'd much rather fix the problem now than have my whole motherboard replaced to realize there was nothing wrong with it.
  9. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Thank the CPU gods for warranties

    No, I think we've covered all I know to check.
    Sometimes it happens this way, you just never know
    what the cause is till things get switched out.
    If all your componants are checking out in another system
    then that leaves us with the MoBo.

    Maybe some of the other members here will see something I've missed.
    Let us know what works out :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...