1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

NIC installed, cables plugged in, no connection?!?!

By beerabuser30
Apr 2, 2006
  1. This is what I am trying to post in the OS area

    My friend takes her computer to Geek Squad for a PC Tune Up. Comes back plugs the internet cable in and it doesn't work. So she calls me and the first thing I do is check to see if the connection to the internet is working, and the cable is ok both are fine. I try to ping a website and it shows nothing, automatic updates aren't working. Try a few browsers and nothing. Run spyware and anti virus and its fine except a Trojan virus which I got rid of. Try to just setup a new connection and that doesn't work. Turned off Windows Firewall because that has given me hell before. The whole time in the taskbar its says local area connection 100mbps. So I assume the NIC card is working. It is a newer HP and the internet connection is cable. It's running XP. Thoughts? I don’t have it in front of me so a bunch of suggestions for next time I go over there would be appreciated.
  2. kirock

    kirock TS Rookie Posts: 1,221

    Uninstall the card from the Device Manager. Shut down the PC. Remove card just to reseat it just in case. Start up and let windows find it again and install drivers for it. I am assuming it is a NIC and not on-board LAN right? If it is on board, then boot into BIOS (DEL or F2 key usually) on power up. I think it's under Accessory PCI Devices, make sure it's enabled. After boot make sure it's there in the Device Manager and is enabled.
  3. beerabuser30

    beerabuser30 TS Enthusiast Topic Starter Posts: 200

    Ill try that thank you
  4. bradthegreat

    bradthegreat TS Enthusiast Posts: 104

    if you're still a no go after reinstall, try checking the network settings (Start>Control Panel>Network Connections>Local Area Connections). Select Internet Protocol (TCP/IP) (it's usually at the bottom of the list) and hit properties. You will probably want to Obtain an IP adress automatically cause most cable internet is set up like that. That's what I'd try i you're still having trouble.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...