No device found ! / Bios not installed....

By RickM ยท 10 replies
Mar 23, 2005
  1. Hello,
    Thank you for taking the time to read this message.
    Four days ago I went to a computer show and bought an Asus P4C800-E deluxe mobo, 1024MB or RAM, Intel Pentium4 3.0Ghz CPU.
    The next day I removed the old Asus A7V133 mobo and installed the
    P4C800-E. Installed all the cards etc.
    I fired it up and this is what I saw at post:
    First the post screen with the Asus Logo.
    Then it went to a blank screen that stated:
    SATA 378 TX2 plus (tm) BIOS
    c 2000 -2005 Promise Technology All rights reserved
    Then the system was snooping around for something which stated:
    Detecting ..........
    Then :
    No device found !
    Bios not installed.
    The system went to the usual Start Windows normally, safe mode etc.
    I selected normally and the system just kept on looping from the beginning LOGO to the selection of Start Windows normally, safe mode over and over.
    Finally, I said the heck with it and formatted the H.D.D. and install windows XP.
    This time the system fired up into Windows XP to the desktop.
    I continued to get the same screen after the post and LOGO:
    SATA378 TX2 plus etc.etc. etc.
    I was wondering if "NO DEVICES" were found and "BIOS NOT INSTALLED" then why was the system booting into Windows XP :suspiciou
    I went to and got the newest BIOS, created a bootable disk and Flashed the BIOS by using AFUDOS ..... afudos /i<filename>
    where <filename> was the name of the new BIOS. The new BIOS was installed.
    I still keep on getting the second screen No Device found !
    BIOS not Installed
    I am now thinking the system is looking for SATA devices and BIOS. I am not currently using any SATA device.
    I do not know what is happening.... Could one of you "Pro's" straighten me out and let me know what is happening ?
    Any information will be appreciated.
    Thank you.
    Rick M.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Yes, the controller is looking for SATA devices and since it can't find any it won't bother loading the SATA BIOS. This normal and everything is OK with your computer BIOS.
  3. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    disable the SATA controller by either a jumper on your MB or in BIOS. RTFM for procedure.
  4. blaacksheep

    blaacksheep TS Rookie Posts: 70

    "RTFM" LOL 8-b

    Yeah, just disable the SATA controller in your BIOS!
  5. RickM

    RickM TS Member Topic Starter Posts: 27

    Thank you everyone for your help. I appreciate it.
    Rick M. :wave:
  6. gustiewind

    gustiewind TS Rookie


    Help please!
    I have an AMD 64 running on an ASUS CPU and everything has been fine until a few days ago when the computer started freezing after being left idle for about 15-20min, it happens everytime and the only option is rebooting the system. I did some basic checks and got a Disk Failed message:
    <controller 0, channel 0, Master>. Then I noticed that on booting:
    The Primary IDE Master: Not detected
    The Secondary IDE Slave: Not detected
    The Secondary IDE Master: PIONEER DVD-RM DV
    The Secondary IDE Slave: Not detected

    Any help will be much appreciated. Many thanks in advance.

    Gus :knock:
  7. iss

    iss TechSpot Chancellor Posts: 1,994

    It sounds like your hard drive has gone belly up.
  8. MightyKing

    MightyKing TS Rookie

    Hi, i had the same problem, i fixed it by going into BIOS setup.

    I went to 'Advanced' then to 'Onboard Devices Configuration' and disabled it.

    This got rid of my "BIOS is not installed" problem.

    What i did, is that this?-->

    But i still have another message appearing when i start my pc.

    After the MOBO startup screen, i get this message:

    "Sil 3112A SATALink Host Controller BIOS Version 4.2.10
    Copyright (c) 1997-2003 Silicon Image, Inc.

    Primary Channel: Drive not found
    Secondary Channel: Drive not found"

    How do i fix that? Does that mean something wont work correctly on my pc?

    Help please
  9. Daveskater

    Daveskater Banned Posts: 1,687

    hi mightyking, if you look at the date on this thread it goes back to january 2006 so you might want to make your own thread and link to this one ;)

    it sounds kind of like the bios has stopped detecting your hard drive but make your own post and see what other people think :)
  10. MightyKing

    MightyKing TS Rookie

    I see, ok thanks i will.
  11. gustiewind

    gustiewind TS Rookie

    Bios not detected

    Hi there,
    I actually solved the problem by Reformatting my hard drive. I had to set up Windows XP again and repartition the drive. I know this sounds pretty radical but I had luckily backed up up my files. I am not an expert and could not understand some of the messages people trying to help sent so I decided to go for the 'brain surgery' solution as I needed to get rid of this problem. I did have to re-install all the software I use, but I kind of wanted to do that anyway to clean up my system. I know this may not be an option for you but it did get rid of the problem I had and my system has been working very well up to now (fingers crossed) and I regularly diphragment and back up my system.
    Best of luck

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...