1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

No sound device

By Rhue ยท 5 replies
Jul 7, 2010
  1. Hello.

    I have a Dell Inspiron 537 desktop that is just a little bit over a year old and I am having problems with my sound. I had picked up some malware but that has been resolved and I had sound after. Four days ago I had sound then later in the day the sound was no longe working. When I bring up Volume contrl it gives me this message There are no active mixer devices available. To install mixer devices go to the controll panel click printer other devices and them click add program. However when i do this all that is there is printer which i do not have. I have spoken with Microsoft and they have done everything they can and still no sound. They ran a dxdiag and it said no sound card available. I then contacted Dell and they were of no help. I was going to reformate my computer but when i went to do that Dell had sent the wrong operating cd and they are telling me they can not send me one because i have a po box for an address.

    When i look under my sound and sudio devices all the drivers are working properly but it tells me no audio device. Under Audio default device there is no playback device no recording device no MIDI playback device.

    I believe that the Plug and Play was deleted from the computer I am not sure if that has anything to do with it or not any help would be greatly appreciated.

    Thanks Rhue

  2. EXCellR8

    EXCellR8 The Conservative Posts: 1,797

    This is a relatively common problem. I believe a malware infection is responsible for corrupting the audio settings and/or registry. Simply removing the infected files typically does not resolve the issue. The easiest method to reverse this is to use System Restore or perform a repair installation of the operating system I've dealt with similar issues before and reinstalling drivers usually doesn't fix it either. If you don't have a restore DVD or OEM disk for the OS, you can borrow one from a friend to perform a repair install, just have your product key handy.
  3. Rhue

    Rhue TS Rookie Topic Starter

    Thank you the repair installation did the trick I now have sound. And a new issue I get a window that says could not load file or assembly sorttbls or one of its dependencies. The sysem can not find the file specified. Would you have any idea what this is? And again my thanks for the help with the sound problems.

  4. EXCellR8

    EXCellR8 The Conservative Posts: 1,797

    when does the message appear? you'll probably need to reinstall the latest service pack depending on what installation disk you used. you should also make sure that all necessary drivers are installed and that you have the .NET Frameworks installed, I can't remember if they are included with the service pack 3.
  5. Rhue

    Rhue TS Rookie Topic Starter

    unable to load sorttbls

    This happens when Windows loads and then at times when I am playing an on line game. I have tried to down load the net frame work 1.1 and the 3.5 but it tells me installation failed. I am not sure what to do to fix this.
  6. EXCellR8

    EXCellR8 The Conservative Posts: 1,797

    Have you tried a system restore by any chance?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...