Numerous Device Manager error 37 codes but tried loads -- any more ideas?

By stucuk ยท 8 replies
Dec 19, 2011
Post New Reply
  1. Folks,

    Son has an Acer Aspire M3910, 6 months old, with Windows 7 Home Premium SP1 64 bit.
    Suddenly following a reboot a number of devices stopped working. Device Manager shows 11 items with a Code 37 error including DVD drive, monitor, LAN / WLAN card, 4 x core Intel i3 CPU's, audio controller, a couple of bus enumerators and a H57 Express Chipset LPC interface controller.
    Have searched through the forums and tried the following:-

    1) Checking for viruses from normal and safe mode using Sophos, MalwareBytes, AdAware and a couple of others - nothing found.
    2) Change the registry to remove Upper and Lower limits to adapter entries.
    3) Replacing the NDIS.SYS file with one from a different machine.
    4) Checking version and size of above, are correct.
    5) Reinstalling drivers from the inbuilt eRecovery tool.
    6) Downloading new drivers from the supplier and installing them.
    7) Rolled back to previous restore point.
    8) Tried sfc /scannow at command prompt - nothing found.

    All the above have made no difference whatsoever. I really don't want to rebuild the machine if I can help it but I as running out of ideas. Would be grateful for any others.

    Many thanks, Stu ...
  2. odriscoll27

    odriscoll27 TS Rookie Posts: 66

    Various Solutions to Code 37

    Hi stucuk welcome to TS

    ok you could try the following steps to update your drivers
    Open Control Panel and select System.
    In the System Properties dialog box, select Hardware tab, and then click on the Device Manager tab.
    Scroll down the Device Manager window and identify the faulty hardware from the list.
    Right-click on the hardware and select Update Driver.
    Follow the screen instructions to resolve the error.​

    however i DID manage to find the following solution online once when i had an issue with my DVD Driveand Monitor with "Code 37"

    FIRST: - Make sure you back up your Registry or Create a System restore point. Messing with the registry can be a pain of you get it wrong. in order to back it up when you go to "Start - Run - Regedit". When Regedit is openm click on the file menu and backup. i recomment backing it up to an external device such as a hard drive or a USB Drive.

    Start Regedit (Start - Run - Regedit) Then this folder: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\(4D36E965-E325-11CE-BFC1-08002BE10318)
    In this key the key folder "UpperFilters and LowerFilters" delete. System restart

    hopefully this MAY help

  3. stucuk

    stucuk TS Rookie Topic Starter

    Hi James,

    Thnks for the reply but, unfortunately, I've already tried both those. Any more suggestions? Thanks.

    Stu ...
  4. odriscoll27

    odriscoll27 TS Rookie Posts: 66

    hmmm unfortunalty im a bit stumped.
    have their been any hardware chanegs recently i.e. new HDD etc?
    What were yhu doing prior to the reboot of the PC when yhu got these codes?

    also is the hardware detected in the BIOS?

    I know yhu have tried this but did yhu get the drivers from here? the link below should provide yhu with the drivers Specific to yhur PC.

  5. stucuk

    stucuk TS Rookie Topic Starter

    Hi James,
    No, nothing has changed hardware wise for months unfortunately, since I initially put it together. I did get one suggestion on another forum it could be the memory so I shall try that one although I struggle a bit to see how.
    Prior to the reboot there were some updates from Microsoft which asked for the reboot - but I rolled back to before these and it made no difference.
    There doesn't appear to be anything missing in the BIOS either, specifically the 'easy' ones, the DVD drive and LAN card, which makes me think if it was a hardware issue then why are they still detected there??
    I,as you, am somewhat stumped! But thanks for the suggestions.
    Stu ...
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Right click Computer->Manage->Services and Applications->Services

    Scroll to Plug and Play. Is status= Started and StartupType=Automatic?
  7. Professor XP

    Professor XP TS Rookie


    Did you update the computer before you rebooted it? maybe you have to rollback the drivers or the updates.
  8. stucuk

    stucuk TS Rookie Topic Starter

    Thanks for the replies -

    LookinAround - checked that and, yes, Plug and Play is set to Automatic.

    Professor XP - We did some Windows update not long before but rolled back those and it made no difference I'm afraid.

    Any other ideas?
    Thanks, Stu ...
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Did you also check Status??? The PnP service Status must = Started. If Status is blank, plug and play device installs won't work

    Though if the plug and play service StartupType= Automatic but it's stopped you may need to reinstall anyway cuz something is very corrupt

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...