Nvidia drivers/graphics issue

By Bluemouse ยท 10 replies
Sep 28, 2006
  1. Nvidia issue - Diagonal line

    Hi, I have a toshiba M30 Laptop with a Geforce 5200FX go graphics card (yea, i know, it sucks).

    Since Toshiba/Nvidia dont make updated drivers for me, i had to modify the INF file of the Nvidia forceware drivers to get them to install. It was all working fine until I reinstalled the drivers, and now I get this diagonal line sometimes coming across the screen (top left -> bottom right) when I play movies. It almost looks like the two triangles of my screen are rendering at different times or something.

    When I use the OLD (original) drivers that came with my laptop they work fine, but now with the forceware drivers it doesnt work, and I have no idea what is causing it? Some setting? They worked before, and I am trying to use the same version again.

    What would cause that Diagonal line? Any idea what I can do aside from using the original drivers? (Forceware is much better)

  2. Gosugod

    Gosugod TS Rookie Posts: 40

    If you right click your desktop and go to properties Settings Advanced monitor you can configure the refresh rate of the graphics card. Generally when things on your screen flicker or create random objects it's either your color resolution or your refresh rate. Hopefully that works. You can always do a driver rollback under device manager and go back to the original settings.
  3. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Yea, I went back to the original drivers, as they seem to be the only ones that work now :S Unfortunately, they suck :)

    How do I modify the rendering or something? Thats what it seems to be. I tried the refresh rate and increased it, but it didnt do anything. Didnt try the colour resolution yet.

    I noticed that it is mainly when there are flashes on the screen (like white flashes before flashbacks or something), but I cant figure it out. It worked before....
  4. Gosugod

    Gosugod TS Rookie Posts: 40

    Does this occur when the operating system has been loaded? When does it occur? Gosh, I've been researching stuff on google to figure it out. So far the only advice I could give is: if it ain't broke, don't fix it. I'll continue to look into it though. I would make sure there is a driver signing on the specific driver you're trying to install. This is just an indication that microsoft has digitially signed the driver stating it works great. If you type dxdiag in the RUN command you can run video tests with your graphics card. You can always produce a copy of information on the files/driver information. Ugh anything so far?
  5. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    The Forceware drivers are not meant for a Go series graphics card. That's the main cause of ur problems. And FYI, NVIDIA never releases drivers for GeForce Go models (except for higher end ones such as the Go 7800 etc).
  6. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Correction, they are not meant for the go series. Before I had uninstalled/reinstalled, it all worked fine, even with the forceware drivers. I was trying to figure out why it doesnt work now, when it was working fine before

    It occurs when I am playing a movie (avi) in a bunch of different players (MPC and VLC included). I havent tried playing a game yet, but I could only assume it would do the same in that. When I install the "modified" forceware (ie, i have to change the inf file because its not "meant" for my graphics card although it did work before), it says that it isnt digitally signed, which is the same as it did when I installed last time except that it actually worked last time :)
  7. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195


    I installed the new drivers again, same issue. However, i found that if I enable Keystone, the diagonal line disappears. The only disadvantage is that it is choppy playing.

    Any ideas?
  8. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    anyone have any ideas?
  9. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Why do u want to use the latest edition of the Forceware drivers? I doubt it would make any difference on ur laptop. Why not try an older one, such as 91.31 or an ever older version? U will find them on NVIDIA's site.
  10. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    ive tried a bunch of them now

    91.31, 81.25, 81.21.......all the same problem, and only since i reinstalled...
  11. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Try using Driver Cleaner Pro to completely uninstall the drivers in safe mode and install them again. I dunno if it will work on a laptop though. Give it a try.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...