One of two partitions detected, hard drive itself is not

By Niccolo ยท 12 replies
Nov 4, 2010
Post New Reply
  1. My computer has three physical hard drives in it, one of which is a 1TB Seagate. Naturally, I have a hilarious problem involving my Seagate Barracuda 1TB hard drive.

    It's a couple of years old and has functioned faithfully for all of that time as a storage device. It had two partitions on it; K and M. (If it helps, I made M first)

    1) A week ago I noticed that I could not access the M partition, but I could access the K partition.

    2) The hard drive itself (that K and M are on) is not detected in the BIOS.

    3) My partitioning program seems to think that my K partition is now physically present on one of the other hard drives.

    Solutions tried:
    1) Swapped around SATA cables (Though I never expected this to work)

    2) Run various partition recovery programs - this failed at the step of "choose the hard drive to recover the partition from" since the hard drive is, well, not actually detected.

    3) Panicked.

    I haven't tried the whole "Put hard drive in a freezer" trick, since I don't know if that's entirely applicable. Is it?

    I don't really have a lot of technical knowledge; most of what I know I've picked up by experimenting... I've read lots of other sites about missing partitions and stuff and they all talked about physical and logical drives, slaving, and a bazer's dozen other terms which I don't actually know about...

    So please offer advice in reasonable layman's terms, please. Thank you kindly!
  2. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    Did it start just doing this on it's own?...Or maybe you installed something or fiddled around with disk manager?

    It could have somthing to do with the fact that when you created the M partition, the system made it 'Active' (basicly meaning that this is the daddy ..or if you boot from your drive this is where it will look first for your OS)..Now when you created the K partition the system may have made that 'Active' instead and cancled out M (probably did i'm thinking).

    Your HDD not showing up in your BIOS either means that..You have a dodgy lead, Its taking up the same slot as somthing else.. or the drive is broken (There may be other possible reasons that i can't see from here)

    For example on taking the same slot:

    WD 500 Gig: Set to Primary Master in BIOS (First boot drive) !!!!Seagate 1TB: Set to primary Master in BIOS!!!! (this won't work right)
    WD 250 Gig: Set to Secondary Master in BIOS (Second boot Drive in line)

    Liteon DVD-RW: Set to Primary Slave in BIOS (Third Boot Drive in line) (Slaves are normally for cd drives but you can have HDDs if you like)

    Liteon DVD-ROM: Set to secondary Slave (Fourth Boot Drive In Line)

    Only 1 drive per time can be set to these, so if your Seagate is in that position it won't work.
    Maybe you could try taking out your HDD and trying in as an external...that way you wont conflict in the bios(or shouldn't do)

    Oh and to change a drive from 'Slave' to 'Master'..Its done by a 'Jumper' (or little plastic thing on the back of yor HD)...If you have a look , it should give you some idea as to where the 'Jumper' is put in order to class the HDD as either 'Master' or 'Slave'.

    Hope this helped Niccolo
  3. Niccolo

    Niccolo TS Rookie Topic Starter

    Thanks Benny, I'll look into the BIOS thing...

    However, I don't think it has anything to do with my creation of the K drive; I created K several weeks ago (a month, maybe a month and a half)

    The M partition only vanished a few days ago - and I know that I've set my computer to boot up first from a separate hard drive altogether - and it has done so and continues to do so.

    It's also not a lead problem - that was the first thing I thought of and so I switched cables and SATA slots to no avail.

    Which leaves it as... It's set to the same slot as something else. Hm. That has possibilities... I'll look into that.

    The really perplexing part is that the whole hard drive itself has vanished utterly, but one of the partitions on the same hard drive is still located by the computer - and is listed as coming from a third hard drive.
  4. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    That does sound strange..I suppose if it was working before then something must have happened on the computer its self...Like: Maybe you installed something and its messed around with disk manager, or you might have picked up a virus or something (theres alot of stuff around that will mess with disk manager and the like), or maybe the jumper on your HDD has come loose inside the computer (it's never happened to me, but it could i suppose) and if the jumper has come loose, then thats all it takes to turn your HDD from Master to Slave, and hence 'taking up two slots'.

    If this happened to me and there was no obvious way of fixing it.. i suppose ide either try it external or install a new fresh OS (brand new disk manager should work) or if that fails, completely format it, give it a 100% partition only, and then see if the bios takes it. if it did, ide then go back to splitting it and whatever.

    Obviously you'de need somewhere to offload your data if you tried that though, and if you can't reach your data on M partition..then ide find another computer to try and get it off with.
  5. Niccolo

    Niccolo TS Rookie Topic Starter

    Yeah, I thought about that... I'll have to get it in another computer to format the thing

    Thanks, I'll try that method.
  6. hughva

    hughva TS Rookie Posts: 58

    Maybe this is simple.
    Your drive has died, and Windows has automatically assigned that letter to the next available device.
    As the drive itself is not found, I'd say this is the problem.
  7. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    @ hughva

    Niccolo said that the drive has 2 partitions K and M...M has stopped but K still works, so the drive must be working (unless i'm missing something here)

    I've had the same old 5 HDDs for nearly 8 years now, and not once has one stopped working on it's own...Maybe these new TB drives and others are not as reliable or something.

    Just like the saying "They don't make'em like they used to".
  8. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    The impression I got reading Hugh's posts, were that:

    The Seagate 1TB has failed, and the drive letters have been re-assigned to another hard drive. e.g. K & M were the 1TB partitions, but it is now K only, and there is no M. K is now another drive, not the original one due to being re-assigned a new drive letter automatically.

    That would make sense. I find it hard to understand why BIOS no longer recognises the HDD, but one of the paritions still work. BIOS isn't looking for the partitions, its looking for the entire physical drive. If its not finding it, something is seriously wrong (assuming its not just a faulty lead).

    My thoughts:

    In this instance, the first thing I would do is run with only the 1TB connected (or if the OS in on another drive, just the OS drive and 1TB connected). Once loaded up, I would head to disk management, and see what its listing there. I would also swap out both SATA data connectors, and use replacements I know to be working. The same with the power connectors (or at very least swap them from another drive working).

    The fact BIOS does not recognise the hard disk makes me believe its failed if the above isn't the reason for it not showing up.
  9. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    what i was thinking was:

    niccolo had some specific data on K and some specific data on M.

    niccolo found that the data on K was still available...and the data on M had gone walkies somewhere

    It was my thought that niccolo had searched for the M data in all his other drives and didn't find M and it's data had gone missing and K with all it's data was fine and accessible (K & M are on the same drive)

    So thats why i thought in that way...i know what you're saying Leeky about the system reassigning the letters though.
  10. Niccolo

    Niccolo TS Rookie Topic Starter

    Benny has the right of it. The data of M drive has gone totally walkabout, but everything that was on K drive (The other part of the 1TB drive) is usable and in perfect order.

    That was one of the first things I checked - the things on my K drive were keys to a password-locked vault and a corruption in one of the files would be... well, not good.

    I've seen some odd computer issues (An old laptop I had a long time ago would spontaneously uninstall its sound drivers) but nothing quite like this.
  11. tipstir

    tipstir TS Ambassador Posts: 2,472   +126

    You can assign the letter in the Os. But older drive would be the one with the Os on it. This the way I did it and it worked with 5x / 3x ultra 133 with 1x sata.

    Sent from my Android ePad Tablet!
  12. Niccolo

    Niccolo TS Rookie Topic Starter

    Welp, time to pack it in.

    I tested my 1TB as an external... it's borked. I should have tested that first, I guess. Oh well, I've recovered what I needed to.

    That's a real nuisance. I think it's just outside warranty, as well. Funny how it's always like that.
  13. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    At least you got to the bottom of it anyway..I can't understand how K partition still worked if the drive was knacked though.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...