OS Loader dying on Windows 8.1 EFI install

By Razer# ยท 9 replies
Feb 13, 2014
Post New Reply
  1. Hey guys!

    Signed up here as I am at a complete loss on what to do with my Win 8.1 install.
    Like I said in the title, I am having issues with Windows 8.1 on my gaming PC. Every so often, I'll restart the machine and poof the OS Loaded is gone.

    This will be the 3rd time this has happened now. Each of the other times I have had to start with a fresh install of windows and had to copy my 3.5TB back up back to the main RAID 0.

    Before I have tried using many of the Windows tools to fix or rebuild the boot but each time I end up being unsuccessful. I have played around a lot with BCDedit, BCDrec, and trying to make new BCD stores from scratch. I have double checked the file system integrity and verified that both drives in my raid are good. The bcdedit command gives what appears to be a functional boot loader as there are no unknown variables and the guid strings are matching up in the right areas. In the SRT log it lists the error as the OS Loader cannot be found.

    Its a long shot, but I am hoping with some of your help we can fight through this issue. From my searches it seems this problem is pretty wide spread so if we can find a solution hopefully we can help all the other experiencing similar issues.

    Thanks in advance!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Do you mean a UEFI install?... (Unified Extensible Firmware Interface) is a standard firmware interface for PCs, designed to replace BIOS (basic input/output system) " my gaming PC" what are the complete specs?
  3. Razer#

    Razer# TS Rookie Topic Starter

    Yes, its a UEFI install.

    Here are full specs:
    Core i5 3570k
    Asus p8z77 WS
    16GB Crucial DDR3-1600MHz RAM
    Gigabyte GTX 670
    Asus pce-ac66 network card
    2x2TB Seagate HDDs in RAID 0 - fully tested in and out of RAID.
    Corsair AX760i PSU.
    Windows 8.1 Pro.

    Like I said, this is a reoccurring issue even with multiple clean installs of Windows 8.1 Pro. Basically it will work fine and even restart and boot fine the first few days. Then after a week or 2, I am greeted with this:

    Automatic Repair

    Automatic Repair couldn't repair your PC...

    I have checked the SrtTrail.txt log, it goes through several tests, then when it gets to "System boot log diagnosis", its says:

    Root cause found:
    Boot manager failed to find OS Loader
    Repair Action: file repair
    Result: Failed. Error Code 0xa
    Time taken: 2656 ms

    Repair action: Boot configuration data store repair
    Result: Failed. Error Code = 0x490
    Time taken: 219ms
  4. Razer#

    Razer# TS Rookie Topic Starter

  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Have you tried using just 1-2TB drive? I have 3-500GB drives in a RAID0 array producing a 1.3TB array split into two 698GB partitions. UEFI bios also. Dual install Windows 7 pro on one partition and Windows 8.1 Enterprise on the other partition. Is the bios fully updated?
  6. Razer#

    Razer# TS Rookie Topic Starter

    I have not tried installing on a single drive. However, I have run a SMART test, as well as the Seagate tools bench mark on each of the drives individually. Both pass. The reason for the large raid is this computer is not only my gaming rig, but my media server as well.

    Bios is fully updated to 3505.
  7. Razer#

    Razer# TS Rookie Topic Starter

    Made a small realization.
    I noticed the "resume object" GUID suggests that windows is trying to boot from a hibernate file, despite the fact I actually restarted the computer. Would it be possible to use bcdedit to change that resumeobject guid to the one that points to the standard winload.efi?
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes, you could try that...
  9. Razer#

    Razer# TS Rookie Topic Starter

    Well just learned something important. ASUS has a feature called CSM, which is used to provide support for HW that doesnt fully support UEFI. Apparently this causes a compatibility issue with Secure Boot and will not let you load windows.

    I am now successfully booted up!
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Good ol' ASUS... A brand I stay away from with a passion...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...