PC Vice City Install Problems!!!

By AyWoe ยท 17 replies
Jul 29, 2003
  1. I just tried to install Vice City for PC, and when it is all done and all restarted, and I go to play the game, it can't start.

    First a pop up comes up and says, "C:\Program Files\Rockstar Games\Grand Theft Auto Vice City\gta-vc.exe A device attached to the system is not functioning."

    Then I hit OK, which is the only button there, and another pop up comes up titled Error Starting Program.

    It says,"The D3D8.DLL file is linked to missing export DDRAW.DLL:DdEntry18."

    And then there is an OK button. I click it and I get nowhere, i'm back to my desktop, doing NOTHING fun.

    If ANYONE has had this problem or hasn't but knows how to fix it, PLEASE let me know!!!!

    Thank you
  2. AyWoe

    AyWoe TS Rookie Topic Starter

    BUMP! Come on someone, anybody....I need help
  3. geezaboy

    geezaboy TS Rookie

  4. geezaboy

    geezaboy TS Rookie

    Having looked into this a bit more it sounds like you've got directx problems! You can check this out my going to Start > Run and typing dxdiag and clicking ok! You can then check version and run some diagnostics!! You must have Direct X version 9 or maybe 9.1 - whatever the latest version is! Its available from www.microsoft.com.directx

    Good luck as its an awesome game!!
  5. LiViN_LeGenD08

    LiViN_LeGenD08 TS Rookie

    Yah most people I've heard that had that problem it had to do with the direct X, which 9.0 is needed for that game. D3D8.DLL is a direct X file so my guess is that's your problem.
  6. AyWoe

    AyWoe TS Rookie Topic Starter

    Thanks guys for your input, I'll check it out! Oh and that smiley was an accident : and D make that, but it is supposed to actually be a : then a D. :)
  7. geezaboy

    geezaboy TS Rookie

  8. AyWoe

    AyWoe TS Rookie Topic Starter

    Okay guys I realized my REAL Problem. When I install DirectX 9.0 it makes you restart your computer naturally. But when it is restarted 9.0 is not there and my old one is still there.

    Any more suggestions?
  9. geezaboy

    geezaboy TS Rookie

    What is the old version you are running? Also what OS are you running?
  10. LNCPapa

    LNCPapa TS Special Forces Posts: 4,274   +461

    I had a similar problem once - which kept me from playing AC2 till I fixed it. I ended up having to download the network installer for DirectX 9.0a and installing that - see if you can find one for 9.0b and try that - hope it takes care of your problem also.

  11. AyWoe

    AyWoe TS Rookie Topic Starter

    I will try your suggestion out. And the version I have now is
  12. HackySack5600

    HackySack5600 TS Rookie

    Hey,I tried to install mine and it says: Cannot start program because of a missing .DLL file DINPUT8.DLL. Any Suggestions? I downloaded that file from a site and the application GTA VC still wont run. I am very frusterated. Please help :)
  13. Bryan_lendering

    Bryan_lendering TS Rookie

    Please send me an e-mail so i can install it please
  14. Bryan_lendering

    Bryan_lendering TS Rookie

    hey aywoe

    please show me how i should install the game or what should i do with the D3D8.dll file in vice city please send me an email at : bryan_lendering@hotmail.com
    please help me

    Bryan Lendering.
  15. kraftdinner123

    kraftdinner123 TS Rookie

    GTA vice city

    when i install the game i was very happy :)

    then i put the no cd crack... :rolleyes:

    and it says that i still need the cd :eek:

    can someone help me ? :(

    i really want to tried out the game :angel:

    plz send your answer to "darkhole200@hotmail.com" :D
  16. l33t_tek

    l33t_tek TS Rookie Posts: 19

    I guess the crack you used was hopeless then. Try putting in the play CD and see if the game boots up. If you're not satisfied with that, go to www.megagames.com and get the Vice City crack there. I know it works because that's where I got mine and I don't need the CD to run. Good luck
  17. N1Hawk

    N1Hawk TS Rookie Posts: 222


    Is the copy of vice city a cd copy or a cracked copy?
  18. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    alexaaa: Techspot does not condone any form of piracy.

    I am therefore deleting your posts and closing this thread.


    Regards Howard TS Moderator.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...