Please help - RE Windows XP PRO reinstall problem

By anthonyv ยท 6 replies
Jan 26, 2005
  1. hi there, any help would be much appreciated as i'm stuck, a designer, have all my data on my hard drive and cannot afford to lose it :(

    ok situation is as follows:

    my pc was running windows XP Home..

    i have installed windows xp pro on many systems without a problem.
    i attempted to use my windows CD to upgrade to xp pro, and this was going well.

    during the copying of files in setup, the system restarted due to a problem, hardware problem of some sort.
    after this, the system would not continue setup and as my xp cd is not bootable, i cannot boot with the disc and restart setup.

    i do not have a floppy disk on my pc, and therefore cannot run setup.

    all my files are on my hard drive, i know this as i used a "DRDOS" boot disk i had to get to command prompt and then changed to c:\ and all my files are there as they were when pc was running fine.

    so, basically, if i turn my system on, it boots up as it should, and you see the windows xp logo during boot, then it loads to the point where you would normally see the xp login screen, but rather that showing this it just shows the mouse cursor and a black background, due to the incomplete setup.

    i'm assuming i need a windows xp install cd that is bootable, to be able to run setup from when i start my system up with the cd in the drive, and then i can continue with setup again.

    my question is, how do i go about this?

    - can i make a copy of my xp cd, and make it a bootable one? if so, how?
    - i have 2 cd rom drives on my system, is there a premade boot cd i can download? - though i tried, once at a command prompt, to run setup.exe from windows cd and it "cannot run in dos".

    any help would be much appreciated.

    i am trying to get around this without having to find a way to backup my 40gb of data, reformat totally, then copy my files back!

    i've heard that i can copy my xp cd to my hard drive, then burn to a cd using nero to make it bootable? but will this work?


    oh, one more thing, i tried using "bart's" boot disk guid but that wouldn't work...? i couldn't get it to build the iso file...
  2. hp_compaq_tech

    hp_compaq_tech TS Rookie

    Question: Does the mouse move when Windows loads to the black screen?
    -Yes, try opening the windows task manager (CTRL+SHIFT+ESC). If that works: File, New Task, 'explorer' Should load the taskbar/icons. Which will allow you to backup the data onto CD, then it would be time to look at formatting the drive and reinstalling XP Home.
    -No, press F8 at boot and out of the 'Windows Advanced Options' menu, try selecting 'Safe Mode'. (note: the administrator account will appear here and should not have a password.. I'd recommend to use it).
    -If No to Safe Mode, I hope you have the XP Home CD to run recovery console.. but even this is hit and miss.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If you have a FAT32 partition, things are quite simple:

    Just download a bootable DOS CD that has a cd-rom driver, copy 'I386' directory from XP CD to hard disk drive, and run i386\winnt.exe. (As a matter of fact copying setup files to hdd isn't mandatory, just faster and simpler for the future)

    If the partitions are NTFS, I'm not sure if XP can write the temporary files to them before the actual setup starts.
  4. anthonyv

    anthonyv TS Rookie Topic Starter

    ok, thanks for the help so far...

    the mouse does move when windows loads, just a black screen tho..
    it does say this at the bottom right side of the screen:

    Windows XP 2600

    task manager won't launch.. you cannot do anything besides move the mouse.

    i don't have an xp home CD :( only pro, and safe mode runs, but does the same thing!

    i'm not sure if its NTFS of FAT32, but i will check, hopefully it is FAT32 and i can copy the I386 folder! - one question though, in dos, how do you cop a whole folder from CD to HDD?
    i'm aware of the command for example: "copy *.* [location]", but this doesn't copy subfolders, i don't know the command(s) to copy a folder and its complete contents.

    Appreciate your help.

  5. patio

    patio TS Guru Posts: 482

    Chances are if you were able to see the files with Dr. Dos you have a FAT 32 file system.
    Unless you have installed the NTFS driver for Dr. Dos which is fairly recent you are running FAT 32.

    patio. :cool:
  6. anthonyv

    anthonyv TS Rookie Topic Starter

    ok sorted the problem, ended up formatting and reinstalling windows.

    but, i have a final problem and its a big one.

    windows loads up fine, all is good, however, if any USB devices are plugged inb, then instead of loading windows, it gets to the point where it would usually show the login screen, and then it will flash a split second of a blue screen and then restarts.

    the only way to stop this is to uninstall any usb devices (i.e., my wireless network card) and then its all fine.

    i did this (uninstalled it) and restarted, the system loaded fine,. and then i decided to try again, by plugging in the usb wireless adaptor, waiting for the "new device found" dialog to pop up, and browsing for the driver.
    the driver installed fine, and a split second after the hardware was "ready for use", the system restarted.

    any ideas what this is all about?

    the weird thing is that there was never a problem with the USB devices before i reinstalled XP.

    the drivers for my usb wireless adaptor is fine, is xp compatible, and i know this, because i've used it on my system before, and on other XP systems without problems.

    Just, on my system, since the reformat and reinstall of windows, any USB devices plugged in cause the system to reboot.

    Please note:
    when the system does this restarting business, it flashes a blue screen for a split second. this is the blue screen that mentions that windows had an error and the system has been shut down etc etc.

    any help would be much appreciated.

    this is the worst problem i could probably have, as i'm a web developer, and i need access to the net, which is usually over my wireless network, which is based on a wireless USB network adaptor.

  7. anthonyv

    anthonyv TS Rookie Topic Starter

    ok, i'd like to thank everyone for their help on the problems i encountered, as discussed in this thread.

    I discovered that my problem was with regards to the drivers of the wireless adaptor, rather than with regards to usb devices in general.

    My network adaptor, the Netgear MA111 was supplied with drivers version 1.1 on a CD.
    Netgear have just released vbersion 2.5 of the drivers, which "solve the problem with Service Pack 2", so having downloaded these, my problem has vanished.

    Once again, thankyou all for your help and support, this was much appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...