Printing fails from MS Word

By Doug8765 ยท 10 replies
May 5, 2013
Post New Reply
  1. Hi -
    Printing works for me when I print what's in the browser. What's weird (and the pinprick that got me to ask this question here) is that a document in Microsoft Word goes through all the motions of printing (Print Preview shows correctly, the printer warms up and spits out a sheet of paper) but all I get is a blank piece of paper. This is MS Word 2007, on Windows 7, and I've been using it for Win 7 was released.

    One extra wrinkle is that Excel 2007 also won't print, but it won't even find the printer and do anything.

  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, It sounds as if your printer is 'seen' by Windows, and works with some software (Browser), so I would be looking in the MS Word (and Excel) printer options.
    That's in 'File' , 'Print' and then in the 'Printer' option, make sure your Printer is selected.
    Would be interesting to know if it did print from 'Word' in the past, but now does not.
    A common problem here is the printer driver software has not yet been updated for Windows 7 (or 8), unless you have proven otherwise.
  3. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Mike1959 -
    Yes, I've been using this printer for years on this computer with no known OS change.
    • Print works from IE.
    • Print does not work for FireFox. When I try it for FF it comes up with "An unknown error occurred while printing."
    • When I try printing something simple in Chrome I get an unending "Loading preview...".
    • In Excel I get - as soon as I select Print ( Print | Print, Print | Quick Print, or Print | Print Preview) from the menu (I don't get as far as having the regular Print dialogue) - "Current printer is unavailable. Select another printer."
    I do all the regular updates, so I don't see why that would be a problem.

  4. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi again -
    FWIW, I used the install disk and did a repair. Still no printing.

  5. jobeard

    jobeard TS Ambassador Posts: 11,132   +983

    Test the printer using NOTEPAD. If that works, it's not the print driver.

    Typical print issues with Office Software is the print settings within the program (not the driver settings).
  6. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,922   +630

    Go File > Print. Maybe you aren't using the correct one?

    Also go to: Start > Devices & Printers. Make sure the correct printer is set as default. If not, right-click > Set as Default.
  7. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, As mentioned, if you can print text from 'Notepad' then the driver is probably ok.
    Fault is much more likely to be in the Word & Excel program settings, e.g. the printer set as the 'default', as long as it is the 'default' in 'Hardware'/'Devices' also.
    If all else fails, (if it was mine) I would 'remove' the printer from 'Devices' , pull the printer cable, reboot pc, and attach printer again, force Windows to sort it out from a new start.
  8. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Jobeard -
    I successfully printed with Notepad.

    Next is to try Mike1959's suggestion that I detach the printer and reattach.

  9. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Mike1959 -
    Your suggestion worked. I removed the printer from my list of printers, unplugged the printer, rebooted the computer, plugged the printer back in and it searched for the printer in archives.

    Now the printer works in MS Word, in Excel and in Firefox.

    Not that this is a problem, because it is not, but whenever I print I get an alert from Comodo, which I allow every time. I've attached an example.

    Thanks Mike1959 and Jobeard.


    Attached Files:

  10. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, A quick search shows the zshp1020 alert appears to do with the Laserjet 1020, so Comodo is just warning that the printer software is about to access the Windows printer spooler.
    You can either click on the 'Allow', OR click on the 'remember my answer' box, so it won't keep on reminding you. Guess it depends on how much it bothers you.
    But good to hear it all works.
  11. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Mike1959 -
    Guess I did not notice that "remember my answer" box. Thanks for that as well as the rest of your help.


Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...